PDA

View Full Version : ATI driver install issue (libstdc missing)


jdvuyk
14th April 2005, 12:07 AM
Hello,

After messing around with my fedora installation to get it setup and running ok I have come accross a problem while having a go installing the latest ATI driver via Livna. I did a "yum update" before running the following command:

[root@localhost ~]# yum install ati-fglrx kernel-module-fglrx
Setting up Install Process
Setting up Repos
livna-stable 100% |=========================| 951 B 00:00
livna-unstable 100% |=========================| 951 B 00:00
livna-testing 100% |=========================| 951 B 00:00
extras 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
livna-stab: ################################################## 155/155
livna-unst: ################################################## 56/56
livna-test: ################################################## 25/25
extras : ################################################## 1083/1083
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-module-fglrx-2.6.10-1.766_FC3.i686 0:8.10.19.1-0.lvn.1.3 set to be installed
---> Package ati-fglrx.i386 0:8.12.10.1-0.lvn.1.3 set to be updated
--> Running transaction check
--> Processing Dependency: libstdc++.so.5(CXXABI_1.2) for package: ati-fglrx
--> Processing Dependency: /boot/vmlinuz-2.6.10-1.766_FC3 for package: kernel-module-fglrx-2.6.10-1.766_FC3
Importing Additional filelist information for dependency resolution
livna-stab: ################################################## 155/155
livna-unst: ################################################## 56/56
livna-test: ################################################## 25/25
extras : ################################################## 1083/1083
--> Processing Dependency: libstdc++.so.5(GLIBCPP_3.2) for package: ati-fglrx
--> Processing Dependency: libstdc++.so.5 for package: ati-fglrx
--> Finished Dependency Resolution
Error: Missing Dependency: libstdc++.so.5(CXXABI_1.2) is needed by package ati-fglrx
Error: Missing Dependency: /boot/vmlinuz-2.6.10-1.766_FC3 is needed by package kernel-module-fglrx-2.6.10-1.766_FC3
Error: Missing Dependency: libstdc++.so.5(GLIBCPP_3.2) is needed by package ati-fglrx
Error: Missing Dependency: libstdc++.so.5 is needed by package ati-fglrx

It seems that there is something wrong with libstdc++. How the heck can I resolve this problem and install the ATI drivers? Machine seems to be running fine aside from this. All help appreciated. Cheers.

machine:
AMD 2500+(m)
A7N8X-E Deluxe
Radeon 9800 Pro

flatproject
14th April 2005, 12:34 AM
Did you try installing the libstdc++ manually? yum install libstdc++

jdvuyk
14th April 2005, 11:26 AM
yes, i tried that and it just responds with a message that says it cant find the package. I tried both yum and apt to get this reinstalled and both just cant find a suitable package. Any other ideas?

Shouldnt yum try to resolve these problems anyway? The reason that it bails out is that it cant find a suitable package. Therefor a "yum install libstdc++" shouldnt achive much as its already automatically tried that.

This is a serious pain. Can I install it using any other method?

Cheers

rae
14th April 2005, 11:43 AM
I believe you need the compat-libstdc++ package

rae

jdvuyk
14th April 2005, 11:51 AM
I believe you need the compat-libstdc++ package

rae


Yeah, I saw that in another post. I tried a "yum install compat-libstdc++" (and a few other permutations of that file name) and again nothing was installed.

What repos should I have for this? On just looking at my own post it appears that I only have the livna repos available. Is this enough or should I have another repo setup for this package? if so, which repo?

Cheers for all responses.

rae
14th April 2005, 03:49 PM
I beleive that the only one you really need is the fedora.repo file under your /etc/yum.repos.d directory. That should have been enabled on your first set of updates. If you haven't updated yet do that and then run 'yum install compat-libstc++'.

rae

flatproject
14th April 2005, 05:04 PM
I would suggest, to configure your yum.conf as described in http://www.fedorafaq.org

After you configure it as described there, try to run the yum install packagename again!

It should work

Avoca Handweavers Travel Photos on Instagram - Terminus Hotel Travel Photos on Instagram