PDA

View Full Version : fc2 won't boot laptop with no floppy drive


theshowmecanuck
1st June 2004, 10:05 AM
A fresh install of FC2 hangs on boot.

It is on an HP Pavilion zv5034us laptop. This laptop does not have a floppy drive. It is dual booted with Windows XP.

The boot commands are:

root (hd0,1)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb
initrd /initrd-2.6.5.1.358.imp

It gets part way through the booting process then stops at this message:

modprobe:FATAL: Error inserting floppy (/lib/modules/2.6.5-1.358/kernel/drivers/block/floppy.ko): No such device

Can anyone give me a suggestion on how to fix this.

Funny enough, Windows XP has no problem booting after this installation.

theshowmecanuck
3rd June 2004, 04:03 AM
Figured out (guessed) how to start in failsafe mode. Used init level 3.

In the /boot/grub/devices.map (if I remember the filename correctly, but it is close enough) there were two lines only. One for a floppy drive, and one for a hard drive. I commented out the floppy drive line and restarted the laptop. If got to the point with the original error message and skipped over it fine.

However, when it got to the point where the X server was starting, it froze up again. You could see the typical multicoloured hash type of patterns across the top of the screen that you see just before the X server kicks in, and then the screen went blank and that was it... dead.

Like I said, this laptop worked fine with Suse 9.0 (minus sound which would not work, which is why I am wanting to change to another distro), so I don't think it is a problem with the machine's video. Rather, I think it is a problem with the Fedora code or configuration. Just stating the obvious. I would like to see Fedora work on this machine/laptop.

kamina
10th June 2004, 05:53 AM
I'm having this same problem... How can I change the init level to 3?

Finalzone
10th June 2004, 08:01 AM
Go the console mode as root and type "init 3"

theshowmecanuck
10th June 2004, 08:38 PM
If you are trying to boot to run level 3, and you are using grub, do this:

1) When the boot menu comes up highlight the linux menu item you want and press 'e' to edit it (or whatever the letter is to edit... it will telll you below the menu, but I am pretty sure it is e.
2) Go to the second line and press e (it will be the longest line and probably ends with 'rhgb quiet'.
3) At the end of the line type 'init 3'. You can also remove the part that says 'quiet' if you want to see what is happening.
4) Press enter.
5) Press 'b' to boot.
6) When you get frustrated, throw out the CD's you just burned and download Mandrake, or Suse, or Gentoo, or Debian, and install one of them.
7) Leave Fedora alone until Redhat gets their **** together ('cause face it, Redhat is driving this guinea pig factory).

I am trying Mandrake 10 right now. It is working great. As a matter of fact, I am writing this using it right now. Now that they have an easy way to reconfigure their security stuff, I have no problem with Mandrake. Suse 9 also is good (but it has reallyreally crappy support... even if you pay for it!). But this is better as it recognizes my touchpad mouse (this is a laptop) and my plugged in optical usb wheel mouse at the same time. Suse 9 did not. The only problem is no sound until I reconfigure ALSA... but I blame that more on the HP laptop having a goofy hardware setup.

If you like Redhat though, try whitebox linux. It is basically the enterprise linux 3 with the redhat logos removed, and no support from redhat. Some Louisiana parish (county) seat wanted to keep redhat, but couldn't afford the new pricing. Redhat let's you get around the per seat license if you remove their logos... which are basically the only closed source thing on the distro. I will try it myself on one of my servers when I get home. Cheers.

liquidlinux
30th April 2005, 10:14 PM
Go into services and turn off Kudzu. Kudzu looks for the floppy drive if its not there it wont look. Mine works but I want to find a way to get the floppy search out of here