PDA

View Full Version : Unable to boot - "cannot open Front File True"


Yora0
4th June 2012, 06:55 PM
When I try to boot, I get the error message "cannot open front file true". When I press the power button, the promt goes through a list of things it checks, then the computer powers down.

The last thing I did was to download the catalyst driver and install it, requiring a reboot.

Anything that can be done to repair that?
I do have a Live USB HD with the same version of Fedora.

Argedion
4th June 2012, 08:28 PM
I do not believe the error has anything to do with your computers ability to boot. I get the same error and my computer boots fine. Seems to me that your having another issue and it could be your driver

Sent from my PC36100 using Tapatalk

Yora0
4th June 2012, 08:42 PM
I'll look into other thing then.

Now, I do have a live usb and through it I can mount the drive that holds the damaged os.
Can I use commands in Konsole to fix things instead of using repair mode? This would have the major advantage that I could also have a web browser open simultaneously and don't have to write down the entire instructions every time I want to try something.
So far I can navigate the directories and even open /etc/default/grub with Kwrite, but I can't save the changes. Is there a way to enable that?

And is there a way to simply restore the original state of the graphics driver that was included in the installation?

sea
4th June 2012, 09:25 PM
Dont use kwrite on system files !!!
That is like opening boot.ini or system32.ini with M$ word...
Use a simple text editor like leafpad or gedit.

Editing system files with krwite, abiword, librewrite... this WILL cause errors on your system.

pikul
5th June 2012, 03:41 PM
I get the same message but my system boots and works fine, i still would like to know what that message means????? anyways, at grub menu just add a number 3 at the end of the kernel line, logon as root and run the xorg -configure command to create a new configuration file.

sea
5th June 2012, 03:53 PM
i get a very smiliar issue after installing another fedora minimal install to another partiton at first boot.
This is caused by a shared /boot and customized grub2 splash screen, using a custom built font.
At least thats the reason on my system.

DBelton
5th June 2012, 05:16 PM
edit your /etc/default/grub file, and on the lie with GRUB_CMDLINE_LINUX there is a parameter that says SYSFONT=True (or it might not even be on there, I forget now)

But just change that to a font that does exist. Previous versions used SYSFONT=latarcyrheb-sun16

Either change True to latarcyrheb-sun16 if the SYSFONT= parameter is already there, or add the complete SYSFONT=latarcyrheb-sun16 parameter if it doesn't exist.

Your GRUB_CMDLINE_LINUX should look similar to this afterwards:
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8

Then run

grub2-mkconfig -o /boot/grub2/grub.cfg

This will get rid of the "cannot open front file true" error message, but not being able to boot is a different problem. The "cannot open front file true" shouldn't keep it from booting.

Yora0
5th June 2012, 09:42 PM
I have the system repaired now, but I also still have that error message. Had indeed nothing to do with the problem at all.
Doesn't seem to cause any actual problems though.

nothing2lose
6th June 2012, 05:22 PM
I have the same problem too.
I can't repair.
I have just installed my fedora 17.

nothing2lose
7th June 2012, 05:05 AM
After i installed new fedora 17. the first time i reboot, it's still message "cannot open font file true" but i can login fedora.
Why does message still?

sentabi
8th June 2012, 07:15 PM
After i installed new fedora 17. the first time i reboot, it's still message "cannot open font file true" but i can login fedora.
Why does message still?

look at post above (http://forums.fedoraforum.org/showpost.php?p=1582163&postcount=7)

JakeR
6th July 2012, 11:29 AM
edit your /etc/default/grub file, and on the lie with GRUB_CMDLINE_LINUX there is a parameter that says SYSFONT=True (or it might not even be on there, I forget now)

But just change that to a font that does exist. Previous versions used SYSFONT=latarcyrheb-sun16

Either change True to latarcyrheb-sun16 if the SYSFONT= parameter is already there, or add the complete SYSFONT=latarcyrheb-sun16 parameter if it doesn't exist.

Your GRUB_CMDLINE_LINUX should look similar to this afterwards:
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8

Then run

grub2-mkconfig -o /boot/grub2/grub.cfg

This will get rid of the "cannot open front file true" error message, but not being able to boot is a different problem. The "cannot open front file true" shouldn't keep it from booting.

Hi

I have this bug (#799401) on a custom livecd.

The problem is solved in this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=dcc9026b9b47e961608 b9a3028f3b9451ae8e0f0

I have anaconda-17.29-1 on my livecd, but the problem still exist? Why?

leprendun
24th July 2012, 07:48 PM
Sea, how did you fix the issue? I'm a linux newbie and having a similar issue.

i get a very smiliar issue after installing another fedora minimal install to another partiton at first boot.
This is caused by a shared /boot and customized grub2 splash screen, using a custom built font.
At least thats the reason on my system.

DBelton
24th July 2012, 09:12 PM
I showed above how to fix the "Can not find font file True" error, but here it is again:

Do all of these commands as root user:


So, first off, edit your /etc/default/grub file and add the follonwing to the GRUB_CMDLINE_LINUX line:

SYSFONT=latarcyrheb-sun16

(latarcyrheb-sun16 was used on previous Fedora versions)

You should now have a line in your /etc/default/grub that looks similar to this:

GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8

Also, you need to change the file /etc/sysconfig/i18n and make the same change there.

This is what your /etc/sysconfig/i18n file should look like once done (assuming you are using US English as your language)

LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"

Once this is done, then you need to rebuild your /boot/grub2/grub.cfg file to for grub to pick up the changes.

grub2-mkconfig -o /boot/grub2/grub.cfg

Now you should not have the error when you boot.

Edit:
Fixed typo

Jamwa
25th July 2012, 07:20 AM
I believe you meant /etc/default/grub and not /etc/defaults/grub

DBelton
25th July 2012, 02:50 PM
I believe you meant /etc/default/grub and not /etc/defaults/grub

You are correct. I made a typo. Thanks for pointing that out :)

I'm going back and fixing it now.

srkamineni
31st July 2012, 03:57 PM
DBelton

This does not fix the issue. I have recently started using fedora and its my first time installing Fedora 17.

I followed exactly the same procedure but doesn't fix the problem. It goes into default mode.

I installed the whole OS once again and after few days my computer froze and I get the same error even though I didn't upgrade. I have done couple of yum updates to get utilities.

I have no idea of how to fix this. I have about 300 gig of video that I converted on that hard disk using handbrake.

Thanks
Raj

nonamedotc
31st July 2012, 04:10 PM
DBelton

This does not fix the issue. I have recently started using fedora and its my first time installing Fedora 17.

I followed exactly the same procedure but doesn't fix the problem. It goes into default mode.

I installed the whole OS once again and after few days my computer froze and I get the same error even though I didn't upgrade. I have done couple of yum updates to get utilities.

I have no idea of how to fix this. I have about 300 gig of video that I converted on that hard disk using handbrake.

Thanks
Raj

What do you mean by default mode? Are you unable to get login screen?

If you are talking about "cannot find font file true" error message, that should in no way hinder the system from booting.

DBelton
31st July 2012, 05:09 PM
True. The "can not find font file True" error will not cause your system to not boot.

Now if you happened to make a typo when you went to fix the problem, it's possible that it would not boot, depending upon what you did.

I would suggest going back and double checking your edits (if you are still getting this same error.)

If you are having a different problem, then I would suggest opening a new thread and providing more information so someone can help you fix it :)

srkamineni
31st July 2012, 05:09 PM
No I am unable to get to the login screen. It goes into console and askme to enter into "system default" or control D to enter default mode. I enter the root password and I get the root shell.

I followed exact the same procedure that DBelton wrote to change the SYSFONT from true to latar***
but it doesn't help me.

I have used SuperGrub2Disk as suggested by some one on this forum but it doesn't fix it

Please help

DBelton
31st July 2012, 05:15 PM
Does it give you any kind of error? A filesystem error that it can't fix automatically will prompt you to enter a shell and fix it manually.

srkamineni
31st July 2012, 05:19 PM
DBelton

No File system errors that I see. But I don't see the Font error message any more. It asks me to enter Control-D or password to enter into default mode.

I saw that True font error before , but it would boot up.

Thanks
Raj

DBelton
31st July 2012, 05:48 PM
Go back and double check what you changed.

Make sure that you changed only the SYSFONT= kernel parameter, and be sure you didn't take out any spaces between parameters, etc...

srkamineni
1st August 2012, 01:41 AM
Hi

Thank you guys. I fixed because I was missing the last quote in i18n file. SYSFONT="latarcyrheb-sun16" fixed it. Then, during the process of debugging this , I removed my external sata drive and ssd drive which were supposed to be mounted on boot. So I had to reconnect or remove the entries in fstab file.


Raj

DBelton
1st August 2012, 04:06 AM
Well, removing a drive that is mounted in /etc/fstab would do it. Especially if you have them set so that the filesystem is checked on boot (very last parameter > 0) That is probably what hung your boot process and dropped you to the rescue shell.

Good to see you found the problem and now have it fixed :)

devart
2nd September 2012, 04:31 AM
Hi there I just wanted to add to this, as Ive racked my brain for a couple hours, then took a drunken nap only to wake up and realise that before I 'yum update'd i was playing around with VirtualBox preferences and I read through some instructions online about adding some 'manual' usbfs mount to share usb access to my virtualboxes. Anyhow...

What happened with me is this, usally my computer is always left on except for system updates. I didnt remember i had altered my /etc/fstab and added these odd line of code, which didnt prevent my system from starting before, but after the update it burped. I never noticed the problem as all the signs online pointed to changing the SYSFONT in the three locations. Which began to confuse me because the third location /boot/grub2/grub.cfg was not present, nor was anything in /boot/ it was actually empty... which i thought was odd.
And so i did a :
whereis grub
and found /etc/grub2.cfg which was bold-red-text file and could not be opened or edited or cp'd.
During my trials I tried creating a custom /boot/grub2 by cp'ing /usr/share/grub - which didnt work.
But after undoing my changes, and keeping the SYSFONT change then noticing the silly usbfs mount i tried to manually create in the /etc/fstab -- it works again. (only about 5 hours down time :))

peace and much love, good luck fellow humans

Bhavnagar Instagram Photos - Naberezhnyye Chelny Photos - Thailand Travel Photos -