PDA

View Full Version : screensaver lock


javiermon
30th March 2012, 12:40 PM
Hi

I've just installed F17 and I see that when I lock the screen the wallpaper shown is fedora's 17 default instead of my own session wallpaper. Any idea how to change this? According to gnome's bugzilla this was changed to prevent showing user's wallpaper which is fine, but I'd rather pick a different wallpaper.

thanks,

sonoran
30th March 2012, 02:50 PM
Just replace the /usr/share/backgrounds/beefy-miracle/default/<your-screen-size>/beefy-miracle.png file with one of your own choosing.

Just to be safe, since control freaks like the fedora/gnome devs are prone to bad practices like hardcoding filenames, I renamed my background to beefy-miracle.png. This worked.

javiermon
30th March 2012, 03:02 PM
Thanks for the workaround, but I would rather see if there's a dconf setting that controls this. Any ideas?

sonoran
30th March 2012, 03:27 PM
a dconf setting that controls this.

User preference? I think where GNOME is concerned that's "looking for love in all the wrong places." :D

I did find a /usr/share/gnome-screensaver/lock-dialogue-system.png file, but it appears to be the old F15 or F16 background, and is only 162k of wasted space in F17.

DBelton
30th March 2012, 08:50 PM
You can change the background for GDM.


su -
(root password)

xhost +SI:localuser:gdm

sudo -u gdm gnome-control-center


Then click on background and set it like you would your regular user.


Edit:

Meant to put that you run the above commands from a terminal window.

Also, exit out of it when finished.

Ita - Udhampur Travel Photos - Zaltbommel Travel Photos