PDA

View Full Version : Fedora 17 on EEE PC 1215N: Sluggish


tkalfaoglu
6th March 2012, 09:19 AM
I just installed fedora 17 alpha from scratch on an EEE PC 1215N (ion2).
It just feels much more sluggish than F15 on the same machine..
I mean, I move the mouse and it pauses. Screen updates are slower, dragging windows takes a while, etc.
The xorg driver is "intel", and the cpuinfo_cur_freq reads 1800000..
Is it the video driver I wonder that makes it feel sluggish?

Actually the whole disk I/O seems more sluggish. I haven't played with hdparm yet.. shall I?

Apart from that, everything seems to work - wireless bluetooth sound, webcam.. etc.

Regards,
-turgut

---------- Post added at 01:19 AM ---------- Previous post was at 12:00 AM ----------

Following further, I see:
[root@tk ~]# hdparm -d /dev/sda
/dev/sda:
HDIO_GET_DMA failed: Inappropriate ioctl for device

# hdparm -T /dev/sda
/dev/sda:
Timing cached reads: 1164 MB in 2.00 seconds = 583.36 MB/sec

leigh123linux
6th March 2012, 09:26 AM
I just installed fedora 17 alpha from scratch on an EEE PC 1215N (ion2).
It just feels much more sluggish than F15 on the same machine..
I mean, I move the mouse and it pauses. Screen updates are slower, dragging windows takes a while, etc.
The xorg driver is "intel", and the cpuinfo_cur_freq reads 1800000..
Is it the video driver I wonder that makes it feel sluggish?

Actually the whole disk I/O seems more sluggish. I haven't played with hdparm yet.. shall I?

Apart from that, everything seems to work - wireless bluetooth sound, webcam.. etc.

Regards,
-turgut

---------- Post added at 01:19 AM ---------- Previous post was at 12:00 AM ----------

Following further, I see:
It's normal for the development kernel to be a lot slower, it has extra debugging enabled.

tox
6th March 2012, 09:29 AM
It's normal for the development kernel to be a lot slower, it has extra debugging enabled.
dunno if they do that in Ubuntu pre-releases ?

tkalfaoglu
6th March 2012, 09:31 AM
Thanks for the replies - any guesses why DMA is disabled altogether?

leigh123linux
6th March 2012, 09:32 AM
dunno if they do that in Ubuntu pre-releases ?
WTF does ubuntu have to do with it :confused:

leigh123linux
6th March 2012, 09:36 AM
Thanks for the replies - any guesses why DMA is disabled altogether?
hdparm doesn't work with scsi devices, all sata drives are seen as scsi devices by the kernel.


[root@main_pc leigh]# hdparm -d /dev/sda

/dev/sda:
HDIO_GET_DMA failed: Inappropriate ioctl for device
[root@main_pc leigh]# cat /etc/fedora-release
Fedora release 16 (Verne)
[root@main_pc leigh]# uname -r
3.2.8-3.fc16.x86_64
[root@main_pc leigh]# hdparm -Tt /dev/sda

/dev/sda:
Timing cached reads: 6872 MB in 2.00 seconds = 3437.63 MB/sec
Timing buffered disk reads: 660 MB in 3.00 seconds = 219.76 MB/sec
[leigh@main_pc ~]$ dmesg |grep DMA
[ 0.000000] DMA 0x00000010 -> 0x00001000
[ 0.000000] DMA32 0x00001000 -> 0x00100000
[ 0.000000] DMA zone: 64 pages used for memmap
[ 0.000000] DMA zone: 5 pages reserved
[ 0.000000] DMA zone: 3906 pages, LIFO batch:0
[ 0.000000] DMA32 zone: 16320 pages used for memmap
[ 0.000000] DMA32 zone: 830768 pages, LIFO batch:31
[ 1.011980] PCI-DMA: Disabling AGP.
[ 1.012084] PCI-DMA: aperture base @ c4000000 size 65536 KB
[ 1.012085] PCI-DMA: using GART IOMMU.
[ 1.012087] PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture
[ 1.141041] ata1: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f100 irq 22
[ 1.141043] ata2: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f180 irq 22
[ 1.141046] ata3: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f200 irq 22
[ 1.141049] ata4: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f280 irq 22
[ 1.141051] ata5: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f300 irq 22
[ 1.141054] ata6: SATA max UDMA/133 abar m1024@0xfe02f000 port 0xfe02f380 irq 22
[ 1.602087] ata4.00: ATAPI: TSSTcorp DVDWBD SH-B123L, SB01, max UDMA/100
[ 1.602185] ata2.00: ATA-8: ST3500418AS, CC38, max UDMA/133
[ 1.602224] ata5.00: ATA-8: ST31000528AS, CC38, max UDMA/133
[ 1.603283] ata4.00: configured for UDMA/100
[ 1.603412] ata2.00: configured for UDMA/133
[ 1.603453] ata5.00: configured for UDMA/133
[ 1.661897] ata1.00: ATA-8: OCZ-VERTEX2, 1.35, max UDMA/133
[ 1.721897] ata1.00: configured for UDMA/133
[ 3.867963] ata7: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfa00 irq 14
[ 3.867965] ata8: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfa08 irq 15
[ 1638.197237] PCI-DMA: Resuming GART IOMMU
[ 1638.197237] PCI-DMA: Restoring GART aperture settings
[ 1638.887987] ata4.00: configured for UDMA/100
[ 1638.966196] ata1.00: configured for UDMA/133
[ 1642.472642] ata2.00: configured for UDMA/133
[ 1645.402354] ata5.00: configured for UDMA/133
[70102.208959] PCI-DMA: Resuming GART IOMMU
[70102.208959] PCI-DMA: Restoring GART aperture settings
[70102.897656] ata4.00: configured for UDMA/100
[70102.974943] ata1.00: configured for UDMA/133
[70106.536053] ata2.00: configured for UDMA/133
[70109.404163] ata5.00: configured for UDMA/133
[133328.162175] PCI-DMA: Resuming GART IOMMU
[133328.162175] PCI-DMA: Restoring GART aperture settings
[133328.855262] ata4.00: configured for UDMA/100
[133328.928317] ata1.00: configured for UDMA/133
[133332.489135] ata2.00: configured for UDMA/133
[133335.347363] ata5.00: configured for UDMA/133
[leigh@main_pc ~]$

tox
6th March 2012, 09:40 AM
WTF does ubuntu have to do with it :confused:
stuffed if i know :p ..but some people that may come from Ubuntu may expect a kernel to be fast. not slow there system to a halt.

fedvasu
6th March 2012, 10:12 AM
stuffed if i know :p ..but some people that may come from Ubuntu may expect a kernel to be fast. not slow there system to a halt.

the kernel used in fedora 17 is an rc3 , f'ing rc3 , cut some slack , by the time f17 hits rc things will be a lot better , ubuntu uses older kernels even for it's pre-releases , now ubuntu 12.04 uses 3.2 stable kernel , ofcourse it is gonna be faster , as leigh pointed out , no debugging options will be enabled in the released(long time ago) 3.2 kernel.

don't expect everything in ubuntu in fedora , if you want performance you are better of stable fedora releases, alpha is well alpha , to test that it boots, crashes less, common issues etc.

fedora itself is bleeding edge , the pre-releases of it are super-bleeding edge , it hurts aww!:D

I suggested you use fedora 16 , a lot more stable and performant.

tkalfaoglu
6th March 2012, 10:20 AM
My dmesg|grep -i DMA is a lot less interesting.. Maybe that's why it feels so sluggish:

[root@tk grub2]# dmesg |grep -i dma
[ 0.000000] DMA 0x00000010 -> 0x00001000
[ 0.000000] DMA32 0x00001000 -> 0x00100000
[ 0.000000] DMA zone: 64 pages used for memmap
[ 0.000000] DMA zone: 5 pages reserved
[ 0.000000] DMA zone: 3914 pages, LIFO batch:0
[ 0.000000] DMA32 zone: 16320 pages used for memmap
[ 0.000000] DMA32 zone: 698016 pages, LIFO batch:31
[ 3.504630] pnp 00:02: [dma 4]
[ 5.984231] DMA-API: preallocated 32768 debug entries
[ 5.984238] DMA-API: debugging enabled by kernel config
[ 5.984263] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 6.711881] ata1: SATA max UDMA/133 abar m1024@0xf5bf7800 port 0xf5bf7900 irq 44
[ 7.536369] ata1.00: ATA-8: ST9500325AS, 0003SDM1, max UDMA/133
[ 7.558002] ata1.00: configured for UDMA/133
[ 12.363303] [TTM] Initializing DMA pool allocator.
[root@tk grub2]#

lsatenstein
10th March 2012, 11:39 PM
I tried Fedora17 alpha on a dual core system, and it was fun to out maneuver the mouse. Yes, Fedora17 is there for us to test and report bugs. (Did not see an entry to explain how to do this reporting), but I did find that there are problems with the video drivers. On my Dual core Samsung laptop (e-380) monitor, with each screen, there are swaths of output that are not painted. Is it due to the optimizing Gcc compiler with which the output was created, or the video driver.

Sigh, I will now wait for F17 Beta.

PaulAlesius
11th March 2012, 12:19 AM
There should be some message at the beginning of pre-release installations to warn people of the performance impact from debug builds. I've created a bug for this: https://bugzilla.redhat.com/show_bug.cgi?id=802091

Fenrin
11th March 2012, 12:57 AM
if it's more sluggish than usual, you could also check if a swap partition is used:
swapon -s

If the list is empty, you should turn your swap partition on.

On my system I don't have any sluggishness issues: 2 GB RAM, Radeon 3200 IGP, AMD Phenom II 2 Core, XFCE desktop, kernel: 3.3.0-0.rc6.git0.2.fc17.x86_64 (the rc5 kernel crashed on my system sometimes)

You could also check if it lists llvmpipe (or how it is called) under system information -> graphics driver. If this is used it could be also sluggish to render 3D stuff like gnome shell.

tkalfaoglu
11th March 2012, 06:25 AM
It healed! I don't know how it happened, but probably has to do with some kernel update..
(I tried to build my own non-debug kernel, which screwed up the device drivers, none of it would load, and had to muck in the rescue mode to redownload stock kernel, reinstall, etc.. Fun times).
The end result of that trauma was that the machine now runs really fast.. :)
Thanks all, -t

simpleblue
11th March 2012, 03:44 PM
It healed! I don't know how it happened, but probably has to do with some kernel update..
(I tried to build my own non-debug kernel, which screwed up the device drivers, none of it would load, and had to muck in the rescue mode to redownload stock kernel, reinstall, etc.. Fun times).
The end result of that trauma was that the machine now runs really fast.. :)
Thanks all, -t
What did you do to reinstall the stock kernel? I'd like to get this kernel with debugging disabled as well.

Thanx

Fenrin
11th March 2012, 05:58 PM
here (http://koji.fedoraproject.org/koji/packageinfo?packageID=8)is a list of the available Fedora kernels. If you click on the newest Fedora 17 kernel, you can see the recent changelog. Where it says:
* Wed Mar 07 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc6.git2.1
- Linux v3.3-rc6-132-g55062d0

* Wed Mar 07 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc6.git1.1
- Linux v3.3-rc6-131-g097d591

* Mon Mar 05 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc6.git0.3
- Reenable debugging options.

* Mon Mar 05 2012 Dave Jones <davej@redhat.com> - 3.3.0-0.rc6.git0.2
- Disable debugging options.
[...]

So I guess you want the kernel 3.3.0-0.rc6.git0.2. Just download kernel (make sure that you choose the right architecture), kernel-devel and kernel-headers and then install it via yum install kernel*.rpm

simpleblue
12th March 2012, 08:02 PM
here (http://koji.fedoraproject.org/koji/packageinfo?packageID=8)is a list of the available Fedora kernels. If you click on the newest Fedora 17 kernel, you can see the recent changelog. Where it says:


So I guess you want the kernel 3.3.0-0.rc6.git0.2. Just download kernel (make sure that you choose the right architecture), kernel-devel and kernel-headers and then install it via yum install kernel*.rpm

Thank you.

I downloaded the kernel from this link: http://koji.fedoraproject.org/koji/buildinfo?buildID=306717 and it's so much more faster on my Acer Iconia touchpad. I have noted that multi-touch does not yet work but am waiting patiently.

tkalfaoglu
20th March 2012, 07:03 AM
What did you do to reinstall the stock kernel? I'd like to get this kernel with debugging disabled as well..Thanx

I think I had used the kernel that came with the alpha-17 dvd.
Now I'm getting bolder and trying the kernel-3.3.0-1.fc17.x86_64.rpm that Dave had made available a few days ago. rpm ivh kernel* is running right now, so if you don't hear from me again, that means the install bombed :)

** UPDATE **

Kernel 3.3.0-1 is the fastest FC17 kernel I have seen.. :)
Dunno if everything works yet, but it looks good..

AdamW
20th March 2012, 09:54 PM
3.3.0-1 has debugging disabled, it should stay that way from now through to final, I *think*.

Wokingham Travel Photos on Instagram - Cua Instagram Photos - Taian Travel Photos