PDA

View Full Version : Wireless Problems


deanej
21st January 2012, 04:00 AM
Recently I've been having issues with my wireless. It can see networks, but refuses to connect to any of them. dmesg has messages about direct probes and authentication timing out. I have to restart in order to fix it, but that's only temporary; the problem returns in a few hours.

How can I fix this? Wifi is essential for me.

sea
21st January 2012, 09:52 AM
Whats the output of:
dmesg|grep Ether
dmesg|grep wlan
dmesg|grep wifi
dmesg|tail

Further, assuming you're wireless is named wlan0, is this output lilsting the 'proper' wifi spot?
spots=$(sudo iw wlan0 scan|grep SSID|awk '{print $2}')
for this in $spots; do ls /etc/sysconfig/network-scripts/|grep $this ;done
This should actualy list 'your' wifi-spot setting files.

Maybe you cant connect to the wifi's because they're password protected, to connect to them (if you have the password):
DEVICE="wlan0"
SPOTNAME=""
PASSWORD=""
wpa_passphrase $SPOTNAME $PASSWORD > /etc/wpa-$SPOTNAME.conf
wpa_supplicant -B -i$DEVICE -c/etc/wpa-SPOTNAME.conf
dhclient $DEVICE

deanej
21st January 2012, 06:47 PM
Whats the output of:
dmesg|grep Ether
dmesg|grep wlan
dmesg|grep wifi
dmesg|tail

My wifi seems to be working today, but some of the messages from yesterday still seem to be there (though even when it's working it takes multiple attempts to connect except on first boot):
[jdeane@JON-LAPTOP ~]$ dmesg | grep Ether
[jdeane@JON-LAPTOP ~]$ dmesg | grep wlan
[ 28.654039] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 31.056806] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 31.083876] wlan0: authenticated
[ 31.104215] wlan0: associate with 00:3a:98:79:16:10 (try 1)
[ 31.305051] wlan0: associate with 00:3a:98:79:16:10 (try 2)
[ 31.505639] wlan0: associate with 00:3a:98:79:16:10 (try 3)
[ 31.705034] wlan0: association with 00:3a:98:79:16:10 timed out
[ 37.837981] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 1)
[ 37.843067] wlan0: authenticated
[ 37.869907] wlan0: associate with 00:3a:98:86:dc:c0 (try 1)
[ 37.886520] wlan0: RX AssocResp from 00:3a:98:86:dc:c0 (capab=0x421 status=0 aid=8)
[ 37.886529] wlan0: associated
[ 37.888068] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 48.194022] wlan0: no IPv6 routers present
[ 813.770916] wlan0: deauthenticating from 00:3a:98:86:dc:c0 by local choice (reason=3)
[ 822.009350] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 824.429405] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 824.480663] wlan0: authenticated
[ 824.501165] wlan0: associate with 00:3a:98:79:16:10 (try 1)
[ 824.701106] wlan0: associate with 00:3a:98:79:16:10 (try 2)
[ 824.901103] wlan0: associate with 00:3a:98:79:16:10 (try 3)
[ 825.101070] wlan0: association with 00:3a:98:79:16:10 timed out
[ 831.223625] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 831.238787] wlan0: authenticated
[ 831.260240] wlan0: associate with 00:3a:98:79:16:10 (try 1)
[ 831.460131] wlan0: associate with 00:3a:98:79:16:10 (try 2)
[ 831.660141] wlan0: associate with 00:3a:98:79:16:10 (try 3)
[ 831.860136] wlan0: association with 00:3a:98:79:16:10 timed out
[ 837.976704] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 838.176099] wlan0: authenticate with 00:3a:98:79:16:10 (try 2)
[ 838.376099] wlan0: authenticate with 00:3a:98:79:16:10 (try 3)
[ 838.576094] wlan0: authentication with 00:3a:98:79:16:10 timed out
[ 844.683237] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 1)
[ 844.753997] wlan0: authenticated
[ 844.754319] wlan0: associate with 00:3a:98:86:dc:c0 (try 1)
[ 844.954087] wlan0: associate with 00:3a:98:86:dc:c0 (try 2)
[ 845.154089] wlan0: associate with 00:3a:98:86:dc:c0 (try 3)
[ 845.354090] wlan0: association with 00:3a:98:86:dc:c0 timed out
[ 852.979303] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 853.052571] wlan0: authenticated
[ 853.073927] wlan0: associate with 00:3a:98:79:16:10 (try 1)
[ 853.273065] wlan0: associate with 00:3a:98:79:16:10 (try 2)
[ 853.473056] wlan0: associate with 00:3a:98:79:16:10 (try 3)
[ 853.673070] wlan0: association with 00:3a:98:79:16:10 timed out
[ 859.784285] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 1)
[ 859.823485] wlan0: authenticated
[ 859.823713] wlan0: associate with 00:3a:98:86:dc:c0 (try 1)
[ 860.023097] wlan0: associate with 00:3a:98:86:dc:c0 (try 2)
[ 860.223089] wlan0: associate with 00:3a:98:86:dc:c0 (try 3)
[ 860.423094] wlan0: association with 00:3a:98:86:dc:c0 timed out
[ 866.390334] wlan0: authenticate with 00:3a:98:79:16:10 (try 1)
[ 866.466562] wlan0: authenticated
[ 866.486771] wlan0: associate with 00:3a:98:79:16:10 (try 1)
[ 866.686056] wlan0: associate with 00:3a:98:79:16:10 (try 2)
[ 866.886102] wlan0: associate with 00:3a:98:79:16:10 (try 3)
[ 867.086099] wlan0: association with 00:3a:98:79:16:10 timed out
[ 873.192281] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 1)
[ 873.392090] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 2)
[ 873.592089] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 3)
[ 873.792087] wlan0: authentication with 00:3a:98:86:dc:c0 timed out
[ 880.970553] wlan0: authenticate with 00:3a:98:86:dc:c0 (try 1)
[ 881.004247] wlan0: authenticated
[ 881.004429] wlan0: associate with 00:3a:98:86:dc:c0 (try 1)
[ 881.009350] wlan0: RX AssocResp from 00:3a:98:86:dc:c0 (capab=0x421 status=0 aid=7)
[ 881.009353] wlan0: associated
[ 881.011051] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 891.634051] wlan0: no IPv6 routers present
[jdeane@JON-LAPTOP ~]$ dmesg | grep wifi
[ 20.490197] Loading firmware rtlwifi/rtl8192sefw.bin
[jdeane@JON-LAPTOP ~]$ dmesg | grep tail


Further, assuming you're wireless is named wlan0, is this output lilsting the 'proper' wifi spot?
spots=$(sudo iw wlan0 scan|grep SSID|awk '{print $2}')
for this in $spots; do ls /etc/sysconfig/network-scripts/|grep $this ;done
This should actualy list 'your' wifi-spot setting files.
First line has no output; second has "bash: syntax error near unexpected token `done'"

Maybe you cant connect to the wifi's because they're password protected, to connect to them (if you have the password):
DEVICE="wlan0"
SPOTNAME=""
PASSWORD=""
wpa_passphrase $SPOTNAME $PASSWORD > /etc/wpa-$SPOTNAME.conf
wpa_supplicant -B -i$DEVICE -c/etc/wpa-SPOTNAME.conf
dhclient $DEVICE

It's not password protected. My university is mostly unprotected wifi.

deanej
25th January 2012, 02:25 AM
Can anyone help? The logs are the same when it's not working, it just keeps timing out forever. It's annoying and impractical to have to restart all the time, and I don't have the money for a new laptop.

sesso
25th January 2012, 03:49 AM
Did the problem just start? I had problems with the latest NetworkManager. I did a yum downgrade and it worked again.

sea
25th January 2012, 12:58 PM
spots=$(sudo iw wlan0 scan|grep SSID|awk '{print $2}')
for this in $spots; do ls /etc/sysconfig/network-scripts/|grep $this ;done
First line, scans the availabel spots, using wlan0, and lists the 2nd entry in the variable spots (therefore 'empty' line)
Run the 2nd line in the SAME terminal, to parse the network-scripts folder, for any matching entries of the available spots.


Another script i'm using (modified while copy-paste, untested), save these lines as wico0.sh in $HOME/bin and call it by sudo wico0.sh.

#!/bin/bash
echo "Do wlan down"
ifcfg wlan0 down >> /dev/zero

echo "Do wlan up"
ifcfg wlan0 up >> /dev/zero

echo "Tell device which spot...."
# WITH PASSWORD:
# wpa_supplicant -B -iwlan0 -c/etc/wpa_$HOTSPOT.conf
# Without Password:
iw wlan0 connect YOURSPOTNAME

echo "dhclient...."
dhclient wlan0


Dont see causing errors there, you might try to downgrade as suggested, or hope for an update soon.
Hope this helps.

deanej
25th January 2012, 03:56 PM
Did the problem just start? I had problems with the latest NetworkManager. I did a yum downgrade and it worked again.

I wanna say they started last week around this time. How do I downgrade it?

deanej
26th January 2012, 06:22 PM
This problem is getting worse for me. I now have to restart every two hours to keep it working. I'm getting infuriated and want to smash my laptop with a sledge hammer.

JEO
26th January 2012, 07:13 PM
I wanna say they started last week around this time. How do I downgrade it?

First prevent it from being automatically updated by adding it to an exclude line in /etc/yum.conf

exclude=NetworkManager*

Then try the following command:

yum downgrade NetworkManager*

deanej
27th January 2012, 08:34 PM
Downgrading just made the wireless worse but updating it again seems to have fixed the issue. At least as far as I can tell for now. Thanks.

Knowing my karma, it will break again right after I post this. Let's hope that doesn't happen.

broadcast23
28th January 2012, 12:05 PM
I am runing FC 16, new kernel came in this mourning in the updates. After I restarted to go into the new kernel, my wireless connection worked tor about maybe 15 seconds then reverted to trying to connect to eth0. heres my hardware configuration:
intel core2duo
realtek 8185 wireless pci lan card
It seems as though the radio is just turned off, as all the the wireless security configuration is still there as I can see the security settings an all, but cannot connect to it. If I go to the old kernal (3.2.1-3) it works fine.

deanej
30th January 2012, 05:47 PM
Just had to restart today again because of it. Maybe it's because my Realtek card seems to be dying. Or maybe Fedora doesn't like my habit of running both wired and wireless when in my room.

Callao Photos - Ranchi Photos - Orumiyeh Travel Photos -