PDA

View Full Version : Mounting Smbfs Partitions, first mount always locks up


nic33
28th May 2004, 09:54 PM
I'm having problems mounting smbfs partitions in that the first mount will always lock up. If I go to the mount point and try to list the directory contents, my shell will just freeze. Usually, after the first mount, if I mount other windows shares I have no problems accessing them. Just, if I try to reboot the first share that is locked up will causs the system to not shut down fully.

I'm running Fedora Core 2 (kernel: 2.6.5-1.358 athlon), smbmount version 3.0.3-5, and I'm connection to shares on Windows XP Pro SP1. I've also run across the same problem when trying to mount to a samba share on another Linux (REBYTE) box.

I've also added all the samba mount points in my fstab. When I remove "noauto" as an option, it mounts all the windows shares (there are a lot of them) w/o any problem that I've encountered thus far. (all of them appear to be working). The only problem w/ this is my Gnome desktop is then full of mount icons, and I can't figure out how to get them off my desktop. Also, it is not a good idea (i suppose) to have all these active connections unless I'm using them. They are created for backup jobs.

When I leave the "noauto" option on, and try to mount them as root I encounter the same lock up problems.

Is there anymore information you need to help me?
Thank you for reading my post, and thank's in advanced to any replies.

-Nic

Badger
3rd June 2004, 01:24 AM
I've run into the same problems even as far back as RH 7.1 or so.

Not sure of the cause, but if you, in another shell, check your ps -ef you'll see an entry of [rpciod] (I believe thats the name -- its been a while). Kill -9 that process and everything will crank up like it should be.

foolish
3rd June 2004, 02:50 AM
http://www.fedorafaq.org/#smbmount might help some.

nic33
3rd June 2004, 04:13 AM
CIFS eh? Sounds neet, I'll give it a try. Thank you so much for the replies guys.

One work around I've found is to mount a share several level's deep and then just umount -fd it. If it successfully unmounts then the rest of my mounts will work fine. If it doesn't unmount, then at least it is pretty deep in the filesystem directory structure that it doesn't mess up any applications that might need to scan the filesystem (say for a file->open).

But the CIFS sounds promising. Thanks again.
-Nic

kama
4th June 2004, 03:03 AM
I have this problem too. Whenever you put an entry in fstab with smbfs as file type the first mount locks everything up. It's easy to reproduce and has to be a bug - does anyone know how to submit the bug?

radonsg
13th June 2004, 05:07 AM
Has this problem been fixed yet? Due to this problem, I switched to xfce4 at the moment. Wat I do to unfreeze it is to do a umount -l /mnt/win_mount. This is really troublesome, has there been a patch?

Sicily1918
15th October 2004, 09:11 AM
Ran into the same situation -- check post

http://www.fedoraforum.org/forum/showthread.php?t=24892

and it should solve your issues.