PDA

View Full Version : how to disable hostname at login


pparks1
28th May 2004, 03:00 PM
I want to disable the hostname from being displayed at boot on my Linux server. Right now it says,

servername login:
I would rather it just say
login:


Anybody know what I have to change. I don't actually want to change the hostname of the server, but rather just not display the hostname at login.

SuperNu
28th May 2004, 05:14 PM
Are you booting to a command line or GUI? I am going to assume that you are booting to a command line. I was reading through the man page for mingetty and noticed the option --nohostname which does what you want. I believe if you add --nohostname to all six gettys initializations, you should achieve what you want. I haven't tested this out yet, but it is a start. Good luck and let me know if it worked or not.

--SN

SuperNu
28th May 2004, 05:22 PM
Just rebooted my system, and the --nohostname option worked. You have to edit /etc/inittab and find the lines like 1:2345:respawn:/sbin/mingetty tty1 and change them to 1:2345:respawn:/sbin/mingetty --nohostname tty1. You are going to have to do this for each tty on your system. Read the mingetty man page for more options. If you are using GDM, KDM or XDM, then you are going to have to change options through them. KDM is under kcontrol -> System Administration -> Login Manager under the appearance tab. I am not sure where the options are for GDM or XDM. Good luck.

--SN

pparks1
28th May 2004, 06:10 PM
Thanks. I will give it a shot. I am booting to a command line, so I think you have it all figured out for me.

Yawata Travel Photos on Instagram - Elazig Instagram Photos - London Photos on Instagram