PDA

View Full Version : How to disable a systemd service?


Japplo
3rd September 2011, 12:29 PM
Hi Fedora Users,
how can I disable a systemd service? I tried:

systemctl disable sendmail.service

but if I reboot my computer the service is once again enabled.

Thanks japplo

smr54
3rd September 2011, 01:58 PM
I believe that in most, if not all cases, the usual chkconfig command will work.

chkconfig sendmail off

(Not on a Fedora box to test it at present, but pretty sure I used that to enable and disable services)

scott32746
3rd September 2011, 02:11 PM
Hello,

Other way is to
# setup --> system services

DBelton
3rd September 2011, 04:10 PM
disabling it doesn't seem to work with sendmail.

For some oddball reason, sendmail is also started up by the network manager service.

The only way I was able to keep sendmail from starting, was to to completely remove sendmail from my system.

yum remove sendmail

tox
4th September 2011, 12:41 AM
you could always use

services sendmail stop

services sendmail off

Gu3st
4th September 2011, 04:21 PM
you can find systemd tutorial at http://fedoraproject.org/wiki/Systemd

marko
4th September 2011, 06:29 PM
you could always use

services sendmail stop

services sendmail off


I think you mean

chkconfig sendmail off

for the second one there is no off argument to service sendmail

tox
5th September 2011, 12:49 AM
I think you mean

chkconfig sendmail off

for the second one there is no off argument to service sendmail

well thats all i used when i turned off bluetooth and worked the command i posted.

marko
5th September 2011, 01:11 AM
well thats all i used when i turned off bluetooth and worked the command i posted.

I think it would work to do


service sendmail stop
chkconfig sendmail off(note no "s" on the end of service )

Reghin-Sat - Dominican Republic Photos - Nimes