PDA

View Full Version : NVIDIA for FC3


mike
8th November 2004, 09:53 PM
NVIDIA Install Instructions for FC3
Based on the Alternate Instructions for NVIDIA from fedorafaq.org
http://www.fedorafaq.org/custom_nvidia.html

1. Get the lastest linux drivers.

2. Now print this out, or write it down, because we're going to close X, the graphical part of Linux.

3. Open a Terminal.

4. Become root:
su -

5. Shut down X:
telinit 3

6. Now, you will have a "Login:" prompt. Log in as root and go to the directory where you downloaded the nVidia drivers.

7. Type:
sh NVIDIA-Linux-x86-1.0-6629-pkg*.run

8. Follow nVidia's instructions to set up the driver. (Read the "EDITING YOUR XF86CONFIG FILE" section.)

9. You may need to remove some conflicting files, only do this if 3d accelerated apps do not apprear to be working.
rpm -e --nodeps xorg-x11-Mesa-libGL
NOTE: If you update any "xorg-x11" package with up2date or yum, you will have to do the above command again.

10. Load nvidia driver
modprobe nvidia

11. Set nvidia driver to load with udev.
cp -a /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*

12. Reboot

spark1
8th November 2004, 11:35 PM
tnx, will try it as soon as i get my fc3 online :)

edit: online! ;p

JLF_65
9th November 2004, 04:30 AM
For x86_64, you need to do
rpm -e --nodeps --allmatches xorg-x11-Mesa-libGL

and for either, modprobe and telinit are in /sbin, so it should be like this
/sbin/modprobe nvidia

And you don't need to reboot - you can just
/sbin/telinit 5
to get back to X.

Other than that, it's all good.

Nice summary for people new to nvidia driver installation. :D

imdeemvp
9th November 2004, 07:13 AM
I all do is follow this instructions from nvidian and I am done in less than 5 mins. http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html

spark1
9th November 2004, 09:27 AM
im done with it but i wanna mention, if some1 got the same problem as i did: in the "telinit 3" part, it will be kinda 'stuck' after saying about the ancaron (FC's installer). its NOT stuck, nor thinking - just click Ctrl+C. i waiting long time for it to do something, finally went to sleep. and now came back and saw its the same.
so, dont do my mistake, tho its not big deal. greets!

by the way: "modprobe nvidia" if it worked, it means my driver is working? how do i make sure its loaded? (in gnome)

fritzonline
9th November 2004, 02:16 PM
Thanks, Mike. This was the problem I was fearing most, as I had tremendous hassles with Fedora Core 2 and my GeForce.

Anyway, now I'm looking forward to getting home and installing.

bretzel
9th November 2004, 03:50 PM
Thank you very Mike for that short help. Me too it was my brain killing problem in FC3.
I should have looked for help before...

I must thank the fedoraforum owner for us Fedora users, to give and get help. :-)
Your instructions guide just worked! I am now booting with the nvidia driver and now I am really happy to stop booting in rescue mode...:-)

Bretzel

mike
9th November 2004, 04:10 PM
by the way: "modprobe nvidia" if it worked, it means my driver is working? how do i make sure its loaded? (in gnome)
In a terminal windows:
lsmod
And look for nvidia in the list.

mike
9th November 2004, 04:15 PM
im done with it but i wanna mention, if some1 got the same problem as i did: in the "telinit 3" part, it will be kinda 'stuck' after saying about the ancaron (FC's installer). its NOT stuck, nor thinking - just click Ctrl+C. i waiting long time for it to do something, finally went to sleep. and now came back and saw its the same.
so, dont do my mistake, tho its not big deal. greets!


After you telinit 3, you can hit
ctrl-alt-F1 to goto a new terminal window.

Buchan
9th November 2004, 06:16 PM
Well I can't say for sure yet Mike but I know things are better than last night. I just followed your instructions thru and ssh terminal from work and things look good. The machine came back up :-)

Last night after the standard nvidia install I just got to Configuring Kernel Parameters... and the system would hang.


Thanks a bunch looks like the thing I was missing was the modprobe nvidia

Thanks again great Howto

sayeeth
9th November 2004, 06:44 PM
Thanks mike, working like a charm now. Waiting eagerly for nvidia rpms. :)

steiale
10th November 2004, 07:25 AM
Hello there,

unforunately this workaround does only work for single processor bootups. When I try to boot my system with smp kernel the nvidia driver does not work.

Anyone any idea why it is so? Any workarounds?

Thanks a lot!!

alex

PompeyBlue
10th November 2004, 10:09 AM
Hello,

Thanks for the work around, after telinit 3 I too was stuck at starting anacron or something and I've just left my PC at home waiting for it to come back to life.

However, I have a quick query....

When I su I notice that /sbin is not in my path list. The telinit command sits in that directory and so I can't actually find it without adding it to my path list or cd'ing to it.

Do you guys all run telinit without problems ? Is my installation a bit broken ? Do you just cd /sbin ?

cscheng
10th November 2004, 03:26 PM
I installed the nvidia drivers as described in the first post, and edited the /etc/X11/xorg.conf file as noted in the ReadMe. I rebooted the system, and instead of seeing the Red Hat Graphical Bootscreen I saw a giant NVidia-logo. This screen didn't disappear and therefore I removed the rhgb in /etc/grub.conf. Anyone have this similar problem? Since I haven't configured a lot, it's no big deal to re-install FC3 and wait for the rpms, but I'm always open for other solutions.

stray
10th November 2004, 03:27 PM
Thanks for the work around, after telinit 3 I too was stuck at starting anacron or something and I've just left my PC at home waiting for it to come back to life.

Perhaps you got dropped to the wrong console window; try hitting ALT-F1 through ALT-F5 to get another console. (ALT-F7 is usually the graphical console, when X is running).


Do you guys all run telinit without problems ? Is my installation a bit broken ? Do you just cd /sbin ?

If you "su -" instead of just "su", then you get root's environment set up for you. Without the minus sign, you retain your own path, which lacks /sbin and /usr/sbin.

jtang613
10th November 2004, 03:54 PM
I installed the nvidia drivers as described in the first post, and edited the /etc/X11/xorg.conf file as noted in the ReadMe. I rebooted the system, and instead of seeing the Red Hat Graphical Bootscreen I saw a giant NVidia-logo. This screen didn't disappear and therefore I removed the rhgb in /etc/grub.conf. Anyone have this similar problem? Since I haven't configured a lot, it's no big deal to re-install FC3 and wait for the rpms, but I'm always open for other solutions.

Just add the line:
Option "NoLogo"
To the "Device" section of your xorg.conf

PompeyBlue
10th November 2004, 04:35 PM
If you "su -" instead of just "su", then you get root's environment set up for you. Without the minus sign, you retain your own path, which lacks /sbin and /usr/sbin.

Well I never, you learn something new every day. Thanks for the reply!

PompeyBlue
10th November 2004, 08:33 PM
I followed the guide and am now hardware accelerated. But out of interest, what would've happened had I not removed the mesa library and installed the driver as is ? What behaviour would I expect ?

sayeeth
10th November 2004, 08:36 PM
I followed the guide and am now hardware accelerated. But out of interest, what would've happened had I not removed the mesa library and installed the driver as is ? What behaviour would I expect ?

Well as far as I'm concerned I did not have any issues without removing the mesa libraries. I actually just uininstalled the mesa libraries a few minutes ago. Honestly, I don't see any glitches on my video and video performance. I'm not sure how to go about testing to see the diiference with and without the mesa libraries. Perhaps someone can shed some insight?

crackers
10th November 2004, 11:23 PM
I haven't installed the NVidia drivers yet, as I just upgraded (and am in the process of "yumming" the updates - ***sigh***), but the NVidia installer prior to 6629 would very politely move the GL libraries out of the way on installation and move them back when uninstalled. I would actually assume the same behavior would apply. Note I said assume - as I said, I haven't done it yet...

Prion
11th November 2004, 07:02 PM
:D THANK YOU!!! :D

I tried your instructions just now and it worked for me. Prior to this I had tried the ones on the nvidia web site, and got nothing but errors. First my computer would not boot up properly. It would stall during bootup. I had to fix this by modifying grub and removing rhgb. Then after that my computer booted up but gave me a bunch of errors when trying to start Xwindows.

I reverted my /etc/xorg.conf file back to its original state, searched on the Internet, found and followed your instructions, rebooted, saw the nvidia logo during bootup, tried Tux Racer, and knew that my GeForce2 GTS card was working properly because Tux Racer was now playing very smoothly.

For some reason though my computer froze up when I tried "telinit 3" to shut-down X and install the nvidia drivers. It got stuck when trying to shut down cups-config-daemon. Not sure why. So I just manually modified /etc/inittab and changed the mode from5 to 3 and rebooted with that.

But thanks once again! I could never get my nvidia card to work properly under FC1.

crackers
11th November 2004, 08:47 PM
Well, from my personal experience,

Step 11 is VERY important!

I had a power failure and didn't do that step. ***sigh*** Uninstall, reinstall, copy.

Grumble, grumble, grumble. :o

bryancole
11th November 2004, 09:47 PM
I've followed all the Nvidia-on-FC3 instructions posted here but when start X after configuring the nvidia driver in Xorg.conf, the X-server flashes up the Nvidia logo, then "hangs". (kind of like what people have reported with rhgb enabled, only I'm not using rhgb and this occurs _after_ bootup)

In fact, X is running and there are no errors in the Xorg.0.log, and I can Ctrl-Alt-Fn to other terminals to log in, but nothing I do changes the fact that the nvidia drivers just give me a blank screen (or the NV logo).

By dropping to 'init 3' and starting X manually with 'startx' while forwarding StdErr to a file shows that Xmodmap is segfaulting during the xinitrc-common script. Any ideas what could be causing this? There are no other errors in any of the logs that I can see.

This is very wierd. My hardware was working fine with FC2. This has only happened since upgrading to FC3, so I don't suspect dodgy hardware. X runs fine with the default 'nv' driver.

ideas?

Bryan

Flawed
12th November 2004, 07:59 PM
Bah, I'm still having no luck with this. :(

I installed/downloaded the kernel source with "up2date --get-source kernel", but the installation still keeps on complaining about my kernel and fails. Before the installer quits, it tells me it might be a good idea to specify the path to the kernel sources if I'm sure I have them. How do I do this and how do I find out where up2date downloaded it to?

pbtpu40
14th November 2004, 03:34 AM
I have a dual P4 Xeon and the standard install process worked just fine. But here is what I did specificly in hopes that you might see something you missed.
Downloaded the nvidia package from www.nvidia.com
went init3, ran the installer as root
edited /etc/X11/xorg.conf as needed #remove dri, change nv to nvidia etc
copy /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices

After this my system was fully functional.
Hope this helps. pbtpu40

pbtpu40
14th November 2004, 03:41 AM
You actually do not have to reinstall from scratch. I'm guessing by the time you see this it may not help, but maybe someone else out there might run into a problem like this. What is happening is rhgb is not starting up proberly because the Nvidia driver isn't there. You can work around this a couple ways.
1.Disable rhgb during the grub boot up by erasing it from kernel command. Init 5 though will still not function properly as the Nvidia kernel isn't there so the X-Server will go beserk.
2. Another option, and a better option is to boot the system into single user mode and performing step 11 and then issuing init 5.
To boot into single user mode, edit the grub command and append single to the end of it.
Editing commands at the grub screen is done by hitting e, if I remember correctly.

crackers
14th November 2004, 07:21 AM
Actually, I should have more explicit - I had to re-install the NVidia drivers to make the copies of the /dev entries - the reboot, quite naturally, "erased" them. Since I skipped step 11, the quickest way to get the entries was to run through a quick re-install then make the correct copies.

IllegalOpertion
14th November 2004, 07:38 AM
The only problem I am having, which is better described more as an annoyance, removing the Mesa libs results in "broken packages" for apt-get. Whenever I run apt-get or synaptic it wants to reinstall this lib before I can proceed with anything.

Leaving the libss installed and running nvidia drivers resulted in a very disturbed system for me. Apps wouldnt open, and in games I got 11 FPS.

pbtpu40
14th November 2004, 08:34 AM
A modprobe nvidia will also reinstaniate the /dev entries. :) I'm glad you got it fixed though.

pbtpu40
Barron
------------------
VHDL -- When software just wont do.

crackers
14th November 2004, 06:15 PM
The only problem I am having, which is better described more as an annoyance, removing the Mesa libs results in "broken packages" for apt-get.
Well, I did not remove the packages. As I said somewhere else, the NVidia installer has been quite "polite" about moving the binaries out of the way on installation and moving them back when uninstalled. The caveat is that you have to be very careful when doing updates because if you update the xorg-x11-Mesa* packages with the NVidia drivers in place, you have officially hosed your OpenGL.

M@stersound
15th November 2004, 01:42 AM
Hi:
I can install nvidia drivers following the MIKE's steps in this forum.

When I type: sh NVIDIA-LINUX-........... .pkg1.run , the installation screen appears, I accept. Then a alert screen shows:
"No precomipled kernel interface was found to match your kernel: would you like the installer to attempt to download a kerenel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)?"

After accepting this, an error screen appears:

"Error Unbable to find the development tool 'cc' in your path: please make sure that you have the package 'gcc' installed. If gcc is installed on your system, them please check that 'cc' is in your path".

My gcc does is installed .

what can I do? :(

IllegalOpertion
15th November 2004, 01:48 AM
Well, I did not remove the packages. As I said somewhere else, the NVidia installer has been quite "polite" about moving the binaries out of the way on installation and moving them back when uninstalled.



Well my Nvidia driver installer doesnt politley move mine out of the way. They install with a warning that these libs will conflict if I leave them installed and that is all I get. This are with the latest Nvidia installer. I have to remove them myself with a rpm -e --nodeps xorg-x11-Mesa-libGL

crackers
15th November 2004, 02:55 AM
Interesting. I wonder what the difference is, then. I installed FC3 with an upgrade and used the 6629 package from NVidia.

Insolence
15th November 2004, 05:26 AM
Hi:
I can install nvidia drivers following the MIKE's steps in this forum.

When I type: sh NVIDIA-LINUX-........... .pkg1.run , the installation screen appears, I accept. Then a alert screen shows:
"No precomipled kernel interface was found to match your kernel: would you like the installer to attempt to download a kerenel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)?"

After accepting this, an error screen appears:

"Error Unbable to find the development tool 'cc' in your path: please make sure that you have the package 'gcc' installed. If gcc is installed on your system, them please check that 'cc' is in your path".

My gcc does is installed .

what can I do? :(


Same thing happened to me, now I'm stuck with that silly 'configuring kernal parameters' thingy

pbtpu40
15th November 2004, 06:23 AM
If the nvidia installer can not find gcc and you are sure you installed it, try a which cc or locate cc at the command prompt. If nothing is returned then gcc was not installed and must be. You should be able to install this with yum. If it was located, make sure to add these locations to your path.
As for mesa problems, I have not had any. If you properly configure everything you should not have any problems. Especially if you are using the installer off the Nvidia site.
When i installed Fedora it was a fresh install, *updating should usually be avoided if possible because it can produce conflicts* After the install the nvidia driver was my first task, i download it and ran it, editied my config file, took care of udev, ran up2date and then rebooted, no problems what so ever.
Some where, something got screwed up.

ahbrown41
17th November 2004, 06:21 PM
Check out:
http://wilsonet.com/mythtv/fcmyth.php#video

Just change everything to reference FC3 and you should be Ok.

Psquared
19th November 2004, 07:33 PM
Will these instructions work with FC2 with Kernel 2.6.9?

Also, when I tried to install using the nVidia installer it complained that I had an earlier RPM version. It said it would uninstall the RPMs (which I had already done with yum remove nvidia) but my PC would not boot past the nVidia Splash screen.

I am tempted to just add the NoLogo command to xorg and see what would happen, but I am a stickler and I want to do this the right way.

mustangfanatic
19th November 2004, 11:26 PM
I read the readme file section and I don't know what that stuff is saying. I know we use xorg instead of xfree86 but whatever they were talking about doesn't make sense to me. Also when I first run the setup it says something about a precompiled kernel interface was not found. Also it says gcc cannot be found. I thought that was supposed to come installed with fc3. Can anyone help me out or am I too newb and should just wait for rpms?

mustangfanatic
20th November 2004, 12:50 AM
It's also saying now that I need to install my kernel source code. When I try to use yum to get this I get the following error.

[root@fc3 ~]# yum install kernel-soucecode
Repository updates-released already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up Repo: fedora-stable
Cannot open/read repomd.xml file for repository: fedora-stable
failure: repodata/repomd.xml from fedora-stable: [Errno 256] No more mirrors totry.
[root@fc3 ~]#

After installing my source rpm (by typing rpm -i kernel-2.6.9-1.678_FC3.src.rpm) my NVidia install is still complaining about missing this. Please help!

Jman
20th November 2004, 01:30 AM
Just add the line:
Option "NoLogo"
To the "Device" section of your xorg.conf
Almost. You need Option "NoLogo" "true"
Then that annoying logo is gone. :)

vipergts450
20th November 2004, 07:14 AM
I've followed all the Nvidia-on-FC3 instructions posted here but when start X after configuring the nvidia driver in Xorg.conf, the X-server flashes up the Nvidia logo, then "hangs". (kind of like what people have reported with rhgb enabled, only I'm not using rhgb and this occurs _after_ bootup)

In fact, X is running and there are no errors in the Xorg.0.log, and I can Ctrl-Alt-Fn to other terminals to log in, but nothing I do changes the fact that the nvidia drivers just give me a blank screen (or the NV logo).

By dropping to 'init 3' and starting X manually with 'startx' while forwarding StdErr to a file shows that Xmodmap is segfaulting during the xinitrc-common script. Any ideas what could be causing this? There are no other errors in any of the logs that I can see.

This is very wierd. My hardware was working fine with FC2. This has only happened since upgrading to FC3, so I don't suspect dodgy hardware. X runs fine with the default 'nv' driver.

ideas?

Bryan
I wish I could help but I have this exact same situation occurring on my machine down to the last letter. It started after the last Xorg update and I cannot figure out why.

I hope this gets isolated soon because it is a very annoying (and very odd) issue.

--Mike

cscheng
21st November 2004, 05:24 PM
Even without the logo, I only get a blank screen with the cursor. Nothing more. Can someone post his (working) xorg.conf?

bob
21st November 2004, 05:42 PM
cscheng, here's mine:
(removed afterwards to conserve bandwidth)

cscheng
21st November 2004, 05:54 PM
Okay, now I know the problem isn't in the xorg.conf...

smfinley
21st November 2004, 05:58 PM
If all else fails you could try the instructions for nVidia here: http://stanton-finley.net/fedora_core_3_installation_notes.html

bob
21st November 2004, 06:05 PM
Beautiful work, smfinley! Thanks for all your efforts.

cscheng
21st November 2004, 06:21 PM
The nvidia driver does load, but I can only see my cursor. The rest of the screen is blank... :(

bob
21st November 2004, 07:01 PM
type in your username and it should ask for your password, then just 'startx'

cscheng
21st November 2004, 07:08 PM
Both X and Nvidia driver are started, but I can't see anything except my cursor. I can login via GDM, but I can't see it. When I move the cursor over the "username textbox", I can see my cursor is changing. It's very weird. It shows my cursor perfectly, but the rest of screen is black. Can someone please help? :(

Psquared
21st November 2004, 08:12 PM
Both X and Nvidia driver are started, but I can't see anything except my cursor. I can login via GDM, but I can't see it. When I move the cursor over the "username textbox", I can see my cursor is changing. It's very weird. It shows my cursor perfectly, but the rest of screen is black. Can someone please help? :(


I didn't read the entire thread, but I am assuming you are trying to load the nVidia 6629 driver in FC3. I can tell you from reading the nVidia forum that this driver is buggy. Bob got it to work, but I didn't - even though it was FC2 I updated to the latest kernel 2.6.9.

The great majority of people get the black screen with varying degrees of functionality. In my case I got the nVidia Logo and it never went away. I disabled the logo in xorg and then all I got was a black screen.

I have read all sorts of workarounds, but most of them involve changing something in the kernel. I think I will wait until nVidia updates the driver. They are aware of the bug and it should be updated soon.

Because I have FC2 I just rolled back my kernel to 2.6.8-1.521 and reinstalled the old nVidia 6111 driver.

cscheng
21st November 2004, 08:47 PM
Very odd... guess we'll just have to wait then...

vipergts450
21st November 2004, 09:03 PM
I'm having the same issue as cscheng. Is there any word as to when nVidia might release a corrected driver?

wa1hco
21st November 2004, 09:04 PM
I get a similar thing. Installed the 6629 drivers and made the modprobe and xorg.conf changes. When X starts the "Nvidia" logo appears full screen and stays there. X tries to display stuff but the screen never gets cleared so it just builds up...getting more and confused. I can log in blindly, but any windows or menu popups just make a mess.

Any ideas?

LinuxNewb
21st November 2004, 09:07 PM
i had/have the exact same problem im just going to uninstall and put in 6111 and see if that works

cscheng
21st November 2004, 09:11 PM
I tried to use an older driver too, but it kept asking for kernel-source. Fedora doesn't include kernel-source since FC3...

LinuxNewb
21st November 2004, 09:16 PM
update your kernel-source and make sure you have gcc

cscheng
21st November 2004, 09:17 PM
I can't, I did a clean install.

LinuxNewb
21st November 2004, 09:44 PM
i belive kernel-source is a rpm

vipergts450
21st November 2004, 11:16 PM
I tried a yum search on kernel-source, and the only match I got was kernel-sourcecode.noarch which was listed as installed. Is there another step necessary to get the 6111 drivers to see this source?

bob
21st November 2004, 11:25 PM
Here's a link to a .src file for the 2.6.9-1.667 kernel http://rpmfind.net/linux/RPM/fedora/3/i386/kernel-doc-2.6.9-1.667.noarch.html
Can't vouch for a thing about it, but it's an option for you.
This is another direct download link too:
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os/SRPMS/kernel-2.6.9-1.667.src.rpm

Psquared
21st November 2004, 11:57 PM
I can't swear to this but I'm pretty sure that you can't get the 6111 to compile against anything other than kernel 2.6.8-1.521. Oh, except I think 6106 will also work with that kernel. Apparently, from what I have read, the 6629 is for kernel 2.6.9 but won't work with FC without slapping your box around pretty good.

Bob, you are the exception. :D

bob
22nd November 2004, 12:14 AM
You're right Psquared, on both accounts ;)
So, for those FC2 people that long for that Nvidia 6111 driver, here's that source code:
http://fedora.quicknet.nl/fedora/fedora/2/i386/SRPMS.updates-testing/

vipergts450
22nd November 2004, 12:33 AM
I have found a patched 6111 driver which DOES compile against the 2.6.9 kernels in FC2 and FC3.

Follow the instructions here:
http://ngc891.blogdns.net/index.php?2004/09/21/3-patched-nvidia-drivers

Basically, unzip with:
tar -xjvf NVIDIA-Linux-x86-1.0-6111-jp1.tar.bz2
then:
cd NVIDIA-Linux-x86-1.0-6111-jp1
and finally, as root:
./nvidia-installer -na

That should be all there is to it and X should work once again.

Hope this helps,
Mike

P.S. - I hope that nVidia comes up with a more compatible (read: working) 6629 driver because I am excited about the reports of improved performance with them.

smfinley
22nd November 2004, 02:08 AM
There are also nVidia instructions for FC3 here:

http://stanton-finley.net/fedora_core_3_installation_notes.html

sl4ck3r
22nd November 2004, 04:20 AM
perfect, this works as advertised

thanks!

cscheng
22nd November 2004, 07:05 AM
Well, the problem is not the type of videocard. Justol'bob has also a Geforce 4 MX like I do.

LinuxNewb
22nd November 2004, 03:49 PM
so basically 6629 on 2.6.9 either works or it doenst? cause im having one HELLUVA time trying to get it to work gonna give it another shot tonite

bob
22nd November 2004, 03:59 PM
Ahhh, my friends, there's a NEW KERNEL afoot (2.6.9-1.6)! I installed for both my FC2 and FC3 boxes this morning and both were easily setup by just rebooting, then logging in as root and running the 'sh NVIDIA-Linux-x86-1.0-6629-pkg1.run' from the correct directory. Hopefully the Kernel Gods have configured it perfectly for everyone this time.

cscheng
22nd November 2004, 05:52 PM
No, it didn't work. :(

LinuxNewb
22nd November 2004, 09:55 PM
bob, is that the 2.6.9-1.681 kernel? or 2.6.9-1.678 kernel?

bob
22nd November 2004, 11:20 PM
That would be the 2.6.9-1.681_FC3, or as it's identified on FC2, 2.6.9-1.6_FC2. I'd send you a screenshot of a working config, but you poor people couldn't see it..... :D

Seriously, once I got the first Nvidia driver working, following Mike's instructions, all I've had to do is download a new driver, if one exists, then browse to it, and right-click on the tar.gz to extract it to my home directory. Now when a new kernel appears, I load it, then reboot and wait for the terminal to appear after startx fails. Then, it's just sign in as root, cd to my home directory & 'sh NVIDIA_Linux-x86-1.0-6629-pkg1.run' and answering 'ok' to all the Nvidia statements. After that, back to user mode and 'startx'.

No need to edit xorg again or modprobe nvidia or set the driver to load with udev again and, so far, no need to remove the xorg-x11-Mesa-libGL even though it was reinstalled with new xorg-x11 packages recently.

lfrossati
23rd November 2004, 01:34 AM
Yes... finally it's working.... it only works in my FC3 with the driver posted by vipergts450...

NVIDIA-Linux-x86-1.0-6111-jp1.tar.bz2

Even with the new kernel 2.6.9 -1.681_FC3, the 6629 version of the nvidia driver doesn't work.

Now i am playing enemy territory and it's faster than in my old FC2. Very well job with this driver (modified 6111) and congratulations for the fedora comunity. I only had a problem with the nvidia driver. FC3 rocks!!!

rpm
23rd November 2004, 01:51 AM
I do this but nothing happend. I type modprobe nvidia and bash return nothing. When I type lsmod in bash return this:

Module Size Used by
nfsd 204641 9
exportfs 8001 1 nfsd
lockd 63241 2 nfsd
parport_pc 24705 1
lp 11565 0
parport 41737 2 parport_pc,lp
autofs4 24005 0
i2c_dev 10433 0
i2c_core 22081 1 i2c_dev
sunrpc 160421 19 nfsd,lockd
nls_utf8 1985 2
ntfs 83952 2
dm_mod 54741 0
button 6481 0
battery 8517 0
ac 4805 0
md5 4033 1
ipv6 232577 12
joydev 8705 0
uhci_hcd 31449 0
ehci_hcd 31557 0
hw_random 5589 0
snd_intel8x0 34829 1
snd_ac97_codec 64401 1 snd_intel8x0
snd_pcm_oss 47609 0
snd_mixer_oss 17217 1 snd_pcm_oss
snd_pcm 97993 3 snd_intel8x0,snd_pcm_oss
snd_timer 29765 1 snd_pcm
snd_page_alloc 9673 2 snd_intel8x0,snd_pcm
gameport 4801 1 snd_intel8x0
snd_mpu401_uart 8769 1 snd_intel8x0
snd_rawmidi 26725 1 snd_mpu401_uart
snd_seq_device 8137 1 snd_rawmidi
snd 54053 10 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi, snd_seq_device
soundcore 9889 1 snd
e1000 77389 0
floppy 58609 0
ext3 116809 1
jbd 74969 1 ext3
ata_piix 8389 0
libata 40005 1 ata_piix
sd_mod 16961 0
scsi_mod 118417 2 libata,sd_mod

This is my xorg.conf file:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
# Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell M782"
DisplaySize 320 240
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

How I make sure that my NVidia is running ??
Regards :(

bob
23rd November 2004, 02:16 AM
Rpm - looks like it isn't working from what you've posted. You're going to have to edit your /etc/X11/xorg.conf to eliminate the "Lload 'dri'" under Module and change Driver 'nv' to Driver 'nvidia' under Device.

Quickest way to check if it's working? Try and run Tux Racer and see if it runs smoothly.

LinuxNewb
23rd November 2004, 03:57 PM
also you have Load 'glx' # out and it shouldnt be put # in front of Load 'dri'

also i updated my kernel and tried 6629 again, still isnt hopefully weill try modified 6111 later :)

DeusEx-Machina
23rd November 2004, 06:28 PM
:) This worked for me!!! Thanks for the help! Good job!

MikeyMike
23rd November 2004, 08:11 PM
i installed it with ease usin a lil bit of this way and the release notes

StefanT
23rd November 2004, 08:28 PM
Btw, using the 6111 drivers instead of the 6629 ones also has fixed my problem that the computer hang on boot in "initializing hardware". I mainly write this here for other desperates that search for the cause (like I was for some days now ;)

Kind regards,
Stefan

LinuxNewb
23rd November 2004, 08:39 PM
Stefan did you use the 6111 from Nvidias website or the recompilled one that viper posted earlier?

vipergts450
24th November 2004, 02:09 AM
I'm glad that those drivers helped so many of you. Has nVidia jumped on this issue yet? Are they even aware of it?

Psquared
24th November 2004, 02:35 AM
I'm glad that those drivers helped so many of you. Has nVidia jumped on this issue yet? Are they even aware of it?

The 6111 jp1 worked for me as well in FC2. However, I did get the following error when running the installer:
nvidia: module license "NVIDIA" taints kernel
However, it did install in kernel 2.6.9-1.6_FC2 and everything seems to be working.

I do think nVidia is aware of the problem. I have been on their Linux forum and there is a lot of discussion about it. We'll see if they release a new driver in the next few days or weeks.

kiram9
24th November 2004, 02:44 AM
i spent about 2 hours playing with my fedora core 2 install so i can get tvout working. This custom file is what i came up with, parts of it will definitally still apply to the newest version, Im going to update very soon....
Please note, after editing the file this way, do not run the display settings changer (gnome one or whatever) it will rewrite the file and screw up the settings...
Note, The only card i edited this file for was my NVIDIA gforceFX5200, which has an svideo connector and a regualr VGA connector. I have no clue what it will do on other cards.
1. What this file allows me to do.
It allows me to play computer games on my TV like unreal tournament 2004, or use Freevo, MythTV etc.
The TV out is automatically enabled when the resolution goes to 800x600 or 640x480.
It allows me to run 2 "Virtual" X sessions, one on my main monitor/tvout, OR manually starting a separate session that is only TV out!.
To start a tvout only session, you would switch to a virtual text console (CTRL-ALT-F1 through F6), and type in
startx --:1 -layout TVout
To switch between sessions you use the CTRL-ALT-f7 or F8 to switch between each session/ cant run both at once.
it allows the tv out to only be active when the screen resolution is 800x600 or 640x480
it also allows me to start another x session from the command line that only works with tvout, (not the monitor)

after using this file, you will be able to start a sepearate x session(with gnome etc) that only runs to your tv.

I found this much more flexable than having one or both enabled at the same time. And TV out is only running when you need it. (I usually run my resolution at 1024 and greater)

The important parts of this file are the end and the bery beginnning.

The way X works is it links each section together.
Layout llinks to the Screen, the screen links the display and the device. So, you can have multiple layouts, the one that is first in the file is executed first, unless it is overridden manually when you use the startx command.
Here is my custom file, origionally started from the autogenerated one.


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "CRT Layout"
Screen 0 "CRT" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerLayout"
Identifier "TVout"
Screen 0 "TV" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules/extensions"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Dell"
ModelName "Dell P991"
DisplaySize 370 270
HorizSync 30.0 - 107.0
VertRefresh 48.0 - 120.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "TV"
ModelName "Television"
HorizSync 30.0 - 50.0
VertRefresh 60.0 - 60.0
Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "COMPOSITE"
Option "ConnectedMonitor" "TV"
EndSection

Section "Device"
Identifier "NV AGP"
Driver "nvidia"
VendorName "nvidia"
BoardName "NVIDIA GeForce FX 5200"
Option "TwinView"
Option "SecondMonitorHorizSync" "30 - 50"
Option "SecondMonitorVertRefresh" "60.0 - 60.0"
Option "MetaModes" "1280x1024,; 1024x768,; 800x600,800x600; 640x480,640x480"
Option "TwinViewOrientation" "Clone"
Option "ConnectedMonitor" "CRT,TV"
EndSection

Section "Screen"
Identifier "CRT"
Device "NV AGP"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1200x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "TV"
Device "NV AGP"
Monitor "Monitor1"
DefaultDepth 24
Option "ConnectedMonitor" "TV"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

The important parts are the device section, monitor section and the layout sections. Make sure that you also have the GLX extension loaded to enable hardware acceleration. To adjust settings, use the nvidia-config utility to change the TV overscan, color, etc. Rember if you run the built in display configurator, it will really mess the file up, so none of these options will work, so make a backup after you get it working.
Play with tthis file more, the main parts to change if you want different functionality are the metamodes in the device section, and the Twinview orentation option. Also if you decide not to clone displays, run the Xenerama option. And for more detailed info, read the NVIDIA readme!! (It was still very confusing to me)
Good Luck!

LinuxNewb
24th November 2004, 05:22 AM
The 6111 jp1 worked for me as well in FC2. However, I did get the following error when running the installer:

However, it did install in kernel 2.6.9-1.6_FC2 and everything seems to be working.

I do think nVidia is aware of the problem. I have been on their Linux forum and there is a lot of discussion about it. We'll see if they release a new driver in the next few days or weeks.

The taints kernel message is like in windows when it says the license is not approved by microsoft , thats all it is saying nothing to worry about

LinuxNewb
24th November 2004, 05:39 AM
I FINALLY GOT IT WORKING!!! thanx so much viper

vipergts450
25th November 2004, 05:50 AM
:-D

Not bad for my first week here, eh? lol ;)

I'm glad I could help. This community seems really great and helpful and I only wish to continue that reputation.

Psquared
25th November 2004, 04:09 PM
The modified 6111 Nvidia driver i compiled/installed the other day suddenly stopped working with the new 2.6.9 FC2 kernel. It was working, but when I rebooted it stopped working. I can see the message during boot that indicates the nVidia driver did not load. I went back to the 2.6.8 kernel out of frustration.

I think I will wait until nVidia does something about this.

LinuxNewb
25th November 2004, 04:14 PM
i too have had problems, my system locks up after 15 mins of using nething graphical, like lbreakout

i have posted a new thread on that problem hoping we can get this solved

ggambett
25th November 2004, 05:41 PM
Same story for me... upgrade to FC3, 6629 drivers with permanent logo, now patched 6111 works but the system freezes randomly. Video card is GeForce MX 4000.

For those who made the 6111 drivers work, is the system stable for you?

I'm using the kernel that came with FC3. Did anyone try upgrading the kernel?

mrquestion
26th November 2004, 07:40 PM
Both "6629" and "6111" drivers does not work for me. However FC3 default driver "nv" works (?just?) OK, but original
nVidia drivers shows only black screen. X logs are clean, no warnings or errors. I tried quite a lot:
(*) NvAGP "0"
(*) copy ModeLine data from X log, when "nv" driver is working: ModeLine :"1280x960" 108.0 1280 1376 ...
(*) disable EDID detection by IgnoreEDID "on"
(*) different dispaly modes

Basically I decided to wait for another nVidia driver as others here, the only problem with the "nv" driver is
when I want to return back to run level 3 ( shutdown X ), screen is scrambled. Also, it displays 1280x960
on 1280x800, what is not too cool aswell.

nVidia GeFroce4 Go 32M [ 0x0176 PCI ], FC3 fresh install, LCD [?? DFP-0 ??], compaq nx9105, 1280x800, 15.4"

LinuxNewb
26th November 2004, 09:11 PM
ok i did a fresh re-installation and followed the instructions smfinley posted. The 6629 driver works now

except that after about 30-45 mins of playing a game (doesnt matter what type fo game opengl or just sumthing simple like Lbreakout2) my whole machine just locks up. i cant do anything except a hard reboot. has neone else had this problem??

Trefex
27th November 2004, 03:03 PM
Well I can't say for sure yet Mike but I know things are better than last night. I just followed your instructions thru and ssh terminal from work and things look good. The machine came back up :-)

Last night after the standard nvidia install I just got to Configuring Kernel Parameters... and the system would hang.


Thanks a bunch looks like the thing I was missing was the modprobe nvidia

Thanks again great Howto

Hi,

I have the exactly same issue, how can i boot back to my system in text mode and edit my xorg.conf file again, or is this coz something went wrong with the kernel?

Thanks

LinuxNewb
27th November 2004, 05:16 PM
when you system hangs pres CTRL-ALT-F1 to get to a term


i got the drivers working but now i hang when i play games after about half an hour , is anyone else expeirencing this?

Trefex
27th November 2004, 05:38 PM
Hi,

Well I did do a rescue mode and put my old xorg config file back. The modprobe is working fine after i installed the drivers, but after doing what the tut says, i rebooted and now it seems to start X ( no splash though ) and then hangs on a black screen, and then nothing happens anymore.

P4, 2.4 Ghz, 1024 MB RAM, Nvidia Gefore 5600 Go...

Thanks for helping me out,

leasure98
30th November 2004, 04:08 AM
Well, here I sit...another night trying to get my Nvidia to work. Installed and re-installed. Did everything in the posts and also tried the how-to's. 3 nights of this crap. FC2...no problems. What the
heck is going on? I've done this Nvidia thing ten times with success on FC1 and FC2. I know the process by heart. I guess I will give up and periodically check the forum. It's great that there's so much help here. I appreciate it. IMHO, there shouldn't be this many hoops to jump through to get this driver working. I installed MEPIS on another hard drive the other day. Had to download 1 file and bang! there is Nvidia pretty as a picture. In FC3, I get to the Nvidia splash screen, then a few seconds later the hourglass has a line in it and the x server is locked up. I can play if I want to by putting 1,000,000 mouse pointers all over the screen. Linux for the masses? Come on. If I've been using it for a year and can't get a common GPL driver to work, what's a newbie going to do? Give up and go back to Windows, that's what. I hate to sound so negative but my gosh I've put 20 hours into this thing...searching post after post on forum after forum to see if I've forgotten to do something or other.

Doritos
1st December 2004, 08:56 PM
OMG
i was looking for this
thanks

neilius
1st December 2004, 11:28 PM
Well it appears that Livna.org have released some rpms of the nVidia driver. I don't know how many other people have tried them but I have and they worked a treat. Installed in less than five minutes, no need to edit any files or get dirty with the terminal... Here's what to do:

Grab the yum.conf from the Fedora FAQ site (www.fedorafaq.org) and replace your original with that.

Open a terminal and type:

yum install nvidia-glx kernel-module-nvidia-`(uname -r)`

Reboot and you should see the nVidia splash screen. What happened to me was that I get the splash the second time X loads, but not for the boot up screen, so it appears the driver loads after everything else. Works a treat though and no problems to report as of yet!!!

Good luck,

Neil. :)

jgionet
2nd December 2004, 02:56 AM
right on!! thxs neilius !! woohoo
I was able to install the drivers no problem now on FC3 :)
now I see the NVIDIA drive for a split second when I boot up and I can see nvidia line in lsmod.
the other cool thing is I can finally play TuxRacer!!
I do sometime see some little "flickers" when I start new applications. Are there some "other" tweaks I have to do? or are these drivers still a little "buggy"?

thxs all.. this forum rocks.. and Fedora rocks!! BEST DISTRO I've ever worked/played with :p

fritzk3
2nd December 2004, 01:44 PM
I'm using FC3. I tried the 6629 package, modified xorg.conf, and got the "splash screen hang" that has been described. I then downloaded the "patched" 6111 drivers that vipergts recommended, but the install program barfed and claimed incompatibility with the kernel, and just quit.

I can't get the package available via yum (like Neilius mentioned) since I only have a wireless card, and ndiswrapper is being uncooperative.

All that being said, what other options do I have besides reinstalling? Is there any way someone can build the yum update into a .run or something? I'd really like to have GL support in FC3...

Thanks...
fritzk3 at gmail dot com

Finalzone
2nd December 2004, 08:27 PM
Read this post (http://www.fedoraforum.org/forum/showthread.php?t=28454). That way you can choose the repository of your package.

fritzk3
7th December 2004, 02:23 PM
OK... I tried the update that Neilius advertised (from livna.org), which installed without a problem, but upon reboot, I got the same old problem - I login, then type 'startx', get the nVidia splash screen, and it just hangs. It seems like there's nothing I can do to get the 6629 drivers working properly, and I may have to just give up hope of having a GL-enabled set of drivers, at least until nVidia gets things fixed.

- I've modified /etc/rc.local to include the modprobe statement
- I've modified /etc/X11/xorg.conf to remove the 'dri' line and ensure the 'glx' line is there
- I've even tried updating the kernel, same problem.

Is there anything else that I am missing here? Worst case, how do I go back to the 6111 drivers... just 'yum remove (current nvidia package)' and then download the 6111 package, and 'sh' the .run file?

Stevenisme
8th December 2004, 02:41 PM
will Fedora auto search my own graphical card?

Psquared
8th December 2004, 03:08 PM
OK... I tried the update that Neilius advertised (from livna.org), which installed without a problem, but upon reboot, I got the same old problem - I login, then type 'startx', get the nVidia splash screen, and it just hangs. It seems like there's nothing I can do to get the 6629 drivers working properly, and I may have to just give up hope of having a GL-enabled set of drivers, at least until nVidia gets things fixed.

- I've modified /etc/rc.local to include the modprobe statement
- I've modified /etc/X11/xorg.conf to remove the 'dri' line and ensure the 'glx' line is there
- I've even tried updating the kernel, same problem.

Is there anything else that I am missing here? Worst case, how do I go back to the 6111 drivers... just 'yum remove (current nvidia package)' and then download the 6111 package, and 'sh' the .run file?

Depends upon which FC kernel you are running. The 6629 driver is designed for the 2.6.9 kernels in FC2 and FC3, but as you see there are problems with it. If you want to go backwards to the 6111 driver you will have to use an earlier kernel in FC2. I don't think it (6111) will work in FC3 - unless you use the modified nVidia installer mentioned above. (I tried that and it wouldn't work for me.)

I use FC2, so I just went back to kernel 2.6.8-1.521 and re-installed the 6111 driver. I'll just wait there patiently until all of this is sorted out.

rejser
9th December 2004, 09:37 AM
I installed the nvidia drivers as described in the first post, and edited the /etc/X11/xorg.conf file as noted in the ReadMe. I rebooted the system, and instead of seeing the Red Hat Graphical Bootscreen I saw a giant NVidia-logo. This screen didn't disappear and therefore I removed the rhgb in /etc/grub.conf. Anyone have this similar problem? Since I haven't configured a lot, it's no big deal to re-install FC3 and wait for the rpms, but I'm always open for other solutions.

Have the exact same problem.

mage.merlyn
9th December 2004, 06:03 PM
Greetings all,

I am currently running Fedora Core 3, kernel 2.6.9-1.667, with nVidia module 6629-2.6.9-1.667 and it works a treat.

The only editing of my xorg.conf file required was to add the following lines under the [device] entry for my graphics card

Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "NvAGP" "1"

Other than that all I needed to do was to change run level to 3 then back to 5 again. Sweet. To install the drivers I just used 'smart' package manager which I installed via syanptic. Or you can get it from the Dag Apt/Yum Repository. Latest version is smart-0.28-1. Also check out Smart Package Manager (http://zorked.net/smart/doc/README.HTML#building-smart) and smartpm.org (http://www.smartpm.org)

One thing that I have done after the fact though is to remove the xorg-x11-Mesa-libGL package with rpm in the command line as mentioned in the orginal post for this thread from mike.

The thing that I am not sure about though is should I also remove the xorg-x11-Mesa-libGLU package as this does result in a number of dependency problems.

Cheers.

Beng
9th December 2004, 10:33 PM
Does anyone have a nvidia driver rpm with binaries? I can not compile atm due to lack of diskspace (one hd brokedown). All help will be appreciated.

Finalzone
9th December 2004, 10:36 PM
Go to http://rpm.livna.org. The repository has the latest version of rpm nvidia.

mike
9th December 2004, 10:40 PM
One thing that I have done after the fact though is to remove the xorg-x11-Mesa-libGL package with rpm in the command line as mentioned in the orginal post for this thread from mike.

The thing that I am not sure about though is should I also remove the xorg-x11-Mesa-libGLU package as this does result in a number of dependency problems.

I think this requirement is no longer needed, do to some fixes in that library.

Mike

rejser
10th December 2004, 09:31 AM
I belive that the logo issue are among them who uses an mx400/mx440 - graphics card

Beng
10th December 2004, 09:55 PM
Ok i did the yum install after i upgrade my kernel. Now on system boot it hangs with the message
Configuring Kernel Parameters...

What exactly do i need todo to get it running again and perhaps this driver working?
(i can get in using the rescue boot but from there i am clueless)

Beng
11th December 2004, 12:22 PM
Well since i didn't get an answer i went searching. Using rescue mode from cd i managed to access my lhd again, then i checked the /etc/X11 directory since i figured it was X that was stuck. Copied the backup xorg.xonf to xorg.xonf and rebooted. I got back in at that point.

Reading trough the forum again i concluded that running the yum install wasn't enough, still needed todo the modprob and copy steps. Completed those, and started x-windows again. Since i am now typing from my accelerated desktop seems i got it fixed.

Still, it clearly shows Fedora isn't ready yet for the average user, a clean install out of the ' box' should at the very least install last years populair videocards drivers without any hassle. But i have the feeling FC-3 is close, very close.

Thanks all who replied and posted here, for the spirit of the Linux community alone i would run the os :)

mage.merlyn
12th December 2004, 04:09 AM
Hi Beng, just to let you know, I moved over to Fedora after having used Mandrake for quite some time.

When installing FC3, as a fresh install it detected my nVidia graphics card 'out of the box', however it only loaded the generic drivers.

I was offline for some time and now that I have a current internet connection decided to upgrade the drivers, as well as other packages.

After becoming dissappointed with up2date, (very slow, I only have dialup), I searched around and decided to go with apt for rpm and synaptic.

While searching through synaptic I found a reference to "smart package manager". This is being developed by the same fellow who ported apt-get to rpm based distros and also wrote synaptic.

Getting back to the point, I installed the nVidia drivers on my system using "smart", (please see my previous post on this thread) Get smart (package manager) (http://www.fedoraforum.org/forum/showpost.php?p=139141&postcount=104)

In using smart to install the nVidia drivers and to install/update other packages I have experienced no problems to date.

I would reccommend that you try this approach.

deviant03
12th December 2004, 12:31 PM
whew, finally got the drivers working and played a little enemy territory :) Thanks for the instructions!

hank
30th December 2004, 07:09 PM
I have had the same problem as reported here. I have an AMD XP2400 system with MSI mb and NV GeForce card. After installing FC3 and the 6629 graphics driver, I startx manually and see the Nvidia logo followed by the Fedora logo...my mouse pointer works but at this point nothing else happens...the whole system hangs!!

THE CURIOUS THING is that I get this result when I startx from my own user (non-superuser) account. However, if I log in as root and then do a startx, everything works! I cleanly get through the startup into my normal X session (I am sendiing this message from such an X session).

This is very repeatable...startx from user account --> hangs. Startx from root account --> works!

Anyone else see this behavior??

cscheng
30th December 2004, 09:50 PM
Haven't noticed this before... but you don't have the same symptomps as everybody else with non-working drivers. You can actually even see the splash screen. My guess is that you haven't installed the drivers correctly. Make sure you have done all steps appropiately.

mrquestion
12th January 2005, 05:37 PM
I noted a desperate post earlier here. nvidia 6629 driver didn't work in FC3, compaq nx9105, 1280x800. Now it works: I downgraded to nvidia 6111 ( patched ), [see the complete discussion for more info]. and xorg.conf main idea is:
ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828

tajidinabd
13th January 2005, 02:52 AM
yea i agree with i have a Compaq laptop r3240us and the 6629 driver will not work worth a crap. Which kernel are u using now cause i tried the 2.6.10 kernel and nothing it doesnt work. if u could let me know about ur experience maybe something with this Compaq/HP laptops not working with this 6629.

kellerbl
13th January 2005, 05:57 AM
I've been trying to get the nvidia module/driver to work, but I seem to boot to the useless "Configuring Kernel Parameters...". When I boot to runlevel 3, I can modprobe nvidia and then startx and it works like a champ. I just can't seem to get the nvidia module to load automatically when I boot to runlevel 5. I've copied the module to /etc/udev/devices (step 11), but that didn't help. I've tried depmod -a, and many things, but the only thing that seems to work is to boot to level 3 and then load nvidia and run startx manually. I'm running FC3 and built kernel 2.6.10 just before installing the nvidia driver, which built the driver fresh since there were non already available. This is also x86_64.

How can I get the nvidia module to load automatically? I'm fairly certain I've got all the other files correct.

One other question: how can I get the screen to allow me to select 1920x1200 (the native resolution of my LCD monitor)? 1600x1200 seem to be the highest setting allowed.

Thanks.

doctorfish
13th January 2005, 08:09 AM
Nvidia troubles here. I followed all the instructions from nvidia and from this thread and when I type startx I get a no windows found error. The nvidia module doesn't load automatically so I have to type modprobe nvidia just before typing startx. This seems to work as the nvidia module then appears in the output of lsmod but I can't get X windows to load.

Has anyone else seen such an error?

Now I can't even get to KDE or Gnome at all. I then uninstalled the nvidia drive and tried to open /etc/X11/xorg.conf from the command line so the I could go back to the generic driver that worked. However, even though I was logged in as root, I got a permission denied error. I am still fairly new to Linux so maybe I'm trying to open the file wrong. Could anyone give me a suggestin as to how I can open the xorg.conf file and get my system working again?

Thanks.

Dave

tajidinabd
13th January 2005, 07:13 PM
Nvidia troubles here. I followed all the instructions from nvidia and from this thread and when I type startx I get a no windows found error. The nvidia module doesn't load automatically so I have to type modprobe nvidia just before typing startx. This seems to work as the nvidia module then appears in the output of lsmod but I can't get X windows to load.

Has anyone else seen such an error?

Now I can't even get to KDE or Gnome at all. I then uninstalled the nvidia drive and tried to open /etc/X11/xorg.conf from the command line so the I could go back to the generic driver that worked. However, even though I was logged in as root, I got a permission denied error. I am still fairly new to Linux so maybe I'm trying to open the file wrong. Could anyone give me a suggestin as to how I can open the xorg.conf file and get my system working again?

Thanks.

Dave



well i am for sure there is something wrong are u using that newest kernel the 2.6.10 one there is some problem so all they tell u is to use and older kernel til they get things working between the nvidia driver and the newest kernel.

doctorfish
14th January 2005, 01:23 AM
Thanks for the reply okplayer02. I guess a more detailed summary is in order.

I have a Compaq Presario R3000 AMD64 laptop with Ferora Core x86_64 installed. The computer works well with the generic "nv" driver and I can set the resolution to 1024x768 which looks fine. However I wanted the higher resolution I get when I boot into the Windows partition and also I have one problem with the display in Linux. Whenever I shut down or reboot the computer, the list of processes shutting down is all garbled and snowy. There's a line of green in there which I believe is the "OK" messages the computer puts out while shutting down. I was hoping this would be fixed by installing the nvidia driver. The computer otherwise shuts down fine thought.

So when installing the nvidia driver here's what I did:

1. Follow verbatim the instructions from the nvidia readme file. When I rebooted and typed startx I just got a black screen that hung and I had to type ctrl-alt-F1 to get out of it. That displayed the error message listed in my first post about not finding a window.

2. I then searched on the internet and found this site and thread and applied a few of the extra steps that nvidia makes no mention of.

rpm -e --nodeps xorg-x11-Mesa-libGL
modprobe nvidia
cp -a /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*

I rebooted again, typed startx and got the same result.
I uninstalled and reinstalled the driver this time following verbatim the instructions listed in the first post of this thread but again got the same result. I then tried the yum update, smartpm update, and the 6111 patch (as seen in this thread) none of which were even able to complete.

Yum and Smartpm had trouble connecting and I couldn't even open the downloaded 6111 bz2 patch file. tar -xzvf and bunzip2 did not work.

So then I thought I'd go back to the generic "nv" driver but not being exerienced with editing text files in the console I wasn't even sure how to do it. After a lot of hassle I finally figured out how to open and edit a file with vim so now I'm back to the generic driver and snowy shutdowns.

Has anyone else seen this problem with the generic drivers with having the shutdown process all garbled and snowy. I suppose I'll start a new thread about it in the AMD64 forum of this site.

Will take any suggestions.

Dave

mooncat
15th January 2005, 05:42 AM
Ok first of all I just jumped the windows ship and have toyed with linux before. I am gonna stick with it from now on so I guess I am noob to fedora.

I got my linux in a nutshell and woohoo off I went and managed to get the driver installed although I am not sure if it is working 100%. lsmod and it shows up in there and I get the nvidia screen at the beginning.

My laptop has nvidia FX Go5200 and supports WXGA but can`t seem to get my resolution bigger than 800x600.
I know on my windows environment that I got 1280x800 and would kinda like to recreate that here too.

I am not sure if it`s the driver or due to the fact my monitor isn`t recognised.
Basically just got fedora 3 and my kernel is 2.6.9 . I got a toshiba widescreen which is in the sattelite M30 series.

Appreciate if someone could point me in the right direction

BandC
17th January 2005, 03:42 AM
Ok, I ordered an EVGA GEForce FX 5200 which should arrive in a couple of days. I am currently running 2.6.10-1.741_FC3. Has anyone tried installing NVIDIA drivers and had good/bad results with the latest kernel? Also, which instructions should I go with? The "official" instructions on the NVIDIA web site or the instructions various people give in this thread? It looks like there are several differing instruction sets. Thanks.

lucaleroi
21st January 2005, 01:07 AM
--------------------------------------------------------------------------------

I've followed these Steps

1) a) Edit "/etc/inittab" =>

Change the id:5:initdefault to id:3:initdefault .

b) Edit "/etc/X11/Xorg.conf" => Look for the Driver "nv" change it to Driver "nvidia"

In the Module section, make sure to have: Load "glx"

Remove the following lines:
Load "dri"
Load "GLcore"

*save the following files*
*Reboot System*

2) Text Mode-Login screen. Login as root.
Change to the directory, where's the NVIDIA-Linux-x86-1.0-6629-pkg1.run file located.
Type sh NVIDIA-Linux-x86-1.0-6629-pkg1.run .

3) No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)

4) No precompiled kernel interface was found to match your kernel; this means that the installer will need to compile a new kernel interface. (Answer: OK)

5) WARNING: Your kernel was configured to include rivafb support as a loadable kernel module.
The rivafb driver conflicts with the NVIDIA driver; the NVIDIA kernel module will still be built and installed, but be aware that the NVIDIA driver will not be able to function properly if the rivafb module is loaded! (Answer: OK)

6) Wait for the Nvidia to finish the installation!

At the Text-Mode Login Screen.

a) Type modprobe nvidia.
b) Type cp -a /dev/nvidia* /etc/udev/devices
c) Type chown root.root /etc/udev/devices/nvidia*
d) Type reboot

7) At the Text-Mode Login Screen.

a) Type init 5

8) Edit the /etc/inittab => id:3:initdefault to id:5:initdefault


The result was that now, when I reboot, it freezes on the nvidia splash screen, although the mouse icon still moves

My PC
nvidia TNT 64
MB: Asus
80Gb (Win XP SP2 and 50Gb partition for fc3)

Any solutions?
Can you help me, please ?

mrtaber
30th January 2005, 01:10 AM
Dumb question, but since I don't play games, how do I tell if my 3D acceleration is working or not? I know that the OpenGL screen savers work. I'd prefer not to delete anything I don't have to.

Thanks,
Mark Taber

jackson21
31st January 2005, 05:26 PM
Super guide for install:
Am using a Fc3 with the updated kernel:
2.6.10-1.741_FC3.

Am sure it worls also with the FC3_64 version, which I uninstalled because of the hangs and freezes.
But, definitely I will also reinstall the FC3_64 version .

Very good documentation !!!!

jackson from Austria

Finalzone
31st January 2005, 08:26 PM
There is an esay way to install Nvidia driver.
On rpm.livna.org website, there is two packages to use:
-kernel-modules-nvidia
-nvidia-glx

Using firefox, download kernel-modules-nvidia first, the package manager(rpm version but future version will be based on yum according to developers) will handle the installation. Then, download nvidia-glx. Reset the X server.

That method saves the need to edit xorg.conf file.

For this quote

The result was that now, when I reboot, it freezes on the nvidia splash screen, although the mouse icon still moves
Could you provide the xorg.conf source, please?

semenzato
10th February 2005, 06:35 PM
I am using a stock FC2 kernel, but this thread seems to be the most active.

I am also having the problem described by several people on this thread.
The installer for build 6629 works fine and X starts with no errors, but only
the cursor is displayed. The rest of the screen is black. I downgraded
to build 6111 and everything seems to work (but I haven't tried any 3D
acceleration).

This is annoying since I have a completely unmodified installation of FC2:

[luigi@nero luigi]$ uname -a
Linux nero.semenzato.com 2.6.5-1.358 #1 Sat May 8 09:01:26 EDT 2004 x86_64 x86_6
4 x86_64 GNU/Linux
[luigi@nero luigi]$ cat /etc/issue
Fedora Core release 2 (Tettnang)
Kernel \r on an \m

My xorg.conf is also quite boring. I simply edited it according to the
installation instructions.

Writing software that works is hard, eh?

deliyana
13th February 2005, 08:38 PM
ok. look this answer ===> www.s__nvidia_fc3._i.com (linoczka.blox.pl/html)

nsteussy
16th February 2005, 12:42 PM
I have the same problem, with the Nvidia splash screen freezing (mouse still moves). I am using FC3_64 and have done a lot of testing. I can get it to work only with 2.6.9-1.667 (x86_64) kernel and the NVIDIA-Linux-x86_64-1.0-6111-pkg2.run package. Yes I have tried all the recommended tricks with loading the module manually and changing the read permissions and patching the NVIDIA driver. Indeed, I have the latest kernel and NVIDIA drivers working flawlessly on FC3 (32bit) installs on two other computers. I can only conclude that this problem is specific to the interaction of the FC3_86x_64 kernel and the NVIDIA x86_64 module.

duke out

Bigfatso
7th March 2005, 10:39 PM
Ok, Im on day 2 of linux. Please be gentle.

Followed the Nivdia Readme instructions, I got a "no useable window " fatal error.... somthing to that effect.

Did some searching found a nvidia Wiki.org site. It said run the nvidia installer with the --add-this-kernel switch, so I did this:
sh NVIDIA-Linux-x86-1.0-6629-pkg1.run --add-this-kernel

it created a new installer named:
NVIDIA-Linux-x86-1.0-6629-pkg1-custom.run

so I typed :
sh NVIDIA-Linux-x86-1.0-6629-pkg1-custom.run
Made it through the install. and I'm getting all warm and fuzzy inside.

typed Startx
nvidia splash screen comes up
X starts
Played TUX (very Smooth)
restarted my computer
typed startx
Got the "no useable window error" thingy again.

logged in as root
went to the installer directory
typed:
sh NVIDIA-Linux-x86-1.0-6629-pkg1-custom.run (again)
typed startx (again)
Nvidia Splash (again)
Xwindows starts (again)
Can do anything I want

Problem is: if I restart my computer, I have to log in as root and do the
sh NVIDIA-Linux-x86-1.0-6629-pkg1-custom.run command each time I restart.
this is kinda problematic.

How do I fix this????

Update:
ok I logged out of X. did an init 5 (I thought iit was the same as typing startx)
so it tried a few times to load X, then up pops the Xconfig utility (or whatever its called now)
Selected some options and Wallahhh! it works.

of course I can't play TUX racer for some reason. I click on the menu and nothing happens.

Anyone have an Idea how to fix that? (figured I'd ask since the last time I gave up and asked a question, a divine force invervened on my behalf and allowed me to stumble into the solution)

GoBroke
14th March 2005, 05:44 AM
Thank you all for the info. Am running FC2, but followed your directions and the ones at NVIDIA and it went pretty much without a hitch (once I managed to exit vim and save the changes).

Again, thank you for a very informative forum

Thomas Howard
15th March 2005, 07:12 AM
Hello.
I installed the nvidia drivers on FC3 recently using synaptic, and they seem to work perfectly, faster than without them even (FC3 is so fast compared to XP) but there is one slight problem, which is that anything that uses openGL or 3d, like Blender or Tuxracer flakes out with screen corruption when I run it, then shows the nvidia logo, then returns me to the login screen.

Its kind of annoying as I would like to have a look at blender or play tuxracer, but its hardly a showstopping problem.

Ed_Hunter
9th May 2005, 10:41 AM
for the command telinit "then the number"

i had to use this command /sbin/telinit "the number"

;)

Sunnz
28th May 2005, 03:08 AM
NVIDIA Install Instructions for FC3
Based on the Alternate Instructions for NVIDIA from fedorafaq.org
http://www.fedorafaq.org/custom_nvidia.html
rpm -e --nodeps xorg-x11-Mesa-libGL
NOTE: If you update any "xorg-x11" package with up2date or yum, you will have to do the above command again.

10. Load nvidia driver
modprobe nvidia

11. Set nvidia driver to load with udev.
cp -a /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*

Are you sure that these steps are necessary? I follwed through it yesterday, it works but very un-stable. I tried again today, with a fresh install of Linux, and apparently I forgot to do these steps. But now it works perfectly fine, very stable and lightling fast!

Razmoose
30th May 2005, 01:22 PM
I've followed all the instructions and help i can find, but I can't get my GeForce2 Go card working on my laptop, a dell inspiron 8000, under FC3.
I have the latest drivers from the nvidia website (NVIDIA-Linux-x86-1.0-7174-pkg1.run), but when i try to start the X server, the screen goes bright white, then fades to black, occasionally with coloured bands across it.
The log shows no errors, but does contain the following relevant warnings:

(WW) NVIDIA(0): The user specified VertRefresh "50.000-150.000" has been
(WW) NVIDIA(0): adjusted to "60.000" (the intersection with
(WW) NVIDIA(0): EDID-specified VertRefresh "60.000"

(WW) (1400x1050,Monitor0) mode clock 129MHz exceeds DDC maximum 120MHz

I am trying to use the default resolution of 1400x1050, which worked fine when i had windows 2000 installed on the machine.

This is the xorg.conf file:

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell D1025HE"
HorizSync 31.5 - 92.0
VertRefresh 50.0 - 150.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia GeForce 2 Go"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Subsection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
Subsection "Display"
Viewport 0 0
Depth 24
Modes "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection

jamie112
30th May 2005, 10:56 PM
Just a few quick shortcuts,

Restart X (inside X) Ctrl + Alt + Backspace
When using telinit 3 and the Anacron message is displayed either hit Ctrl Alt F1 (as shown earlier) or jsut hit enter a fe times (for impatient people ;)) Also if you dont have a printer installed (as I don't) just copy the directions into a text editator then once in text mode open it using nano, to refer back.

-Jamie

Razmoose
2nd June 2005, 04:07 PM
never mind, the most recent nvidia driver pacakge seems to work

strikeforce
3rd June 2005, 07:36 AM
There was an issue with EDID where the frequencies were incorrect. THe new ones from what I understand work however READ THE README since it doesn't work on old cards.

hank
4th June 2005, 01:24 PM
Has anyone succesffuly gotten FC3 to work with an MX440 vintage nvidia card? I can get the X server to start successfully as root but never as a non-root user. As non-root, I see the NV logo then the Fedora Splash screen and it freezes dead at that point. Root boots into X no problem. For information, I am attaching a screenshot of a diff of two Xorg.Log files...the one of the left is booting into X as root and works successfully. The one on the right boots as non-root and freezes. They both work from the same xorg.conf file. The key differences are highlighted in red.

TIA

strikeforce
7th June 2005, 01:43 AM
That would be possibly your udev devices.

chmod a+rw /etc/udev/devices/nvidia*

hank
10th June 2005, 09:51 PM
Strikeforce-

Thanks...however, I have previously implemented all the permission changes mentioned in your post and others on this board. Still the problem persists. It definitely has the look and feel of a permissions problem but I am stumped as to what is the issue.

xJlM
2nd July 2005, 04:24 PM
Stanton Finley has a real simple setup for installing the nVidia driver. Look at http://stanton-finley.net/ for more info...

hank
5th July 2005, 02:05 AM
yes...I have done everything indicated at that web site and the result is what I posted previously....as root the X server loads no problem....as non-root I cannot get X to load. Is this a persistent bug in the nvidia drivers? Has anyone out there gotten a GeForce MX440 card to work properly with FC3 or possibly FC4 for that matter???

strikeforce
5th July 2005, 10:29 AM
It could possibly be udev stuffing stuff around.

chmod a+x /etc/udev/devices/nvidia*

hank
7th July 2005, 03:07 AM
Strikeforce-

Why do you think I would have to add executable permissions on device files??

strikeforce
7th July 2005, 03:22 AM
I've seen it placed everywhere prior to so that a normal user can access those files. Because currently only root can read write and execute those files. What your saying seems like udev is not allowing you to access it.

http://fedora.redhat.com/docs/udev/

Have a look at that it explains it heaps better than what I could ever do.

hank
8th July 2005, 02:14 AM
Strikeforce-

Thanks...I'll check it out.

rclark
21st July 2005, 12:02 AM
Moving from one card to another in FC3. I had a catch 22 when adding in a 'new' NVidia card. Kernel would hang on boot as it was looking for old card (VIA on motherboard). Needed to boot with non graphical interface to load the new driver. Turns out all I had to do was temporary change the boot command options to the kernal via grub using the 'a' option . Replace the 'rhgb' option with a '3' (go to run level 3 on boot) and hit enter. This doesn't load the redhat graphical boot nor allow x-windows to start. From there you login and follow the normal install instructions "sh NVIDIA<version>.run and modify the xorg.conf file. That's it! No other files needed to be configured.... And when you reboot everything is as it was before the change....

See my thread (http://forums.fedoraforum.org/showthread.php?t=64659) for details ...

Personally, I think I will permanently remove the 'rhgb' as I don't see any purpose to it other than make it look 'pretty' :rolleyes: .