PDA

View Full Version : [TIP] vlc on F15


mmix
3rd April 2011, 03:18 PM
vlc works for F15 [pulseaudio-devel need]

faac 1.28
faad2 2.7
gpac
xvidcore
x264
yasm
lame 3.98.4
schroedinger
ffmpeg
vlc-1.2.0-git

$ export PKG_CONFIG_PATH=/usr/lib/pkgconfig/

http://cblfs.cross-lfs.org/index.php/FFmpeg

[ffmpeg configure]
$ ./configure --prefix=/usr/ --enable-shared --enable-pthreads --enable-gpl --enable-postproc --enable-x11grab --enable-nonfree --enable-libfaac --enable-libmp3lame --enable-libx264 --enable-libxvid

[vlc configure]
$ ./configure --prefix=/usr/ --disable-lua --disable-mad --disable-a52 --disable-qt4 --disable-skins2 --enable-pulse

DBelton
3rd April 2011, 03:25 PM
even easier..

enable the rpmfusion repos and do a yum install vlc :D

Installed Packages
Name : vlc
Arch : i686
Version : 1.1.8
Release : 1.fc15
Size : 5.1 M
Repo : installed
From repo : rpmfusion-free-rawhide
Summary : The cross-platform open-source multimedia framework, player and
: server
URL : http://www.videolan.org
License : GPLv2+
Description : VLC media player is a highly portable multimedia player and
: multimedia framework capable of reading most audio and video
: formats as well as DVDs, Audio CDs VCDs, and various streaming
: protocols. It can also be used as a media converter or a server to
: stream in uni-cast or multi-cast in IPv4 or IPv6 on networks.

(that is great info you posted above.. If someone wants the latest version of vlc, then they would have to compile as you did above.)

Gubakha Instagram Photos - Luanda - Kurchatov Travel Photos