PDA

View Full Version : screen sleep ( dim+lock too fast)


evilgawd
25th March 2011, 04:48 PM
Hi ,

I was wondering if someone had encounter this problem.

When i log into F15, every 5-6 seconds of inactivity ( mouse or kb) it start to dim the screen and lock the screen . While locking the screen is a good thing , 5-6 seconds of inactivity to lock a screen is nuts ! ;)

Ive checked the usual thing and i have put every setting to the max length.

Any ideas ?

Thank

jpollard
25th March 2011, 05:10 PM
Not sure about the F15, but this is normally part of your screensaver configuration, and you should be able to adjust that.

evilgawd
25th March 2011, 05:18 PM
afaik , screensaver are out of gnome3 in F15.

jpollard
25th March 2011, 05:41 PM
The only other possiblity is the DPMS of the X server.

You can try "xset -dpms" which should disable it. This will give a test to see if this is what is blanking your screen.

If you want the DPMS (and this is what is causing the blanking) then
you can use "xset +dmps dpms 10 20" which should set the standby timer to 10 seconds, and turn the display off after 20.

The manpage isn't complely clear but it is described in the "xset" documentation.

evilgawd
25th March 2011, 05:46 PM
Same behavior :/

Im thinking it could be a setting in gnome3 ... :/

GoinEasy9
25th March 2011, 05:49 PM
I have my screensaver settings set for 1 hour ... after updates last night, if, I don't keep the mouse moving, the screen starts to dim after about 30 seconds. I'll wait until I get home tonight and see what updates. No need to try and fix something that will be fixed by a quick update. I see that some of the gnome problems have updates that are already pushed.

marko
25th March 2011, 06:07 PM
You can quickly see what the dpms settings are for your display by running xset -q in a terminal:

$> xset -q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
XKB indicators:
00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 204 repeat rate: 45
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 20/10 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 600
Colors:
default colormap: 0x20 BlackPixel: 0 WhitePixel: 16777215
Font Path:
catalogue:/etc/X11/fontpath.d,built-ins
DPMS (Energy Star):
Standby: 1800 Suspend: 2700 Off: 0
DPMS is Enabled
Monitor is On

williamove
25th March 2011, 06:43 PM
I noticed this as well. To correct it I went to "Screen" section of the system settings and unchecked the box "Dim when idle". Closed it, then re-opened "Screen" settings once again and checked the box "Dim when idle".

That seems to have put it back to its previous behavior of dimming then screen after ~1 minute of inactivity. My guess is the update must destroy the preferences for this and toggling the setting for "Dim" re-creates it.

bill

evilgawd
25th March 2011, 09:14 PM
I noticed this as well. To correct it I went to "Screen" section of the system settings and unchecked the box "Dim when idle". Closed it, then re-opened "Screen" settings once again and checked the box "Dim when idle".

That seems to have put it back to its previous behavior of dimming then screen after ~1 minute of inactivity. My guess is the update must destroy the preferences for this and toggling the setting for "Dim" re-creates it.

bill

Didnt work here :/

rcbeerman
26th March 2011, 05:13 AM
org.gnome.desktop.session idle-delay appears to be the culprit.

According to http://people.gnome.org/~bmsmith/gconf-docs/C/gnome-screensaver.html
it this value defaults to 10, which is "The number of minutes of inactivity before the session is considered idle."

However, on my machine, it appears that this parameter actually configures the number of seconds:

$ gsettings get org.gnome.desktop.session idle-delay
uint32 10

(And sure enough, after 10 seconds of inactivity I see dbus traffic indicating idle status)

so, from the shell, to change it to 1 minute:
$ gsettings set org.gnome.desktop.session idle-delay 60

If that doesn't work for you, it appears that you can also deactivate idle-activation with the command
$ gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

I don't at this time know enough about the gnome stack to provide an elegant solution.

jaminJay
26th March 2011, 08:57 AM
Thanks rcbeerman! This appears to have worked!

I was wondering why the speech-bubble next to my user control would change to an elipsis shortly before locking. Lots of focus stealing, too, which appears to have stopped as well.

evilgawd
26th March 2011, 04:27 PM
Make sense, altho mine seem to be stuck in some read-only mode for some reason ....

**update+ reboot fixed the issue, i was then able to set it :D


$ gsettings get org.gnome.desktop.session idle-delay
uint32 5
$ gsettings set org.gnome.desktop.session idle-delay 600
$ gsettings get org.gnome.desktop.session idle-delay
uint32 5
$ gsettings set org.gnome.desktop.screensaver idle-activation-enabled false
$ gsettings get org.gnome.desktop.session idle-delay
uint32 5

org.gnome.desktop.session idle-delay appears to be the culprit.

According to http://people.gnome.org/~bmsmith/gconf-docs/C/gnome-screensaver.html
it this value defaults to 10, which is "The number of minutes of inactivity before the session is considered idle."

However, on my machine, it appears that this parameter actually configures the number of seconds:

$ gsettings get org.gnome.desktop.session idle-delay
uint32 10

(And sure enough, after 10 seconds of inactivity I see dbus traffic indicating idle status)

so, from the shell, to change it to 1 minute:
$ gsettings set org.gnome.desktop.session idle-delay 60

If that doesn't work for you, it appears that you can also deactivate idle-activation with the command
$ gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

I don't at this time know enough about the gnome stack to provide an elegant solution.

Quetta Travel Photos - Krasnodar Travel Photos on Instagram - Tajikistan -