PDA

View Full Version : LXDE Error


jonathan47
12th March 2011, 06:41 PM
I added LXDE to my existing F14 Gnome system and when logging into LXDE receive the following error:

GDBus.Error:org.freedesktop.PolicyKit1.Error.Faile d: An authentication agent already exists for the given subject

Any suggestions?

PabloTwo
12th March 2011, 08:14 PM
A couple of weeks ago I did a "yum groupinstall LXDE" on my F12 XFCE system and ran into the same error message. If I recall correctly, I solved that by doing:
rpm --nodeps -e lxpolkit
Everything still ran OK in an LXDE session after doing so. It seemed it was conflicting and competing with an already installed gnome-polkit package.

jonathan47
12th March 2011, 11:21 PM
Thanks for your suggestion. After poking around, I found an open bug on this issue:

https://bugzilla.redhat.com/show_bug.cgi?id=657006

While a fix is still in the works, comment # 6 suggests "go into 'Preferences->Desktop
Session Settings' and un-check 'PolicyKit Authentication Agent' as LXDE runs
it's own LXPolKit Authentication Agent."

It works for me, at least for now.

PabloTwo
13th March 2011, 12:34 AM
Thanks for that workaround suggestion. I didn't look into the problem because I only kept LXDE on my hdd for about a day. Not being overly impressed, I uninstalled all the programs the 'groupinstall LXDE' brought in. However, I did notice in the grub menu session selector, while LXDE was onboard, that there were also choices for openbox-gnome and openbox. That tweaked my curiosity.

I installed just openbox, and have been having a blast creating a whole new desktop ever since. Haven't booted back into XFCE since doing so either. :)

Santa Rita do Sapucai Photos on Instagram - Ventspils Travel Photos on Instagram - Tuguegarao City Photos