PDA

View Full Version : httpd (apache) in FC3 throws 403s everywhere


yellowbkpk
25th October 2004, 06:11 PM
Hi Forums,

I dumbly installed FC3 onto a machine I have limited physical access to (it's at home and I'm at school).

The problem is that if I move a file from my user directory (~USER, for example) to the html dir (/var/www/html, for example), and try to access it by browsing to http://foo.com/filename.avi, I get a 403 (and a 403 while trying to use an ErrorDocument to handle the request). I've tried all sorts of combinations for permissions on all the dirs leading up to /var/www/html and changed owners of the file - nothing seems to work.

I also get the same problem when trying to put anything in the ~USER/public_html dir. I have UserDir enabled and have done everything I needed to do in FC2 to get UserDirs to work.

Any ideas?

Thanks,
Ian

ewdi
25th October 2004, 06:15 PM
can you try set the file user and group to nobody (where apache var/www/html files usually belongs to)

Anotehr way you can try this
Add this first
Alias /main/ /home/username/public_html/

and inside the virtual host

AddType application/x-httpd-php .php .phtml .php3
AddType application/x-httpd-php-source .phps
User username
Group username
<Directory "/home/user/public_html/">
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
DirectoryIndex index.php index.shtml index.htm index.html index.cgi
</Directory>

so access your files inside your home public with domain.com/main/yourfiles.xxx

let me know if it works

yellowbkpk
25th October 2004, 08:49 PM
Well yum decided to nuke my FC3t3 install, so I guess I'm back to square one (minus the ability to fix it because I am 400 miles away).

Doh.

Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram