PDA

View Full Version : [SOLVED] install ok, but boot failed


catch22
21st November 2010, 12:30 AM
I have 2 Debian OS's and wanted to put Fedora next to it.
Install went ok, but after rebooting it says:
"No root device found. Boot has failed, sleeping forever."

During install from the live CD I didn't "v" the boot (efi or something?) because I thought Grub would take care of everything.

Should I just reinstall again and choose the Fedora bootloader?
Won't it mess up Grub?

glennzo
21st November 2010, 01:00 AM
Does any OS boot? Does Debian boot? You may be able to edit your bootloader to repair Fedora's boot issues.

catch22
21st November 2010, 01:23 AM
Does any OS boot? Does Debian boot? You may be able to edit your bootloader to repair Fedora's boot issues.
Yes, Ubuntu and Crunchbang both boot.
I do notice that they both have a "recovery" option in boot also, while Fedora doesn't.

I did a Grub-update, and Fedora is in Grub, but after booting some 20-30 lines of text how up and then I get the error message about "sleeping forever".

I didn't pick Fedora's bootloader option during install, thinking Grub would handle it.

glennzo
21st November 2010, 01:35 AM
Ubuntu's grub will, and apparently has, added Fedora to the mix. Are you saying that you chose to not install a boot loader during the Fedora install process?

catch22
21st November 2010, 01:45 AM
Ubuntu's grub will, and apparently has, added Fedora to the mix. Are you saying that you chose to not install a boot loader during the Fedora install process?Exactly.
I guess I should have? Is there a way to fix this :confused:

glennzo
21st November 2010, 02:13 AM
Boot with the Fedora installation DVD. Choose rescue mode and install Fedora's boot loader. Then figure out how to boot Ubuntu with Fedora's legacy grub.

catch22
21st November 2010, 12:21 PM
Boot with the Fedora installation DVD. Choose rescue mode and install Fedora's boot loader. Then figure out how to boot Ubuntu with Fedora's legacy grub.I booted with the CD again, but didn't see any "rescue"-option anywhere on the way. I simply continued a fresh install and updated.
Now Fedora boots fine, but I don't see Grub passing along, so I can't boot into Ubuntu or Crunchbang.

Will sudo update-grub work? Or am I in trouble?
EDIT: I might try the following? (from http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/s1-rescuemode-boot.html )

*
Boot the system from an installation boot medium.
*
Type linux rescue at the installation boot prompt to enter the rescue environment.
*
Type chroot /mnt/sysimage to mount the root partition.
*
Type /sbin/grub-install bootpart to reinstall the GRUB boot loader, where bootpart is the boot partition (typically, /dev/sda).
*
Review the /boot/grub/grub.conf file, as additional entries may be needed for GRUB to control additional operating systems.
*
Reboot the system.

glennzo
21st November 2010, 12:38 PM
No. That command is for a system running GRUB2, like the new Ubuntus. Is Windows available in the boot menu?

Anyhow, you have 2 choices. Figure out how to boot Ubuntu with Fedora's legacy GRUB, which is what your Fedora system is using. This is documented here in this forum if I'm not mistaken and is contingent upon Ubuntu's GRUB being installed in Ubuntu's boot partition IIRC. I don't think that's the case for you though. The other option is to reinstall Ubuntu's GRUB using the Ubuntu Live CD. This may also be documented here but I'm not sure. Here's a link that should prove to be extremely helpful for reinstalling GRUB2. https://help.ubuntu.com/community/Grub2 Scroll way down the page to where there is a heading that says Reinstalling Grub 2. There are several methods outlined. Personally, I use method 3 - chroot. This has worked extremely well for me in the past. Don't be intimidated by all the commands. It's really pretty simple and only takes 5 minutes. Your reward will be a system that boots all three OS's. The only downside to using Ubuntu's GRUB2 is that if there's a Fedora kernel update you need to boot Ubuntu and run sudo update-grub before you will be able to take advantage of, and boot into, the new Fedora kernel.

So there you have it. This is what I know about multi-booting Linux systems that use 2 different versions of the grub boot loader. It works for me and it works very well. Others may (hopefully) poke their heads in here and tell us that there's a much simpler method. If they do we will both learn something new.

catch22
21st November 2010, 01:18 PM
... Is Windows available in the boot menu?
...
reinstall Ubuntu's GRUB using the Ubuntu Live CD...I don't have Windows on the machine :p
Thanks for your help; I'll see if the chroot method works with Crunchbang, because that's the OS that "rules" Grub on my machine, I think.

glennzo
21st November 2010, 01:20 PM
I don't have Windows on the machine :p
Thanks for your help; I'll see if the chroot method works with Crunchbang, because that's the OS that "rules" Grub on my machine, I think.
What version of GRUB does Crunchbang use? If it's GRUB2 you can in fact use sudo update-grub and should easily be able to get Ubuntu added.

catch22
21st November 2010, 01:49 PM
What version of GRUB does Crunchbang use? If it's GRUB2 you can in fact use sudo update-grub and should easily be able to get Ubuntu added.That is indeed the plan, to first try sudo update-grub and hope for the best :)

---------- Post added at 01:49 PM GMT ---------- Previous post was at 01:27 PM GMT ----------

So, I put in the Crunchbang live CD and opened a terminal.
sudo update-grub
gave me: bash: update-grub: command not found

I didn't get very far with the chroot-method either.
sudo fdisk -l didn't detect /dev/sda, which I believe is my "normal system partition" (if I interpret that right - it's where Crunchbang is installed)

df -Th. gave me: df: invalid option

Looks like I'm stuck now :-(

EDIT: BTW, I never see a Grub splash screen when booting Fedora - is that normal behaviour?

glennzo
21st November 2010, 01:54 PM
No. You're not stuck. What version of GRUB does Crunchbang use? If it's legacy grub
[root@satellite yum.repos.d># grub --version
grub (GNU GRUB 0.97)
then there is no update-grub command. That is only for GRUB2, so you would need to manually add the other OS's.

Let's take a few steps backwards. What is installed on the computer for OS's? What boots and what doesn't? What's the last OS you installed?

glennzo
21st November 2010, 01:55 PM
EDIT: BTW, I never see a Grub splash screen when booting Fedora - is that normal behaviour?

Yes. These days the timeout parameter in the menu is "0" so it typically boots right into Fedora.

catch22
21st November 2010, 02:15 PM
No. You're not stuck. What version of GRUB does Crunchbang use? If it's legacy grub
[root@satellite yum.repos.d># grub --version
grub (GNU GRUB 0.97)
then there is no update-grub command. That is only for GRUB2, so you would need to manually add the other OS's.

Let's take a few steps backwards. What is installed on the computer for OS's? What boots and what doesn't? What's the last OS you installed?Not sure what Grub-version Crunchbang uses, but sudo update-grub normally does work (just in the live-CD it didn't).

Installed are:
Crunchbang statler (Debian Squeeze)
Ubuntu 10.10 Maverick Meerkat
Fedora 14

At present the only OS that boots is Fedora, because I don't get to see the Grub splash to pick another OS.
Fedora is the last one installed.

smr54
21st November 2010, 02:23 PM
ISTR that Rahul mentioned somewhere, if there are other systems, you do get a chance to enter grub. I wonder if it is a 0 timeout or just hidden?

I'm pretty sure that #!Crunchbang still uses legacy grub.

glennzo
21st November 2010, 02:32 PM
@smr54. Forgot about hiddenmenu.

@catch22. Maybe the first thing you want to do is change Fedora's boot menu behavior. Open a terminal as root
su -
<password>
Edit the text file.
nano /boot/grub/grub.conf
Remove the line that says hiddenmenu and change the line that reads timeout=0 to timeout=10. This will allow you to see a menu and have 10 seconds to make a choice.

catch22
21st November 2010, 02:41 PM
@smr54. Forgot about hiddenmenu.

@catch22. Maybe the first thing you want to do is change Fedora's boot menu behavior. Open a terminal as root
su -
<password>
Edit the text file.
nano /boot/grub/grub.conf
Remove the line that says hiddenmenu and change the line that reads timeout=0 to timeout=10. This will allow you to see a menu and have 10 seconds to make a choice.

it says "command not found":
[root@d54C6E5DA ~]# nano /boot/grub/grub.conf
Commando niet gevonden.
* Afbreken.. The search was cancelled as it was taking too long to complete.
You can increase the value of 'MaxSearchTime' in /etc/PackageKit/CommandNotFound.conf to change the timeout. (btw my former reply is waiting for moderator's approval, hence the delay)

glennzo
21st November 2010, 02:48 PM
I don't see anything moderated.

Why do you get command not found? How can that be?

Try ls /boot/grub/ and see if grub.conf is there. This is Fedora, right?

Got to go out for a bit. Be back in an hour.

catch22
21st November 2010, 03:05 PM
I don't see anything moderated.

Why do you get command not found? How can that be?

Try ls /boot/grub/ and see if grub.conf is there. This is Fedora, right?

Got to go out for a bit. Be back in an hour.Strange... I definitely got a message about that post waiting for moderation.
Anyway, it turns out the command was not found because nano wasn't installed -doh- :)
I changed the grub.conf and will know the result in a few minutes...

EDIT: so now I do see the splash.
I see the same Fedora twice, but not one of them has (recovery) behind the name, as would be suspected (I think?)
The other OS's are not there, so I tried sudo update-grub but it says I'm not in the sudoers file.

glennzo
21st November 2010, 04:09 PM
OK, the reason that there are 2 Fedoras is because there was likely a kernel update. The new kernel gets added to Fedora's boot menu automatically. The top most one is the newest kernel so you should use that one, however, the older one will still work. You won't see anything about "recovery" in the boot menu, at least not with Fedora. Let's try to get your Crunchbang Linux back into the mix. Do the following in a terminal as root.
fdisk -l
Post the result of the output here please. My replies may be slow as I have things to do and can no longer just sit in front of the computer but I'll keep checking in periodically.

catch22
21st November 2010, 04:20 PM
OK, the reason that there are 2 Fedoras is because there was likely a kernel update. The new kernel gets added to Fedora's boot menu automatically. The top most one is the newest kernel so you should use that one, however, the older one will still work. You won't see anything about "recovery" in the boot menu, at least not with Fedora. Let's try to get your Crunchbang Linux back into the mix. Do the following in a terminal as root.
fdisk -l
Post the result of the output here please. My replies may be slow as I have things to do and can no longer just sit in front of the computer but I'll keep checking in periodically.
Thanks for explaining.
As for the sudoers file problem, I remembered that su - will get me into root in Fedora; will have to get used to that. So here's the output (I can translate any parts, if you want):

Schijf /dev/sda: 40.0 GB, 40020664320 bytes
255 koppen, 63 sectoren/spoor, 4865 cilinders, totaal 78165360 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes

Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x0006ce91

Apparaat Opstart Begin Einde Blokken ID Systeem
/dev/sda1 * 2048 12333055 6165504 83 Linux
/dev/sda2 24764414 78156224 26695905+ 5 uitgebreid
/dev/sda3 12333056 13357055 512000 83 Linux
/dev/sda5 73920512 78155775 2117632 82 Linux wisselgeheugen
/dev/sda6 24766464 49149951 12191744 83 Linux
/dev/sda7 51873792 73918463 11022336 83 Linux

Partitietabel-items liggen niet in schijfvolgorde.

Schijf /dev/sdb: 120.0 GB, 120034123776 bytes
255 koppen, 63 sectoren/spoor, 14593 cilinders, totaal 234441648 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes

Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x90909090

Apparaat Opstart Begin Einde Blokken ID Systeem
/dev/sdb3 63 234436544 117218241 83 Linux

Schijf /dev/sdc: 82.3 GB, 82348277760 bytes
255 koppen, 63 sectoren/spoor, 10011 cilinders, totaal 160836480 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes

Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x8f8000b0

Apparaat Opstart Begin Einde Blokken ID Systeem
/dev/sdc1 * 63 160826714 80413326 83 Linux

glennzo
21st November 2010, 04:30 PM
There a ton of possibilities as far as where Crunchbang is installed. Do you know what drive / partition it is on?

Oh, post the content of Fedora's /boot/grub/grub.conf too please.
cat /boot/grub/grub.conf

Just so you know, this may be a somewhat long process of discovery. We need to know where Crunchbang is installed so we can get the grub.conf or menu.lst info from it and add it to Fedora's grub.conf, assuming Crunch uses legacy grub.

catch22
21st November 2010, 04:50 PM
There a ton of possibilities as far as where Crunchbang is installed. Do you know what drive / partition it is on?

Oh, post the content of Fedora's /boot/grub/grub.conf too please.
cat /boot/grub/grub.conf

Just so you know, this may be a somewhat long process of discovery. We need to know where Crunchbang is installed so we can get the grub.conf or menu.lst info from it and add it to Fedora's grub.conf, assuming Crunch uses legacy grub.gparted says Crunchbang is on /dev/sda1
[root@d54C6E5DA ~]# cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/sda7
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
# hiddenmenu
title Fedora (2.6.35.6-48.fc14.i686)
root (hd0,2)
kernel /vmlinuz-2.6.35.6-48.fc14.i686 ro root=UUID=842cec7e-441d-4b96-8762-a9e36f5a4d17 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=nl_BE.UTF-8 KEYBOARDTYPE=pc KEYTABLE=be-latin1 rhgb quiet
initrd /initramfs-2.6.35.6-48.fc14.i686.img
title Fedora (2.6.35.6-45.fc14.i686)
root (hd0,2)
kernel /vmlinuz-2.6.35.6-45.fc14.i686 ro root=UUID=842cec7e-441d-4b96-8762-a9e36f5a4d17 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=nl_BE.UTF-8 KEYBOARDTYPE=pc KEYTABLE=be-latin1 rhgb quiet
initrd /initramfs-2.6.35.6-45.fc14.i686.img
I can get to my Crunchbang files BTW, so I can also post the contents of it's grub.conf
It is very very long though, so I'll do it in a separate reply.

---------- Post added at 04:50 PM GMT ---------- Previous post was at 04:45 PM GMT ----------

...and here's the content of grub.cfg on Crunchbang:
[root@d54C6E5DA grub]# cat grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
set saved_entry=${prev_saved_entry}
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z ${boot_once} ]; then
saved_entry=${chosen}
save_env saved_entry
fi
}
insmod ext2
set root='(/dev/sdb,1)'
search --no-floppy --fs-uuid --set 84a1185e-1bd8-4292-8823-1f016845bdc0
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
insmod ext2
set root='(/dev/sdb,1)'
search --no-floppy --fs-uuid --set 84a1185e-1bd8-4292-8823-1f016845bdc0
set locale_dir=($root)/boot/grub/locale
set lang=nl
insmod gettext
set timeout=9
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod ext2
set root='(/dev/sdb,1)'
search --no-floppy --fs-uuid --set 84a1185e-1bd8-4292-8823-1f016845bdc0
insmod png
if background_image /usr/share/images/desktop-base/grub-splash-crunchbang.png ; then
set color_normal=white/black
set color_highlight=black/white
else
set menu_color_normal=white/black
set menu_color_highlight=black/white
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "CrunchBang Linux, with Linux 2.6.32-5-686" --class crunchbang --class gnu-linux --class gnu --class os {
insmod ext2
set root='(/dev/sdb,1)'
search --no-floppy --fs-uuid --set 84a1185e-1bd8-4292-8823-1f016845bdc0
echo Loading Linux 2.6.32-5-686 ...
linux /boot/vmlinuz-2.6.32-5-686 root=UUID=84a1185e-1bd8-4292-8823-1f016845bdc0 ro quiet
echo Loading initial ramdisk ...
initrd /boot/initrd.img-2.6.32-5-686
}
menuentry "CrunchBang Linux, with Linux 2.6.32-5-686 (recovery mode)" --class crunchbang --class gnu-linux --class gnu --class os {
insmod ext2
set root='(/dev/sdb,1)'
search --no-floppy --fs-uuid --set 84a1185e-1bd8-4292-8823-1f016845bdc0
echo Loading Linux 2.6.32-5-686 ...
linux /boot/vmlinuz-2.6.32-5-686 root=UUID=84a1185e-1bd8-4292-8823-1f016845bdc0 ro single
echo Loading initial ramdisk ...
initrd /boot/initrd.img-2.6.32-5-686
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Ubuntu, with Linux 2.6.35-22-generic (on /dev/sdb6)" {
insmod ext2
set root='(/dev/sdb,6)'
search --no-floppy --fs-uuid --set 29d9abed-fec8-4f53-b62b-d05051f7406b
linux /boot/vmlinuz-2.6.35-22-generic root=UUID=29d9abed-fec8-4f53-b62b-d05051f7406b ro quiet splash
initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry "Ubuntu, with Linux 2.6.35-22-generic (recovery mode) (on /dev/sdb6)" {
insmod ext2
set root='(/dev/sdb,6)'
search --no-floppy --fs-uuid --set 29d9abed-fec8-4f53-b62b-d05051f7406b
linux /boot/vmlinuz-2.6.35-22-generic root=UUID=29d9abed-fec8-4f53-b62b-d05051f7406b ro single
initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry "Fedora release 14 (Laughlin) (on /dev/sdb7)" {
insmod ext2
set root='(/dev/sdb,7)'
search --no-floppy --fs-uuid --set 25e74a61-eb46-4893-b156-48c8ed642484
linux /boot/vmlinuz-2.6.35.6-45.fc14.i686 root=/dev/sdb7
initrd /boot/initramfs-2.6.35.6-45.fc14.i686.img
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
EDIT: oops - notice I got the wrong file here, sorry - I'll find the correct one. EDIT2: shucks, I'm confusing myself now - it is the only file I can find that looks like grub.conf - notice it's called grub.cfg though. sorry for the panic ;-)

glennzo
21st November 2010, 04:50 PM
You can get to those files? Great! All you need is the first stanza from it's grub.conf.
title ***************
root (hdx,x)
kernel= **********
initrd=*********

Those 4 lines added to Fedora's boot menu should allow you to boot Crunch.

catch22
21st November 2010, 05:21 PM
You can get to those files? Great! All you need is the first stanza from it's grub.conf.
title ***************
root (hdx,x)
kernel= **********
initrd=*********

Those 4 lines added to Fedora's boot menu should allow you to boot Crunch.

I don't see those lines in the grub.cfg though :confused:

On the Crunchbang forum I noticed a post mentioning where Ubuntu had overtaken the MBR (master boot or something) and they said sudo grub-setup would fix it (meaning Crunchbang would be 1st option again at boot) but in my terminal it says grub-setup: command not found.

glennzo
21st November 2010, 05:24 PM
Yes. I haven't checked but from what you've posted I'm seeing GRUB2 coming at me. You can't run a command on a system that isn't running, so to be able to run sudo update-grub for Crunch, first Crunch needs to be running. Best thing for you to do is check out how to reinstall Crunchbang's boot loader. That will be the fastest and easiest thing to do if you want to get these three OS's booting.


Back in post #8 I gave you a link to reinstall the Ubuntu boot loader. There must be a similar page to reinstall Crunch's boot loader, maybe on the Crunch forum?

catch22
21st November 2010, 05:49 PM
Yes. I haven't checked but from what you've posted I'm seeing GRUB2 coming at me. You can't run a command on a system that isn't running, so to be able to run sudo update-grub for Crunch, first Crunch needs to be running. Best thing for you to do is check out how to reinstall Crunchbang's boot loader. That will be the fastest and easiest thing to do if you want to get these three OS's booting.


Back in post #8 I gave you a link to reinstall the Ubuntu boot loader. There must be a similar page to reinstall Crunch's boot loader, maybe on the Crunch forum?okido, I'll check it out on the Crunchbang forum.
Thanks for your help - much appreciated!

glennzo
21st November 2010, 05:59 PM
Good. Meanwhile be happy with the fact that Fedora works even if the others don't. At least you have a working system. There is no deadline for getting the others back up and running so don't be too hasty with your decisions.

catch22
21st November 2010, 10:58 PM
Good. Meanwhile be happy with the fact that Fedora works even if the others don't. At least you have a working system. There is no deadline for getting the others back up and running so don't be too hasty with your decisions.True, it's good to have at least one system working.
On the Crunchbang forum sudo yum install update-grub and then sudo update-grub was suggested. The result wasn't too great [root@d54C6E5DA ~]# sudo yum install update-grub
Loaded plugins: langpacks, presto, refresh-packagekit
Adding nl_BE to language list
Setting up Install Process
No package update-grub available.
Error: Nothing to do
[root@d54C6E5DA ~]# sudo update-grub
sudo: update-grub: command not found
I'm thinking there must be a proper way to update Grub in Fedora though? And wouldn't that add the 2 other OS's automatically?

glennzo
21st November 2010, 11:05 PM
There is no update-grub command for Fedora unless you've installed grub2 for Fedora. That is not recommended since it's still in the experimental stages.

The only way, as far as I know, to boot a system that uses grub2 (Ubuntu) from a system that uses grub legacy (Fedora) is to chainload it, and that will only work if grub2 was originally installed to the boot partition of the Ubuntu system. This is my understanding so of course I could be dead wrong.

Now, find out how to reinstall Crunch's (assuming grub2) or Ubuntu's boot loader. Once that's done you will probably start to be able to boot all three OS's.

catch22
22nd November 2010, 01:18 AM
...
Now, find out how to reinstall Crunch's (assuming grub2) or Ubuntu's boot loader. Once that's done you will probably start to be able to boot all three OS's.With trial and error and a lotta luck I managed to reinstall Crunchbang's bootloader (live cd, text rescue, panic, calm breathing and then a bit of luck :-))

glennzo
22nd November 2010, 01:23 AM
That's great! What does it show in the boot menu? Do you have Fedora and Ubuntu options along with Crunchbang?

catch22
22nd November 2010, 01:26 AM
That's great! What does it show in the boot menu? Do you have Fedora and Ubuntu options along with Crunchbang?Yes, they're there all 3 of them :)
Thanks again for your patience!

glennzo
22nd November 2010, 01:28 AM
Not sure if I actually helped or just served to confuse the hell out of you, but at least the end result is exactly what you were expecting. You're welcome.