PDA

View Full Version : Eclipse in Rawhide


reflexing
27th October 2010, 06:13 PM
Hello, I just want to use good old Eclipse in Rawhide, but don't have even XML editor with syntax highlight :)

Having installed „eclipse-platform” package, trying to install „Eclipse XML Editors and Tools” with different update sites enabled — it always fails due to problems like this:

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.cvs.source,1.0.500.v201004 14
No repository found containing: org.eclipse.update.feature,org.eclipse.cvs.source, 1.2.0.v20100427-7B77FKt90GE5h0NCO35T7A01911
No repository found containing: osgi.bundle,org.eclipse.ecf.filetransfer.source,4. 0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.identity.source,3.1.0. 201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. httpclient.source,4.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. httpclient.ssl.source,1.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. source,3.1.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. ssl.source,1.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.source,3.1.0.201010121 910
No repository found containing: osgi.bundle,org.eclipse.ecf.ssl.source,1.0.100.201 010121910
No repository found containing: org.eclipse.update.feature,org.eclipse.equinox.p2. user.ui.source,2.0.1.r361_v20100903-897JF_lFRVaY0OInpI7vLq5
No repository found containing: osgi.bundle,org.eclipse.help.base.source,3.5.2.r36 _r20100816
No repository found containing: org.eclipse.update.feature,org.eclipse.help.source ,1.2.0.v20100427-7e7kEPFCsz-mFu_PfwL1ht5
No repository found containing: osgi.bundle,org.eclipse.jdt,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt,3.6.1.r 361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.jdt.source,3.6.1.r361_v201 00714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt.source, 3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.pde,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde,3.6.1.r 361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.pde.source,3.6.1.v20100625 _r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde.source, 3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.platform.source,3.6.1.r361 _v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.platform.so urce,3.6.1.r361_v20100909-9pF78H4oFrRqntrnsSGD6FKz-2yA7pFh6oW
No repository found containing: osgi.bundle,org.eclipse.rcp.source,3.6.0.v20100527-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.rcp.source, 3.6.1.r361_v20100827-9oBYFOtFkzKz-2xIrIhFaM_V
No repository found containing: osgi.bundle,org.eclipse.sdk,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.sdk,3.6.1.r 361_v20100714-0800-7Q7m6D9kQgfgB-G1z-jfGOddPJndx44-sNVytmFVifoAi
No repository found containing: osgi.bundle,org.objectweb.asm,3.2.0

Any help will be appretiated, don't want to install it in ugly /opt :(

cupsd
28th October 2010, 04:21 PM
http://www.if-not-true-then-false.com/2010/linux-install-eclipse-on-fedora-centos-red-hat-rhel/
Regards, :p

reflexing
28th October 2010, 04:26 PM
Thanks, but I know how to install it in /opt. I want to know the right way to use Eclipse with XML Tools from Rawhide repos.

reflexing
29th October 2010, 03:52 PM
Enabled every update site I found. Still fails:

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phase s.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.cvs.source,1.0.500.v201004 14
No repository found containing: org.eclipse.update.feature,org.eclipse.cvs.source, 1.2.0.v20100427-7B77FKt90GE5h0NCO35T7A01911
No repository found containing: osgi.bundle,org.eclipse.ecf.filetransfer.source,4. 0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.identity.source,3.1.0. 201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. httpclient.source,4.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. httpclient.ssl.source,1.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. source,3.1.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer. ssl.source,1.0.0.201010121910
No repository found containing: osgi.bundle,org.eclipse.ecf.source,3.1.0.201010121 910
No repository found containing: osgi.bundle,org.eclipse.ecf.ssl.source,1.0.100.201 010121910
No repository found containing: org.eclipse.update.feature,org.eclipse.equinox.p2. user.ui.source,2.0.1.r361_v20100903-897JF_lFRVaY0OInpI7vLq5
No repository found containing: osgi.bundle,org.eclipse.help.base.source,3.5.2.r36 _r20100816
No repository found containing: org.eclipse.update.feature,org.eclipse.help.source ,1.2.0.v20100427-7e7kEPFCsz-mFu_PfwL1ht5
No repository found containing: osgi.bundle,org.eclipse.jdt,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt,3.6.1.r 361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.jdt.source,3.6.1.r361_v201 00714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt.source, 3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.pde,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde,3.6.1.r 361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.pde.source,3.6.1.v20100625 _r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde.source, 3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.platform.source,3.6.1.r361 _v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.platform.so urce,3.6.1.r361_v20100909-9pF78H4oFrRqntrnsSGD6FKz-2yA7pFh6oW
No repository found containing: osgi.bundle,org.eclipse.rcp.source,3.6.0.v20100527-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.rcp.source, 3.6.1.r361_v20100827-9oBYFOtFkzKz-2xIrIhFaM_V
No repository found containing: osgi.bundle,org.eclipse.sdk,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.sdk,3.6.1.r 361_v20100714-0800-7Q7m6D9kQgfgB-G1z-jfGOddPJndx44-sNVytmFVifoAi
No repository found containing: osgi.bundle,org.objectweb.asm,3.2.0

Almaty Travel Photos on Instagram - Tbilisi Travel Photos on Instagram - Varanasi -