PDA

View Full Version : Display problem using Fedora Core 1 and nVidia Quadro 4 AGP


jthsiao
20th October 2004, 03:26 PM
Hi,

I'm having some display problems with Fedora Core 1. The mouse moves around in the screen smoothly, but as soon as I grab and drag something (like a screen) to move around the desktop, the refresh rate of the monitor slows down dramatically. The screen would refresh only a few seconds instead of being smooth without dragging anything. From time to time, typing in the terminal prompt would refresh slowly as well.

Here are my hardware configuration:

CPU: Dual Xeon
Memory: 1G
Video card: nVidia Quadro 4
Monitors: Dell 1900FP, Dell 1901FP

Here is a printout of my XF86Cconfig:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" RightOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "GLCore"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 1900FP (Digital)"
DisplaySize 380 310
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell 1901FP (Digital)"
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro 4 (generic)"
BusID "PCI:1:0:0"
Screen 0
Option "NvAGP" "3"
Option "NoLogo" "on"
Option "CursorShadow" "on"
Option "CursorShadowAlpha" "30"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "NVIDIA Quadro 4 (generic)"
BusID "PCI:1:0:0"
Screen 1
Option "NvAGP" "3"
Option "NoLogo" "on"
Option "CursorShadow" "on"
Option "CursorShadowAlpha" "30"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Thanks in advance for any advice you can give me!

- Tony

Tru
20th October 2004, 05:20 PM
Have you installed the nvidia drivers ?(I'm sorry I cant tell from what you said) If not that would help greatly and it is very easy. Just goto www.fedorafaq.org and use there yum.conf and then follow his simple instructions on using yum to install nvidia drivers, also there are lots of other goodies there.

jthsiao
20th October 2004, 05:54 PM
Have you installed the nvidia drivers ?(I'm sorry I cant tell from what you said) If not that would help greatly and it is very easy. Just goto www.fedorafaq.org and use there yum.conf and then follow his simple instructions on using yum to install nvidia drivers, also there are lots of other goodies there.
Hi Tru,

Yes, I have installed the nVidia drivers instead of the default nv drivers. It is listed in my devices section:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro 4 (generic)"
BusID "PCI:1:0:0"
Screen 0
Option "NvAGP" "3"
Option "NoLogo" "on"
Option "CursorShadow" "on"
Option "CursorShadowAlpha" "30"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "NVIDIA Quadro 4 (generic)"
BusID "PCI:1:0:0"
Screen 1
Option "NvAGP" "3"
Option "NoLogo" "on"
Option "CursorShadow" "on"
Option "CursorShadowAlpha" "30"
EndSection
I am using the nVidia in the line:
Driver "nvidia"
I have also trying out the AGPGARP in the line:
Option "NvAGP" "3"
Those seem to be the recommended solutions for display problems. However, I'm still having trouble with my display. One new thing that I've tried this morning is to use a different desktop style. The really slow display was happening while I was using Gnome, and now using KDE, it's still slow, but slightly faster than when I was using Gnome. I'm not sure if that help diagnose the problem, but that's another symptom that I am now noticing.

Again, thanks for reading and replying. I really appreciate your comments!

jthsiao
22nd October 2004, 06:03 PM
Here's a follow-up to my problems:

As I have said earlier, I switched to using KDE instead of Gnome and the screen refresh has been a bit better. I also switched the display option to not show window contents while dragging, which sped up the refresh a little bit more.

However, I've been running into a new problem with my display. When I open certain programs the screen starts to have flickering lines across the screen. This only happens on my 'Screen 1', which is my secondary monitor. If I move those windows to my primary monitor, the flickering stops. I'm wondering if it has to do with the specific monitor as the primary monitor is an older Dell 1900FP and the secondary monitor is a newer Dell 1901FP monitor. There may be some issues display windows with certain color in it? I am not sure.

Anyhow, I'd appreciate any inputs you have about these questions. Thanks!

Yong-dong Photos on Instagram - Trebinje Photos - Bhawana Travel Photos