PDA

View Full Version : Wrong default keyboard layout in installer on localized spins


PryGuy
29th July 2010, 10:41 AM
Good day!
I use livecd-creator+a kickstart file to build my own spin. I've added '@russian-support' in my .ks file and added the following lines to it:keyboard us
lang ru_RU.UTF-8
timezone Europe/Moscow
I boot my spin, everything is in Russian, but when I also get Russian keyboard layout when I run 'liveinst' when I absolutely do not need it as everything installer needs comes in English! Okay, I gave it a quick fix adding '--keymap=us' parameter.

But another and most serious problem for me is the 'firstboot' that starts after the hard disk installation. I have exactly the same problem there. As I said before I have specified 'keyboard us' in .ks file and I want it it to be English, but I get Russian instead of that! I modified 'xorg.conf' file adding the following lines hoping that 'firstboot' gets settings there:Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSectionBut I failed. The problem is still here.
A quick expection shown that there are some interesting params in '/goot/grub/menu.lst' that were added automatically during installation and as I think 'firstboot' looks there and this causes my problem:LANG=ru_RU.UTF-8 KEYBOARDTYPE=pc KEYTABLE=ru
How on earth do I tell installer to use the English keyboard layout in grub by default?
Thanks in advance!!!

EDIT: There's another thing I just found out. It's in '/etc/sysconfig/keyboard':KEYTABLE="ru"
MODEL="pc105"
LAYOUT="ru,us"
KEYBOARDTYPE="pc"
OPTIONS="grp:shifts_toggle,grp_led:scroll"
This seems to be a nice file to suspect also! ;)
But the problem is that I have normal (English) settings when I 'cat' it on LiveCD. It is reconfigured later and I think I can't just put new values to it via the .ks file...

Primorsko-Akhtarsk Instagram Photos - Raya Travel Photos on Instagram - Gongju