PDA

View Full Version : Intel kms working again for K34-40


SlowJet
16th June 2010, 07:35 PM
With newly compiled kernel-2.6.34-40 with the newly compiled xorg-x11-server works again with kms (rhgb quite) and no /etc/X11/xorg.conf

$ uname -a
Linux Ruthie-07.WinProxy 2.6.34-40.fc14.i686.PAE #1 SMP Wed Jun 16 15:15:36 UTC 2010 i686 i686 i386 GNU/Linux
[darwinhwebb@Ruthie-07 ~]$ rpm -qa xorg-x11-server\*
xorg-x11-server-utils-7.4-16.fc14.i686
xorg-x11-server-Xephyr-1.8.0-7.fc14.i686
xorg-x11-server-common-1.8.0-7.fc14.i686
xorg-x11-server-Xorg-1.8.0-7.fc14.i686
[darwinhwebb@Ruthie-07 ~]$ rpm -q xorg-x11-drv-intel
xorg-x11-drv-intel-2.11.0-4.fc13.i686 (865GBF)
# intel f14 may work here also?

Also continues to work for nouveau ( nvidia mx2 (nv10,nv11) ) on Pent III via Apollo-133

SJ

dd_wizard
17th June 2010, 06:06 PM
Hey SJ, do you think I should "downgrade" xorg-x11-server and/or xorg-x11-drv-intel?

[gene@Mobile-PC ~]$ yum list installed xorg-x11-drv-intel* xorg-x11-server*
Loaded plugins: auto-update-debuginfo, fastestmirror, presto, refresh-packagekit, remove-with-
: leaves, show-leaves, verify
Installed Packages
xorg-x11-drv-intel.x86_64 2.11.0-4.fc13 @/xorg-x11-drv-intel-2.11.0-4.fc13.x86_64/13
xorg-x11-server-Xorg.x86_64 1.8.0-12.fc13 @updates-testing/13
xorg-x11-server-common.x86_64 1.8.0-12.fc13 @updates-testing/13

The fc13 packages have been working, but I'm not seeing the updates filter into fc14. It would be nice if the rawhide packages had higher release numbers than the fc13 packages. The upgrade path is somewhat broken at the moment.

dd_wizard

SlowJet
17th June 2010, 09:22 PM
Hey SJ, do you think I should "downgrade" xorg-x11-server and/or xorg-x11-drv-intel?

The fc13 packages have been working, but I'm not seeing the updates filter into fc14. It would be nice if the rawhide packages had higher release numbers than the fc13 packages. The upgrade path is somewhat broken at the moment.

dd_wizard


http://mirrors.fedoraproject.org/publiclist/Fedora/development/i386/

Find your fav mirror that has the packages on it.
D/L them.
Try first with the f13 intel and then if you want, try the f14 intel drv later.

What are you D/L
kernel 34-40 from mirror (or k34-43 and dracut-006-1 from koji)
xorg-x11-server-common-1.8.0-7.f14
xorg-x11-server--Xorg-1.8.0-7.f14
xorg-x11-drv-intel-1.8.0-7.f14

mv kerenl-..rpm kernel...-rpm.sav

#rpm -Uvh *.rpm --test
if one or more installed is newer than rpm then
#rpm -Uvh *.rpm --oldpackage --test
if no error remove --test


For kernel do
# mv kernel....rpm.sav kernel-...rpm
a seperate rpm -ivh kernel...rpm --test
if no error then remove test.

SJ

dd_wizard
18th June 2010, 01:08 AM
Thanks, I'll just get everything from koji, the xorg-x11-server packages first. What I'm really wondering is, do the rawhide xorg packages have any regressions from the last fc13 packages I got before going to rawhide? Some of the fixes in the fc13 change logs were never rolled into rawhide. That may or may not be a problem.

dd_wizard

Slobodka Travel Photos on Instagram - Michurinsk - Freital