PDA

View Full Version : FC2 and XP (on FAT32)


leaded
25th May 2004, 02:03 AM
I was reading about all of these problems with dual-boot systems and XP and the NTFS filesystem geometry errors and whatnot. I'm a little confused about what the problem is, but I think it's something to do with the 2.6 kernel messing up the partition map with NTFS partitions.

But, that's not what this is about. Since that's what I've gathered from reading random bug reports and blog posts, I assume it's the filesystem. I have PartitionMagic 8 for Windows and I went ahead and converted my entire C:\ partition from NTFS to FAT32 to prepare for an FC2 install. But before I go any further, I wanted to make sure it was an NTFS issue, not Windows XP.

Btw, XP runs fine on FAT32. I don't see any difference, and I don't do any NT-related activities (NTFS -> NT File System) so maybe that's why.

Anyway, long story short- since my XP partition is FAT32 and not NTFS, am I avoiding the dual-boot problem that's been reported lately?

(If I'm unclear as to what the problem is that I'm referring to, check out http://www.onlamp.com/pub/wlg/4896)

Thanks!

Jman
25th May 2004, 04:30 AM
It's not necessarily ntfs, but the way the 2.6 kernel sees the hard drive geometry. Apparently setting the hard drive to LBA in the bios is the best.

See this bug: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115980

leaded
25th May 2004, 12:10 PM
LBA is the "best"? Does that mean that there's still a risk? I just spent 2 days recovering XP (from something stupid I had done) and I don't want to do it again, so the possibility of a risk will put FC2 on hold for me.

Ug
25th May 2004, 12:51 PM
Its a fairly easy one to fix, and probably won't occur. The solution is: 1) Open a terminal and log in as super user:

su

2) Execute the following command where "/dev/hda" is where your Windows partition is located (hda is likely to be the most common especially if Windows was installed before Fedora - as it is in most cases). The parameter "-H255" refers to the number of heads which your hardisk has. In most cases this parameter will work - but if it doesn't try replacing it with "-H240" which is more common on older systems.

sfdisk -d /dev/hda | sfdisk --no-reread -H240 /dev/hda

3) Reboot your system and try to log into windows from the Grub bootloader.Its also a problem with Mandrake 10

dragon
26th May 2004, 02:55 PM
Lots of people are having this problem - please take a look at my fedora forum posts at http://www.fedoraforum.org/forum/showthread.php?s=&postid=14703

I've noted a couple of solutions which have been discussed on various mailing lists including the one mentioned above.

cgriffin
27th May 2004, 03:58 AM
You said you had Partition Magic 8. Doesn't that come with a bootloader program? If so, another option is to use that program to handle your dual booting rather than grub. You'll want to do some reading up on this, but I have found that using a boot manager is the easiest and safest thing to do. You have to be careful when installing FC when you get to the bootloader part in the installation. You have to install grub on the primary FC partition, not your MBR For example, if your hard drive is /dev/hda and you have windows at /dev/hda1 and FC at /dev/hda5, you want to make sure grub is installed at /dev/hda5 and NOT the MBR. Then, you install FC, reboot into windows, run your bootloader program, and add an entry for FC and point it to /dev/hda5. When you reboot, the bootloader at the MBR will load, and when you select FC, it will take you to grub at /dev/hda5.

I've probably confused you even more... but it might be worth checking out.

Other good boot managers are BootIt Next Generation and Acronis OS Selector.

leaded
29th May 2004, 08:04 AM
I went into my computer BIOS settings and here's what I found. I know it's overly verbose, but better safe than... er, coming back to give more info!

Compaq Computer Corporation Setup Utility

Storage -> Device Configuration

Hard Disk
- IDE Primary 0 40.0GB, St256460 (whatever numbers)

Pressed [Enter]

[various options]
Translation Mode Bit Shift

Ok, so Translation Mode can be changed to LBA Assisted. Is that what everyone is referring to?
It can also be set to a User setting, with definable cynlinders, heads, and sectors (4, 3, and 2 digit values, respectively).

I think I should go with LBA Assisted, but I'd like confirmation before screwing something up! Thanks.

leaded
29th May 2004, 08:06 PM
Using LBA Assisted kept Windows from booting so I switched back to Bit Shift.

Thanks, charlie, for the suggestion. I installed BootMagic and it's working great. It had me create a rescue disk on installation, and I noticed one the files was something like "rsetmbr.exe" which I guess would fix the geometry problem, should a problem arise.

I'll will post of my results.

pdb
30th May 2004, 05:00 PM
The dual-boot problem is pretty extensively covered in a message on the fedora-devel-list (and no doubt mirrored elsewhere). It goes through what the bug is, how to prevent it, and how to recover. The key is to NOT PANIC if you do run into trouble. But hopefully you have no troubles anyway! :)

http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html

leaded
3rd June 2004, 07:43 AM
Well, the partition table got screwed up immediately after the installation. When I booted into XP, I ran PartitionMagic and it tried to correct the problems and just made everything worse. Oh well.

Thanks, pdb, I didn't know about that article. Maybe I'll check it out tonight and maybe give it another shot! *fingers crossed*

leaded
10th June 2004, 12:54 AM
charlie, I wanted to thank you again for that suggestion with BootMagic. When I had originally tried to follow your advice, for some stupid reason I was still making a boot partition, rather than having grub be on the main linux partition. Needless to say, it didn't work well with BootMagic and I gave up hopeless. Yesterday, I went back and re-read it, more closely this time, seeing the part about where to put grub. And now I'm got a successful dual-boot!! It boots first to the BootMagic menu (well it should, I'll explain in a sec) and I choose Linux, then it goes to grub, which I have set to time out after 1 second.

About BootMagic... when you install it from Windows, you have to make a 20-80 mb partition (like certain grub setups), then the installer installs to that partition. Then you can use the Windows program to set the options and make icons and stuff. But after I reboot, the partition becomes hidden. BootMagic loads, but the shortcuts for the program in XP "go bad" because the files "don't exist." I used PartitionMagic to unhide the partition but that killed it somehow. So for now, I'm using PQBoot from the BootMagic rescue disk to switch between Linux and Windows, because BM is broken. I guess everything has to be set-up initially before a post-installation reboot. You're supposed to be able to edit the options via boot disk, but for some reason it goes straight to PQBoot and not BM (from the boot disk).

At any rate, I'm content with it. I don't even know if I want to configure BM again because I can use this boot disk to change the start-up partition. My family doesn't need to be exploring Linux anyway.

Oh, I owe a lot of thanks to pdb too, so the link to that RedHat article. There was a prevention method listed on how to keep the 2.6 kernel from messing up XP. Something like boot> linux install hda=5169,240,39 which kept the kernel from writing some hd map. At any rate, it led to success so thank you so much!

And to end this thread... the original question was answered so long ago, so sorry to anyone checking this out for an answer to that question! :D I learned a lot through the discussion tho, so thanks to all!

cgriffin
10th June 2004, 01:43 AM
Leaded,

I am glad that it has worked for you! I have always used a third party boot manager program to handle my dual (and triple and quadruple!) booting. That way I never really have to worry about it. I install it in windows and go from there. Usually the boot manager part that gets loaded first has the ability to "see" your new linux installations on the fly and add them but if not, it's a piece of cake to do it yourself.

The only catch is when you install Fedora or any other linux distribution. You have to be careful where it installs grub or lilo. I have found that most distros default to installing grub/lilo on the MBR which makes sense, I guess, since most people aren't going to use a third party boot manager. You just have to catch it during install and change grub/lilo so it gets installed at the root partition of your distro rather than the MBR> Other than that, however, it's a good way to handle things without worrying about messing up your windows boot.

OpenSouls.com
10th June 2004, 02:27 AM
sfdisk -d /dev/hda | sfdisk --no-reread -H240 /dev/hda

I saw this in an article, only one problem. It tells it cannot find the sfdisk command. I'm su-ed in, and even tried to find the sfdisk pacakage online. Any suggestions?

leaded
10th June 2004, 04:07 AM
OpenSouls, if I were you I would do the following, as mentioned in http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html

Download and burn the Fedora Core 2 Rescue CD.

Boot from the Rescue CD (there is no need to start networking or mount
drives)

Issue the command: fdisk -l /dev/hda to print the current partition table
to screen in non-interactive mode.

Write down the drive geometry as reported at the beginning of the output
from fdisk. This is reported as number of Cylinders, Heads, and Sectors
(hence the name CHS).

You can now reboot the computer by simultaneously holding down the keys
Ctrl-Alt-Delete.

You can now boot the Fedora Core 2 installation CD. At the first menu prompt
you should now choose to run the installer with the known geometry.

Example: linux hda=14593,255,63


It worked perfectly for me!

OpenSouls.com
10th June 2004, 04:26 AM
I figured out where sfdisk was, just booted off the install with linux rescue cl arguments.

Problem is, I have Fedora already installed. Bleh.

CharlesC
13th October 2004, 06:51 AM
You said you had Partition Magic 8. ...... t I have found that using a boot manager is the easiest and safest thing to do. You have to be careful when installing FC when you get to the bootloader part in the installation. You have to install grub on the primary FC partition, not your MBR .

This is exactly the problem I have! I have Boot Magic on my first disk
containing Windows Me and Windows XP Pro partitions. My second disk
has a Linux partition with Fedora installed but no bootloader

How do I setup Fedora to allow booting from the second disk?
Do I install GRUB on /dev/hdb or /dev/hdb1 ?????

Charles

leaded
14th October 2004, 04:55 AM
You have to install a bootloader. Install grub. Here's what you need to do...

Make two partitions on your 2nd hard drive. Make one that's around 100mb, and set the mount point to /boot. Make the other one as big as you need it to be for your Linux partition and choose the mount point to be /. Click next.

There should be a check box there to configure advanced bootloader options. Check it and choose next. Then, there's a bullet for MBR and first sector of partition. Choose the second one. It should be hdb1. Install Fedora, reboot.

You'll notice that Fedora will not boot, and it'll boot into Windows- as it should. Once it Windows, load BootMagic. Click Add. The hdb1 partition should be available as a Linux partition. If it's not, choose "Advanced Partition Hiding" from the Options menu to show it. Once linux is added, restart your computer and choose it. It should then go to grub and then you're good to go.

I know the temptation is not to install grub, since you've got BootMagic. But BootMagic doesn't load the kernel, it just chooses which partition to boot to. Even if you didn't need grub for that, grub also lets you choose between different kernels (mine has 2.6.5 and 2.6.8. Once I ran 'yum upgrade kernel' it was automatically added to grub)

If you need any more help, let me know. I've reinstalled everything recently so this is all fresh in my mind. Unfortunately (well, maybe fortunately) I had to completely abandon Windows because it locks up after using it for a few minutes. It's not my version of XP (downloaded two types), nor the fact that it's XP (2000 freezes too), and it's not my wireless keyboard and mouse (regular K&B froze too). VERY frustrating- I installed Windows XP or 2000 9 times before giving up. *thinking about purchasing VMware*

Psquared
2nd December 2004, 06:55 PM
I want to install Ubuntu Linux to experiment with. I already have XP and FC2 working and Grub lets me choose which OS to start. If I install Ubuntu do I need to take the same precautions as with installing FC2? Will Grub automatically pickup the new OS? Do I need to resize my partitions using Partition Magic before installing Ubuntu?

Right now, my 80 gig harddrive is

40 gigs for XP
40 gigs for FC2

Partition Magic sees the FC2 partition as full and won't let me resize it. Does that mean I have take some space away from XP?

leaded
5th December 2004, 06:22 AM
PartitionMagic can't resize anything other than FAT, FAT32, and NTFS. Take some away from one of those parition types. I think there's a tool to resize ext2/3 partitions but I have no experience with them.

As far as GRUB is concerned, I have no idea. The installer usually edits the grub config file. I don't know what kind of installer Ubuntu uses. I think Fedora's can sense other OS's and make the appropriate changes but I'm clueless any further.

Chelyabinsk Travel Photos on Instagram - Myrtle Beach Travel Photos on Instagram - Amparafaravola Travel Photos on Instagram