PDA

View Full Version : FC2 upgrade queries


WATSON
25th May 2004, 12:30 AM
Dear All,

I have upgraded my FC1 installation to FC2 with the yum methodology outlined in the forums. This seemed to work fine after resolving a couple of dependcies until the very end when I got the error message below. Possibly - after a bit of searching - this may be to do with the upgrading of Python.

However, running uname -r now gives me 2.4.22-1.2188.nptl, which would seem to suggest that something is not right. grub.conf does show a 2.6 kernel so I'm not too sure what's up.

Could any of you experts possibly give me a bit of guidance? It would be much appreciated. :)

Toby.


Erasing: XFree86-libs-data 1248/1250
Completing update for ed - 1249/1250
Kernel Updated/Installed, checking for bootloader
Grub found - making this kernel the default
Traceback (most recent call last):
File "/usr/bin/yum", line 30, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum/yummain.py", line 375, in main
pkgaction.kernelupdate(tsInfo)
File "/usr/share/yum/pkgaction.py", line 611, in kernelupdate
up2datetheft.install_grub(kernel_list)
File "/usr/share/yum/up2datetheft.py", line 13, in install_grub
import grubcfg
File "/usr/share/yum/grubcfg.py", line 12, in ?
import iutil
File "/usr/share/yum/iutil.py", line 2, in ?
import types, os, sys, select, string, stat, signal
ImportError: No module named select



I maybe should also add that I get a load of errors when starting X, presumably these might be related?

WATSON
25th May 2004, 03:05 PM
Well, the latest is that I commented out all the old lines from grub.conf which seems to have led to various problems all over the place and much breakedness. :(

Looks like the only option might be to format and reinstall Fed C2 from CD...?