PDA

View Full Version : FC13 yum doesn't work after upgrade


dcarp
26th May 2010, 03:18 AM
Trace message:

[root@localhost /]# yumdownloader python
Traceback (most recent call last):
File "/usr/bin/yumdownloader", line 21, in <module>
import yum
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 39, in <module>
import config
File "/usr/lib/python2.6/site-packages/yum/config.py", line 30, in <module>
from parser import ConfigPreProcessor, varReplace
File "/usr/lib/python2.6/site-packages/yum/parser.py", line 3, in <module>
import urlgrabber
File "/usr/lib/python2.6/site-packages/urlgrabber/__init__.py", line 54, in <module>
from grabber import urlgrab, urlopen, urlread
File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 427, in <module>
import pycurl
ImportError: /usr/lib64/libcurl.so.4: undefined symbol: ares_library_init

Installed packages:
[root@localhost /]# rpm -q python yum yum-utils python-urlgrabber python-pycurl libcurl
python-2.6.4-25.fc13.x86_64
yum-3.2.27-4.fc13.noarch
yum-utils-1.1.26-7.fc13.noarch
python-urlgrabber-3.9.1-7.fc13.noarch
python-pycurl-7.19.0-4.fc12.x86_64
libcurl-7.20.0-4.fc13.x86_64

nirik
26th May 2010, 04:30 AM
How did you upgrade?

what does 'ldd /usr/lib64/libcurl.so.4' show?

---------- Post added at 09:30 PM CDT ---------- Previous post was at 09:30 PM CDT ----------

How did you upgrade?

what does 'ldd /usr/lib64/libcurl.so.4' show?

djmac
7th June 2010, 11:43 AM
I had the same problem. Checking with strace pointed me to a 3rd party libcurl file being loaded by yum.

open("/usr/lib/nsr/libcurl.so.4", O_RDONLY) = 9

nsr is Legato networker. Removing all Networker RPM's (lgtoclnt, etc, etc) allowed yum ot work again.

Hope this helps someone else out.

Cheers,
Dave

Cebu City Travel Photos on Instagram - Osaka-shi Instagram Photos - Myanmar Travel Photos -