PDA

View Full Version : Problem installing/configuring VMware Tools in F13 beta guest


Ijan
21st April 2010, 12:36 AM
Hi,

yesterday I decided to give Fedora another spin and installed F13 beta in a VMware 7.0 VM.

Unfortunately the according "VMware Tools" behave sort of strange. They install with a success message but when config-script gets started after the installation, it does not output anything for about one minute and then tries to restart the whole installation process which then again triggers the configuration-script which after one minute...

The mouse driver works fine but I neither have drag-and-drop support nor does the video driver allow resizing.

Being new to Fedora I'm not sure where to look for troubleshooting. There is no xorg.conf yet in /etc/X11 and here's what my xorg.log looks like:

[ 89.794] (II) Loading extension DRI2
[ 89.794] (==) Matched vmware as autoconfigured driver 0
[ 89.795] (==) Matched vesa as autoconfigured driver 1
[ 89.795] (==) Matched fbdev as autoconfigured driver 2
[ 89.795] (==) Assigned the driver to the xf86ConfigLayout
[ 89.795] (II) LoadModule: "vmware"
[ 89.812] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[ 89.824] (II) Module vmware: vendor="X.Org Foundation"
[ 89.825] compiled for 1.7.99.3, module version = 10.16.7
[ 89.825] Module class: X.Org Video Driver
[ 89.825] ABI class: X.Org Video Driver, version 7.0
[ 89.825] (II) LoadModule: "vesa"
[ 89.835] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 89.838] (II) Module vesa: vendor="X.Org Foundation"
[ 89.838] compiled for 1.7.99.3, module version = 2.2.1
[ 89.839] Module class: X.Org Video Driver
[ 89.839] ABI class: X.Org Video Driver, version 7.0
[ 89.839] (II) LoadModule: "fbdev"
[ 89.853] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 89.856] (II) Module fbdev: vendor="X.Org Foundation"
[ 89.856] compiled for 1.7.99.3, module version = 0.4.1
[ 89.857] ABI class: X.Org Video Driver, version 7.0
[ 89.857] (II) VMWARE: driver for VMware SVGA: vmware0405, vmware0710
[ 89.858] (II) VESA: driver for VESA chipsets: vesa
[ 89.858] (II) FBDEV: driver for framebuffer: fbdev
[ 89.858] (++) using VT number 1

[ 89.879] (II) Primary Device is: PCI 00@00:0f:0
[ 89.906] (WW) Falling back to old probe method for vesa
[ 89.907] (WW) Falling back to old probe method for fbdev
[ 89.908] (II) Loading sub module "fbdevhw"
[ 89.908] (II) LoadModule: "fbdevhw"
[ 89.917] (II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so
[ 89.934] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 89.935] compiled for 1.8.0, module version = 0.0.2
[ 89.936] ABI class: X.Org Video Driver, version 7.0
[ 89.940] (EE) open /dev/fb0: No such file or directory
[ 89.950] (--) VMWARE(0): VMware SVGA regs at (0x10d0, 0x10d1)
[ 89.950] (II) Loading sub module "vgahw"
[ 89.951] (II) LoadModule: "vgahw"
[ 89.966] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[ 89.971] (II) Module vgahw: vendor="X.Org Foundation"
[ 89.971] compiled for 1.8.0, module version = 0.1.0
[ 89.971] ABI class: X.Org Video Driver, version 7.0
[ 90.294] (--) VMWARE(0): caps: 0x001FC3E2
[ 90.294] (--) VMWARE(0): depth: 24
[ 90.294] (--) VMWARE(0): bpp: 32
[ 90.295] (--) VMWARE(0): vram: 16777216
[ 90.295] (--) VMWARE(0): pbase: 0xd0000000
[ 90.295] (--) VMWARE(0): mwidt: 2560
[ 90.295] (--) VMWARE(0): mheig: 1600
[ 90.296] (II) VMWARE(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 90.297] (--) VMWARE(0): depth: 24
[ 90.297] (--) VMWARE(0): bpp: 32
[ 90.298] (--) VMWARE(0): w.red: 8
[ 90.298] (--) VMWARE(0): w.grn: 8
[ 90.298] (--) VMWARE(0): w.blu: 8
[ 90.298] (--) VMWARE(0): vis: 4
[ 90.298] (==) VMWARE(0): Depth 24, (==) framebuffer bpp 32
[ 90.299] (==) VMWARE(0): RGB weight 888
[ 90.300] (==) VMWARE(0): Default visual is TrueColor
[ 90.301] (==) VMWARE(0): Using HW cursor
[ 90.302] (==) VMWARE(0): Using gamma correction (1.0, 1.0, 1.0)
[ 90.304] (II) VMWARE(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz
[ 90.304] (II) VMWARE(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz
[ 90.305] (WW) VMWARE(0): Unable to estimate virtual size
[ 90.305] (II) VMWARE(0): Clock range: 0.00 to 400000.00 MHz
[ 90.308] (II) VMWARE(0): Not using default mode "640x350" (vrefresh out of range)
[ 90.308] (II) VMWARE(0): Not using default mode "320x175" (bad mode clock/interlace/doublescan)
[ 90.309] (II) VMWARE(0): Not using default mode "640x400" (vrefresh out of range)
[ 90.309] (II) VMWARE(0): Not using default mode "320x200" (bad mode clock/interlace/doublescan)
[ 90.309] (II) VMWARE(0): Not using default mode "720x400" (vrefresh out of range)
[...]
[ 90.344] (II) VMWARE(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
[ 90.347] (--) VMWARE(0): Virtual size is 800x600 (pitch 800)
[ 90.348] (**) VMWARE(0): *Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
[ 90.349] (II) VMWARE(0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
[ 90.350] (**) VMWARE(0): *Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
[ 90.350] (II) VMWARE(0): Modeline "800x600"x56.2 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz)
[ 90.350] (**) VMWARE(0): *Default mode "640x480": 25.2 MHz, 31.5 kHz, 59.9 Hz
[ 90.351] (II) VMWARE(0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)


TIA