PDA

View Full Version : F13 Update Errors


jonathan47
2nd April 2010, 06:15 AM
Am getting the following errors from yum update:

Transaction Check Error:
package libcollection-0.4.0-2.fc13.x86_64 (which is newer than libcollection-0.4.0-1.fc13.i686) is already installed
package libini_config-0.4.0-2.fc13.x86_64 (which is newer than libini_config-0.4.0-1.fc13.i686) is already installed
package libdhash-0.4.0-2.fc13.x86_64 (which is newer than libdhash-0.4.0-1.fc13.i686) is already installed

Adding skip-broken didn't work. Any ideas?

BugRocks1
2nd April 2010, 07:13 AM
Using RPM force option doens't install the packages?

Hansvon
2nd April 2010, 07:58 AM
yum --exclude=sssd,sssd-client update

and wait for proper sssd* packages.

cheesie
2nd April 2010, 08:07 AM
I removed the libcollection file and then I could install the packages. Only the update of the gnome-color-manager package failed. I reinstalled the libcollection-0.4.0-1.fc13 (x86_64)

mmix
2nd April 2010, 01:22 PM
Thanks to Hansvon.

It works like charm.

yum update --skip-broken --exclude=sssd,sssd-client

jonathan47
2nd April 2010, 04:29 PM
yum --exclude=sssd,sssd-client update

and wait for proper sssd* packages.

Thank you Hansvon. Worked great!

mindfaq
2nd April 2010, 05:08 PM
For future issues:
# rpm -q --whatrequires libdhash
sssd-1.1.0-2.fc13.x86_64and so on...

Hansvon
3rd April 2010, 01:02 AM
Today's updates bring working sssd* and gnome-color-manager packages but krb5-libs is not signed so you need to run yum with --nogpgcheck or exclude=krb5*

jonathan47
3rd April 2010, 04:03 AM
For future issues:
# rpm -q --whatrequires libdhash
sssd-1.1.0-2.fc13.x86_64and so on...

Many thanks.

MuadNu
3rd April 2010, 11:23 PM
It doesn't work for me...

#yum update --skip-broken --exclude=sssd,sssd-client
...
Error: Package: libproxy-0.2.3-12.fc12.x86_64 (installed)
Requires: libproxy-python = 0.2.3-12.fc12
Removing: libproxy-python-0.2.3-12.fc12.x86_64 (installed)
Installing: libproxy-python-0.3.1-4.fc13.x86_64 (updates-testing)
Error: Package: libproxy-0.2.3-12.fc12.x86_64 (installed)
Requires: libproxy-bin = 0.2.3-12.fc12
Removing: libproxy-bin-0.2.3-12.fc12.x86_64 (installed)
Installing: libproxy-bin-0.3.1-4.fc13.x86_64 (updates-testing)
Error: Package: sssd-1.1.0-2.fc13.x86_64 (@updates-testing)
Requires: libdhash = 0.4.0-2.fc13
Removing: libdhash-0.4.0-2.fc13.x86_64 (@updates-testing)
Available: libdhash-0.4.0-3.fc13.i686 (updates-testing)
Error: Package: sssd-1.1.0-2.fc13.x86_64 (@updates-testing)
Requires: libini_config = 0.4.0-2.fc13
Removing: libini_config-0.4.0-2.fc13.x86_64 (@updates-testing)
Available: libini_config-0.4.0-3.fc13.i686 (updates-testing)
Error: Package: sssd-1.1.0-2.fc13.x86_64 (@updates-testing)
Requires: libcollection = 0.4.0-2.fc13
Removing: libcollection-0.4.0-2.fc13.x86_64 (@updates-testing)
Available: libcollection-0.4.0-3.fc13.i686 (updates-testing)
You could try using --skip-broken to work around the problem
GConf2-2.28.1-1.fc13.x86_64 is a duplicate with GConf2-2.28.0-10.fc13.x86_64
1:NetworkManager-glib-0.8.0-4.git20100325.fc13.x86_64 is a duplicate with 1:NetworkManager-glib-0.8.0-3.git20100323.fc13.x86_64
ORBit2-2.14.18-1.fc13.x86_64 is a duplicate with ORBit2-2.14.17-4.fc13.x86_64
at-spi-1.30.0-1.fc13.x86_64 is a duplicate with at-spi-1.29.92-1.fc13.x86_64
atk-1.30.0-1.fc13.x86_64 is a duplicate with atk-1.29.92-1.fc13.x86_64
bash-4.1.2-4.fc13.x86_64 is a duplicate with bash-4.1.2-3.fc13.x86_64
bluez-libs-4.63-1.fc13.x86_64 is a duplicate with bluez-libs-4.62-1.fc13.x86_64
brasero-libs-2.30.0-1.fc13.x86_64 is a duplicate with brasero-libs-2.29.92-1.fc13.x86_64
clutter-1.2.4-1.fc13.x86_64 is a duplicate with clutter-1.2.2-1.fc13.x86_64
1:dbus-1.2.24-1.fc13.x86_64 is a duplicate with 1:dbus-1.2.22-2.fc13.x86_64
1:dbus-libs-1.2.24-1.fc13.x86_64 is a duplicate with 1:dbus-libs-1.2.22-2.fc13.x86_64
1:dbus-x11-1.2.24-1.fc13.x86_64 is a duplicate with 1:dbus-x11-1.2.22-2.fc13.x86_64
desktop-file-utils-0.16-1.fc13.x86_64 is a duplicate with desktop-file-utils-0.15-8.fc12.x86_64
glib2-2.24.0-1.fc13.x86_64 is a duplicate with glib2-2.23.6-1.fc13.x86_64
glib2-devel-2.24.0-1.fc13.x86_64 is a duplicate with glib2-devel-2.23.6-1.fc13.x86_64
gnome-bluetooth-libs-2.30.0-1.fc13.x86_64 is a duplicate with gnome-bluetooth-libs-2.29.91-2.fc13.x86_64
gnome-keyring-2.30.0-1.fc13.x86_64 is a duplicate with gnome-keyring-2.29.92-2.fc13.x86_64
gnome-media-2.30.0-1.fc13.x86_64 is a duplicate with gnome-media-2.29.91-2.fc13.x86_64
gnome-menus-2.30.0-1.fc13.x86_64 is a duplicate with gnome-menus-2.29.92-1.fc13.x86_64
gnome-panel-libs-2.30.0-1.fc13.x86_64 is a duplicate with gnome-panel-libs-2.29.92.1-1.fc13.x86_64
gnome-vfs2-2.24.3-1.fc13.x86_64 is a duplicate with gnome-vfs2-2.24.2-4.fc13.x86_64
gobject-introspection-0.6.9-3.fc13.x86_64 is a duplicate with gobject-introspection-0.6.8-0.1.20100128git.x86_64
gvfs-1.6.0-1.fc13.x86_64 is a duplicate with gvfs-1.5.5-2.fc13.x86_64
hal-libs-0.5.14-3.fc13.x86_64 is a duplicate with hal-libs-0.5.14-2.fc13.x86_64
libIDL-0.8.14-1.fc13.x86_64 is a duplicate with libIDL-0.8.13-2.fc12.x86_64
libbonoboui-2.24.3-1.fc13.x86_64 is a duplicate with libbonoboui-2.24.2-2.fc12.x86_64
libgcc-4.4.3-12.fc13.x86_64 is a duplicate with libgcc-4.4.3-8.fc13.x86_64
libgnome-2.30.0-1.fc13.x86_64 is a duplicate with libgnome-2.28.0-5.fc13.x86_64
libgnome-keyring-2.30.0-1.fc13.x86_64 is a duplicate with libgnome-keyring-2.29.92-git20100322.1.fc13.x86_64
libgnomecanvas-2.30.0-1.fc13.x86_64 is a duplicate with libgnomecanvas-2.26.0-3.fc13.x86_64
libgnomekbd-2.30.0-1.fc13.x86_64 is a duplicate with libgnomekbd-2.29.92-2.fc13.x86_64
libgnomeui-2.24.3-1.fc13.x86_64 is a duplicate with libgnomeui-2.24.1-3.fc12.x86_64
libgtop2-2.28.1-2.fc13.x86_64 is a duplicate with libgtop2-2.28.0-2.fc13.x86_64
libproxy-0.3.1-4.fc13.x86_64 is a duplicate with libproxy-0.2.3-12.fc12.x86_64
librsvg2-2.26.2-1.fc13.x86_64 is a duplicate with librsvg2-2.26.0-4.fc13.x86_64
libsoup-2.30.0-1.fc13.x86_64 is a duplicate with libsoup-2.29.91-1.fc13.x86_64
libstdc++-4.4.3-12.fc13.x86_64 is a duplicate with libstdc++-4.4.3-8.fc13.x86_64
libwnck-2.30.0-1.fc13.x86_64 is a duplicate with libwnck-2.29.92-1.fc13.x86_64
openssl-1.0.0-1.fc13.x86_64 is a duplicate with openssl-1.0.0-0.22.beta5.fc13.x86_64
pango-1.28.0-1.fc13.x86_64 is a duplicate with pango-1.27.1-1.fc13.x86_64
pixman-0.18.0-1.fc13.x86_64 is a duplicate with pixman-0.17.12-2.fc13.x86_64
plymouth-core-libs-0.8.1-3.fc13.x86_64 is a duplicate with plymouth-core-libs-0.8.1-1.fc13.x86_64
1:qt-4.6.2-11.fc13.x86_64 is a duplicate with 1:qt-4.6.2-8.fc13.x86_64
totem-pl-parser-2.30.0-1.fc13.x86_64 is a duplicate with totem-pl-parser-2.29.92-1.fc13.x86_64
zenity-2.30.0-1.fc13.x86_64 is a duplicate with zenity-2.28.0-1.fc12.x86_64


I've tried everything else I can think of, but I always get some error.

AdamW
6th April 2010, 09:08 PM
you could just wait for a bit, this will be fixed in the next push most likely. It was a bug in the sssd packaging.

GoinEasy9
6th April 2010, 10:06 PM
sssd is fixed in F13, rawhide though is trying to install the problem version.

Kyoto - Ecuador - Calgary Travel Photos -