PDA

View Full Version : PackageKit holding yum lock


GoinEasy9
17th March 2010, 08:19 PM
I put up a new install of F13 and am adding my usual additions using yum install <pkgname>

Is anyone else having a problem with PackageKit holding up yum? It's only a few seconds, but it seems to be happening all the time.

example:
[root@fedora13dw32a bin]# yum install evince-dvi
Loaded plugins: fastestmirror, presto, refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 3761.
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit
Memory : 38 M RSS ( 84 MB VSZ)
Started: Wed Mar 17 15:10:58 2010 - 00:04 ago
State : Sleeping, pid: 3761
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit
Memory : 38 M RSS ( 84 MB VSZ)
Started: Wed Mar 17 15:10:58 2010 - 00:06 ago
State : Sleeping, pid: 3761
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit
Memory : 38 M RSS ( 84 MB VSZ)
Started: Wed Mar 17 15:10:58 2010 - 00:08 ago
State : Sleeping, pid: 3761
Loading mirror speeds from cached hostfile
* fedora: mirror.us.as6453.net
* rpmfusion-free-rawhide: mirror.liberty.edu
* rpmfusion-nonfree-rawhide: mirror.liberty.edu
* updates-testing: mirror.us.as6453.net
Setting up Install Process

I'm just curious, because it seems the only problems I'm having with F13 are somehow related to PackageKit. Also, I haven't used the PackageKit-gui today, it's not sitting in the background.

ovadyah
17th March 2010, 08:54 PM
I have just re-started PackageKit on my F13 box. I have been in the habit of installing yumex at the start and using it. Had some issues earlier and turned PackageKit off.
I will watch it and see how things go.
ejn

AdamW
17th March 2010, 09:53 PM
that's normal, that's just when it checks if updates are available. You can disable the update notification service if it really annoys you.

dd_wizard
17th March 2010, 09:55 PM
I got that in F12 and F13, too. I finally disabled PackagKit in System > Preferences > Startup Applications and it stopped happening.

dd_wizard

GoinEasy9
17th March 2010, 10:06 PM
Thank you AdamW and dd_wizard. I never saw it to the extent I have in F13 (that's why I posted), but, I like update notifications, so I'll live with it. Besides, once the box is set up, I don't use yum enough so that a few seconds make a difference.

Thanks Again.

JEO
17th March 2010, 10:41 PM
In /etc/yum/pluginconf.d/refresh-packagekit.conf you can disable the refresh of PackageKit that happens after every yum invocation that actually does something.

GoinEasy9
17th March 2010, 10:48 PM
Thanks JEO, will try that. I think that's what I am looking for.

Bandar-e Anzali - Eimsbuettel Travel Photos on Instagram - Bambui Instagram Photos