PDA

View Full Version : Nvidia guide for Rawhide.


leigh123linux
29th January 2010, 08:38 PM
Rawhide Howto for the rpmfusion nvidia drivers


This is a Three-Step Process. If you don't follow all three steps, your install will fail!



1. Install the nvidia driver.

For GeForce 6, 7, 8, 9 & 200 series cards


su
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
yum install akmod-nvidia xorg-x11-drv-nvidia-libs.i686


2. Edit grub.conf ( if you omit this step the driver will fail to work )


this command adds rdblacklist=nouveau option to /boot/grub/grub.conf


su -
sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)3. Reboot

chepioq
30th January 2010, 03:49 PM
Hi Leigh...
Thank for this tuto, that work with my rawhide kernel 2.6.33-0.24.rc5.git1.fc13.x86_64 and Nvidia card GeForce 8700M GT/PCI/SSE2

Sagitter
30th January 2010, 05:32 PM
Only for 64 bit arch? :confused:

leigh123linux
30th January 2010, 05:53 PM
Only for 64 bit arch? :confused:

No it should work for 32 bit as well.

Sagitter
30th January 2010, 08:47 PM
Very good !!!:D:cool:

nvidia driver beta are installed, thank you Leigh123Linux.

leigh123linux
3rd February 2010, 08:29 PM
Guide updated to 195.36.03

Kernel patch no longer needed.

chepioq
3rd February 2010, 08:40 PM
Before update to 195.36.03, I remove the 195.30-2 one?

leigh123linux
3rd February 2010, 08:53 PM
Before update to 195.36.03, I remove the 195.30-2 one?


No need, just run yum update

i.e

yum --nogpgcheck update /path/to/rpms

chepioq
4th February 2010, 07:56 AM
Hi Leigh
Thank that work...
I have just a question:
I am on x64, but for wine I need xorg-x11-drv-nvidia-libs-195.36.03-1.i686
And I don't remember how install (or built...) on my x64...

---------- Post added at 07:56 AM CST ---------- Previous post was at 07:17 AM CST ----------

I found the solution;
rpmbuild -ba xorg-x11-drv-nvidia.spec --define "kernels $(uname -r)" --target i686

leigh123linux
4th February 2010, 10:30 AM
Hi Leigh
Thank that work...
I have just a question:
I am on x64, but for wine I need xorg-x11-drv-nvidia-libs-195.36.03-1.i686
And I don't remember how install (or built...) on my x64...

---------- Post added at 07:56 AM CST ---------- Previous post was at 07:17 AM CST ----------

I found the solution;
rpmbuild -ba xorg-x11-drv-nvidia.spec --define "kernels $(uname -r)" --target i686



You could use

rpmbuild -ba xorg-x11-drv-nvidia.spec --target i686

chepioq
4th February 2010, 02:35 PM
Thank Leigh.

ZenmasteR
27th February 2010, 01:45 AM
can i use this for the 173x drivers?

Demz
27th February 2010, 01:49 AM
can i use this for the 173x drivers?

depends on the videocard you have

leigh123linux
27th February 2010, 10:41 AM
can i use this for the 173x drivers?


No, I don't deal with 173xx drivers.

Demz
27th February 2010, 10:46 AM
your better off to compile those drivers manually

leigh123linux
27th February 2010, 10:53 AM
Guide updated to 195.36.08

leigh123linux
7th March 2010, 10:12 AM
The driver doesn't build with the latest kernel.


WARNING: could not find /home/leigh/rpmbuild/BUILD/nvidia-kmod-195.36.08/_kmod_build_2.6.34-0.8.rc0.git11.fc14.x86_64/usr/src/nv/.nv-kernel.o.cmd for /home/leigh/rpmbuild/BUILD/nvidia-kmod-195.36.08/_kmod_build_2.6.34-0.8.rc0.git11.fc14.x86_64/usr/src/nv/nv-kernel.o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'rcu_lock_map'
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!

Sagitter
7th March 2010, 11:23 AM
Hi,

have you readed this news:

http://www.phoronix.com/scan.php?page=news_item&px=ODA0MA

?

:(

leigh123linux
7th March 2010, 11:39 AM
Hi,

have you readed this news:

http://www.phoronix.com/scan.php?page=news_item&px=ODA0MA

?

:(


Yes.

http://forums.fedoraforum.org/showthread.php?t=241786


http://leigh123linux.fedorapeople.org/pub/screenshots/nv_Screenshot.png

leigh123linux
7th March 2010, 12:00 PM
Hi,

have you readed this news:

http://www.phoronix.com/scan.php?page=news_item&px=ODA0MA

?

:(

If you suffer from over heating


su
yum install nvclock
nvclock -f --fanspeed 100

chepioq
7th March 2010, 05:44 PM
If you suffer from over heating


su
yum install nvclock
nvclock -f --fanspeed 100
That don't work on my laptop with nvidia card 8700M GT
[root@localhost dominique]# nvclock -f --fanspeed 100
Error: Your card doesn't support fanspeed adjustments!
[root@localhost dominique]#

Gaurav Prabhu
7th March 2010, 06:30 PM
I am on Fedora 12 & just updated my system with yum yesterday. Now I have got an updated version of Kernel. Now I get,

I now get "init : prefdm respawning too fast". The booting halts then.
Now I have booted in previous kernel & its working fine.

Will this guide help?

Sagitter
7th March 2010, 06:37 PM
Now is ok without using nvclock.

leigh123linux
7th March 2010, 06:52 PM
Now is ok without using nvclock.

The changes made by nvclock don't survive reboot so add the command to rc.local

Sagitter
7th March 2010, 08:00 PM
The changes made by nvclock don't survive reboot so add the command to rc.local


Ok, thank you.

leigh123linux
16th March 2010, 01:58 PM
Updated to 195.36.15

rockdoctor
27th March 2010, 11:14 PM
Ah, the joys of trying to use the nvidia driver on the moving target that is Rawhide. I'm just executing the nvidia file rather than creating a nice rpm, but that's neither here nor there . What's here is that kernel-2.6.34-0.4.rc0.git2.fc14.x86_64 plays nicely with
NVIDIA-Linux-x86_64-195.36.15-pkg2.run (no need to patch). What's there is that the latest kernel currently available, kernel-2.6.34-0.16.rc2.git0.fc14.x86_64.rpm, does not.

Fortunately, I know of no compelling reason to upgrade my Rawhide kernel at this time. Unfortunately, I didn't save the nvidia-installer.log file before restoring my system. Is there a new patch out there I can try?

leigh123linux
24th April 2010, 12:41 AM
Updated to 195.36.24

- Official Xorg 1.8 support added


http://www.nvnews.net/vbulletin/showthread.php?p=2239062

chepioq
3rd June 2010, 08:29 PM
Hi leigh,
Is this guide work for rawhide F14 and kernel 2.6.34 ?

leigh123linux
3rd June 2010, 09:11 PM
Hi leigh,
Is this guide work for rawhide F14 and kernel 2.6.34 ?

No, the extra debugging in the fedora 2.6.34 kernel prevents this, use the F13 kernel instead.

YeOK
3rd June 2010, 11:40 PM
No, the extra debugging in the fedora 2.6.34 kernel prevents this, use the F13 kernel instead.

I have a sound card that requires the 2.6.34 kernel, I managed to recompile the Fedora 14 kernel here on Fedora 13, the standard akmod package compiles fine now. I had to edit the config_nodebug file, then make a custom Fedora 13 package. I deleted the changes but being super lazy, I simple used the replace tool; '=y for =n'.

Screenshot: http://dl.dropbox.com/u/109740/Screenshots/2634-nvidia.png

Only really helpful if you want to build a custom kernel though.

leigh123linux
11th June 2010, 10:24 PM
I have a sound card that requires the 2.6.34 kernel, I managed to recompile the Fedora 14 kernel here on Fedora 13, the standard akmod package compiles fine now. I had to edit the config_nodebug file, then make a custom Fedora 13 package. I deleted the changes but being super lazy, I simple used the replace tool; '=y for =n'.

Screenshot: http://dl.dropbox.com/u/109740/Screenshots/2634-nvidia.png

Only really helpful if you want to build a custom kernel though.


The nvidia driver now works with 2.6.34


http://koji.fedoraproject.org/koji/buildinfo?buildID=176236



* Tue Jun 01 2010 Kyle McMartin <kyle@redhat.com> 2.6.34-16
- quiet-prove_RCU-in-cgroups.patch: shut RCU lockdep up as in 8b08ca52f5942c21564bbb90ccfb61053f2c26a1.

chepioq
30th June 2010, 07:47 AM
I test F14 rawhide, but kernel 2.6.34 and.2.6.35 don't boot on my toshiba...

But the latest kernel: 2.6.35-0.13.rc3.git2.fc14.x86_64 boot (it's a good new for me...).

I test and it work, but akmod-nvidia don't work...
Do you think that drivers nvidia can work on 2.6.35 kernel in future?

chepioq
1st July 2010, 07:38 PM
I test F14 rawhide, but kernel 2.6.34 and.2.6.35 don't boot on my toshiba...

But the latest kernel: 2.6.35-0.13.rc3.git2.fc14.x86_64 boot (it's a good new for me...).

I test and it work, but akmod-nvidia don't work...
Do you think that drivers nvidia can work on 2.6.35 kernel in future?

A little up...

vallimar
2nd July 2010, 05:28 PM
Works fine for me, but I'm using the 256.35 drivers which are the new stable branch.

chepioq
2nd July 2010, 05:43 PM
Works fine for me, but I'm using the 256.35 drivers which are the new stable branch.

Where did you find the kmod for 256.35 drivers ?

tox
3rd July 2010, 04:08 AM
he probably downloaded them from nvidia's ftp site

---------- Post added at 12:08 PM CDT ---------- Previous post was at 12:07 PM CDT ----------

i dont see them in RPMfusion

GoinEasy9
3rd July 2010, 05:09 AM
Nvidia's site does not contain kmod's.

chepioq
3rd July 2010, 07:54 AM
Nvidia's site does not contain kmod's.

I know that, and I know how install nvidia drivers with the nvidia site...
But it's not practice for rawhide, because there are a lot of new kernel (three in three days...),

If 256.35 drivers work with 2.6.35 kernel, I think it is more easy use akmod-nvidia for rawhide.

Unfortunately, I am not able to make that...

vallimar
3rd July 2010, 02:42 PM
I build my own kmods. I submitted my changes/updates to kwizart / rpmfusion a couple weeks ago but I presume they haven't had time to update things or just didn't like my new methods for handling the sweeping changes Nvidia made to the driver layout.

I've been building my own kernels again lately as well to strip out some of the more useless bits and debugging code I don't need. So not sure if they would work with a stock Fedora kernel with debugging enabled either.

---------- Post added at 08:42 AM CDT ---------- Previous post was at 08:35 AM CDT ----------

But it's not practice for rawhide, because there are a lot of new kernel (three in three days...)
You don't have to install every kernel they push. The problem is they go weeks sometimes without any updates and then will build several on top of eachother, each one fixing one tiny little thing that most likely wasn't a problem for you. For awhile they were building dozens of kernels for repeated tweaking of intel and radeon drivers, which if you didn't even have those, served no purpose in updating. Check the changelog before you potentially waste your time and bandwidth on their development kernel updates.

chepioq
4th July 2010, 08:59 AM
I build my own kmods. I submitted my changes/updates to kwizart / rpmfusion a couple weeks ago but I presume they haven't had time to update things or just didn't like my new methods for handling the sweeping changes Nvidia made to the driver layout.
.

An other question:
How can I build an akmod-nvidia?
Have you a tutorial for that?

vallimar
5th July 2010, 03:14 PM
I've never dealt with the akmods, so I can't give much information there.
Maybe someone else can offer guidance, otherwise search through the forums as it's likely come up before.

teekay78
5th July 2010, 03:23 PM
Works fine for me, but I'm using the 256.35 drivers which are the new stable branch.

Did you also hit this error?

FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'debu
g_lockdep_rcu_enabled'
make[4]: *** [__modpost] Fehler 1

Both the akmods and latest upstream 256.35 versions do not compile against this kernel.
Unfortunately nouveau driver also doesn't work ([drm] no devices found).

vallimar
5th July 2010, 11:16 PM
You have to use a kernel without debugging code, either from F13, or a manually rebuilt one from F14.
As mentioned above, I roll-my-own kernels so don't have that constant problem that Fedora devs inflict upon their users. Also, don't try to update to the Xorg 1.9 code yet, doesn't work too well.

teekay78
6th July 2010, 09:57 AM
You have to use a kernel without debugging code, either from F13, or a manually rebuilt one from F14.
As mentioned above, I roll-my-own kernels so don't have that constant problem that Fedora devs inflict upon their users. Also, don't try to update to the Xorg 1.9 code yet, doesn't work too well.

Thanks for the info, vallimar.

I found a working pre-built kernel on koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=179074

All fine with that one.

vallimar
6th July 2010, 03:03 PM
Good find. I forgot they had some 2.6.34 with separate debug builds in F14.
You may want to use this one instead though: http://koji.fedoraproject.org/koji/buildinfo?buildID=181064

chepioq
6th July 2010, 05:13 PM
Thanks for the info, vallimar.

I found a working pre-built kernel on koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=179074

All fine with that one.

It is a 2.6.34 kernel, but now for rawhide there are 2.6.35 kernel...

chepioq
12th July 2010, 06:38 AM
Just an info:
The latest xorg-x11-server (1.8.99.904-3.20100702.fc14) don't work with drivers nvidia 195.36.31-1.fc14

tox
12th July 2010, 06:42 AM
have you tried using the 256 drivers with that x-server ?

chepioq
12th July 2010, 06:52 AM
have you tried using the 256 drivers with that x-server ?

No, i wait for a kmod or akmod for this version...

tox
12th July 2010, 06:56 AM
No, i wait for a kmod or akmod for this version...

thats the only driver thats gonna work with that Server version now.

vallimar
12th July 2010, 07:46 PM
I already stated several days ago not to bother as it doesn't work with the new driver.

jonrysh
19th July 2010, 01:50 AM
Works fine for me, but I'm using the 256.35 drivers which are the new stable branch.

What's the easiest way to remove the nvidia kmod/akmod rpms and install the nvidia 256.35 drivers? Right now, I'm running kmod-nvidia-195.36.31-1.fc13.1.x86_64, which makes googleearth crash on startup. I'd like to try out nvidia's latest before it gets released by rpmfusion, which may take a while. But the obvious:
# rpm --erase ...nvidia...kmod... ...nvidia...akmod...
# sh NVIDIA-Linux-x86_64-256.35.run
could easily make my system unusable.

tox
19th July 2010, 02:04 AM
What's the easiest way to remove the nvidia kmod/akmod rpms and install the nvidia 256.35 drivers? Right now, I'm running kmod-nvidia-195.36.31-1.fc13.1.x86_64, which makes googleearth crash on startup. I'd like to try out nvidia's latest before it gets released by rpmfusion, which may take a while. But the obvious:
# rpm --erase ...nvidia...kmod... ...nvidia...akmod...
# sh NVIDIA-Linux-x86_64-256.35.run
could easily make my system unusable.
su
yum erase kmod-nvidia akmod-nvidia

why do you have the 2? akmod an the kmod?

GoinEasy9
19th July 2010, 02:09 AM
The akmod builds the kmod, that's why both are there.

tox
19th July 2010, 02:38 AM
The akmod builds the kmod, that's why both are there.

exactly, but he didnt explain if he downloaded the 2 from RPMFusion ( which a lot do ) or if he just has the akmod which builds the kmods for each kernel you install.

jonrysh
19th July 2010, 07:16 AM
exactly, but he didnt explain if he downloaded the 2 from RPMFusion ( which a lot do ) or if he just has the akmod which builds the kmods for each kernel you install.

Usually I run a the latest vanilla kernel from the Fedora repos; then I'm happy to run the matching kmod from rpmfusion. Sometimes I rebuild the kernel to make it preemptible (for audio recording); then I need akmod.

Thanks for the advice

jonrysh
19th July 2010, 09:36 PM
su
yum erase kmod-nvidia akmod-nvidia

Thanks again for the advice. The latest version of the proprietary nvidia drivers, NVIDIA-Linux-x86_64-256.35.run, stops googleearth from crashing.

But there's more stuff that has to be erased. After "$ yum erase ...", and installing the proprietary nvidia drivers version 256.35 booting produced these nasty errors:
iptables: Applying firewall rules: [ OK ]
Checking for module nvidia.ko: [FAILED]
nvidia.ko for kernel 2.6.33.6-147.fc13.x86_64 was not found. [WARNING]
The nvidia driver will not be enabled until one is found. [WARNING]
/etc/rc5.d/S08nvidia: line 42: 1066 Segmentation fault $exec disable
Starting portreserve: [ OK ]
Though the system ran OK.


I got rid of the errors by "rpm --erase"ing the following:
akmods-0.3.6-3.fc12.noarch
buildsys-build-rpmfusion-kerneldevpkgs-current
kmod-nvidia-2.6.33.5-112.fc13.jon.x86_64-195.36.24-1.fc13.5.x86_64
kmod-nvidia-2.6.33.5-124.fc13.x86_64-195.36.31-1.fc13.x86_64
kmod-nvidia-2.6.33.6-147.fc13.x86_64-195.36.31-1.fc13.1.x86_64
kmodtool-1-18.fc11.noarch
nvidia-kmod-debuginfo-195.36.31-1.fc13.1.x86_64
xorg-x11-drv-nvidia-195.36.31-2.fc13.x86_64
xorg-x11-drv-nvidia-devel-195.36.31-2.fc13.x86_64
xorg-x11-drv-nvidia-libs-195.36.31-2.fc13.i686
xorg-x11-drv-nvidia-libs-195.36.31-2.fc13.x86_64

But (apparently from getting confused) rpm removed the nvidia drivers just built. I reinstalled the nvidia proprietary drivers (now the installation process got confused and produced lots of spurious errors) -- and now everything runs OK (at least so far).

So it looks like the thing to do is in this order

Remove the kmod/akmod stuff
Install the nvidia proprietary drivers

vallimar
31st July 2010, 02:19 AM
FYI -- the new Nvidia pre-release driver, 256.44 works with the latest Xorg 1.9 pre-release now.
You still need a non-debug kernel most likely.

jonrysh
3rd August 2010, 01:57 PM
Thanks vallimar. I have installed the 256.44 from the Nvidia site, and it works find, including Google Earth, which previously crashed on starting.

lovenemesis
23rd August 2010, 07:55 PM
Does it mean I have to use 2.6.34 kernel in F14 to get nvidia binary driver working?

Cheers,

jonrysh
23rd August 2010, 08:55 PM
Does it mean I have to use 2.6.34 kernel in F14 to get nvidia binary driver working?

Cheers,

I don't think so, provided you download the latest package from Nvidia. It should compile and install in the same way that packages can be installed for Fedora-13 (I hope.)

jon

lovenemesis
23rd August 2010, 10:35 PM
I was hit by the problem when compiling the nvidia.ko module:

http://forums.fedoraforum.org/showpost.php?p=1378584&postcount=43

Didn't go as what it used be on F13. :(

thesun
24th August 2010, 12:19 AM
Why am I not finding the akmod-nvidia rpms? I'm using nouveau and experiencing lots of X crashes. Thought switching driver might help but this doesn't seem to work now...

vallimar
24th August 2010, 03:54 AM
I was hit by the problem when compiling the nvidia.ko module:

http://forums.fedoraforum.org/showpost.php?p=1378584&postcount=43

Didn't go as what it used be on F13. :(
Development kernels have extra debugging enabled which causes this problem.
If you want to play in the unstable playground and have working Nvidia drivers, then
you have 2 choices: Stick with an older kernel that has separate debug packages,
or learn to build your own kernels with separate or removed debugging bits.

This has been mentioned several times so it shouldn't be news if you had done
some searching around.

---------- Post added at 09:54 PM CDT ---------- Previous post was at 09:52 PM CDT ----------

Why am I not finding the akmod-nvidia rpms? I'm using nouveau and experiencing lots of X crashes. Thought switching driver might help but this doesn't seem to work now...

Look to rpmfusion.org. They won't work with a development kernel for the same reasons
mentioned previously. Also, rpmfusion hasn't updated to the latest drivers.

AlexZ
30th September 2010, 11:50 AM
Hi all. In rpmfusion repo akmod-nvidia has version 195* and xorg-x11-nvidia has version 256*, so it is does not work. Now I'm using binaries from nvidia.com, but it's working bad (for ex. scrolling in gedit is too slow). How to fix it?. Thanks.

uname -a
Linux localhost.localdomain 2.6.35.6-37.fc14.i686.PAE #1 SMP Fri Oct 1 06:14:07 UTC 2010 i686 i686 i386 GNU/Linux

yum repolist:
fedora Fedora 14 - i386 17*810
google-chrome google-chrome 5
rpmfusion-free-rawhide RPM Fusion for Fedora Rawhide - Free 524
rpmfusion-nonfree-rawhide RPM Fusion for Fedora Rawhide - Nonfree 195
updates Fedora 14 - i386 - Updates 0
repolist: 18*534

chepioq
10th October 2010, 07:55 AM
Hi all. In rpmfusion repo akmod-nvidia has version 195* and xorg-x11-nvidia has version 256*, so it is does not work. Now I'm using binaries from nvidia.com, but it's working bad (for ex. scrolling in gedit is too slow). How to fix it?. Thanks.

uname -a
Linux localhost.localdomain 2.6.35.6-37.fc14.i686.PAE #1 SMP Fri Oct 1 06:14:07 UTC 2010 i686 i686 i386 GNU/Linux

yum repolist:
fedora Fedora 14 - i386 17*810
google-chrome google-chrome 5
rpmfusion-free-rawhide RPM Fusion for Fedora Rawhide - Free 524
rpmfusion-nonfree-rawhide RPM Fusion for Fedora Rawhide - Nonfree 195
updates Fedora 14 - i386 - Updates 0
repolist: 18*534

The kmod 195* is not compatible with the F14 xorg,
If you want install kmod-nvidia drivers, install the 260.19 version, look at http://forums.fedoraforum.org/showthread.php?t=237118&highlight=nvidia

tox
22nd January 2011, 07:42 AM
find new Drivers here http://www.nvnews.net/vbulletin/showthread.php?t=122606

phoenixpb
22nd January 2011, 02:35 PM
173.14.28 doesn't work

tox
22nd January 2011, 11:49 PM
A NEW BETA LINUX DRIVER WORKS WITH X-SERVER 1.10 AND KERNEL 2.6.38 http://www.nvidia.com/object/linux-display-amd64-270.18-driver.html http://www.nvidia.com/object/linux-display-ia32-270.18-driver.html

---------- Post added at 09:42 AM ---------- Previous post was at 09:35 AM ----------

ftp://download.nvidia.com/XFree86/Linux-x86/270.18/

ftp://download.nvidia.com/XFree86/Linux-x86_64/270.18/

---------- Post added at 09:49 AM ---------- Previous post was at 09:42 AM ----------

i have no idea about legacy drivers being updated to work with 1.10 at this point

leigh123linux
23rd January 2011, 04:30 AM
A NEW BETA LINUX DRIVER WORKS WITH X-SERVER 1.10 AND KERNEL 2.6.38 http://www.nvidia.com/object/linux-display-amd64-270.18-driver.html http://www.nvidia.com/object/linux-display-ia32-270.18-driver.html

---------- Post added at 09:42 AM ---------- Previous post was at 09:35 AM ----------

ftp://download.nvidia.com/XFree86/Linux-x86/270.18/

ftp://download.nvidia.com/XFree86/Linux-x86_64/270.18/

---------- Post added at 09:49 AM ---------- Previous post was at 09:42 AM ----------

i have no idea about legacy drivers being updated to work with 1.10 at this point


It wont work with the fedora 2.6.38 kernel due to the extra debugging.

tox
23rd January 2011, 04:36 AM
It wont work with the fedora 2.6.38 kernel due to the extra debugging.

ohh ok, ................

leigh123linux
23rd January 2011, 04:50 AM
ohh ok, ................

And FYI 260.19.36 will compile OK with the 2.6.38 kernel (compiled without the extra debugging).


[leigh@localhost ~]$ rpm -qa |grep nvidia |sort
kmod-nvidia-2.6.36.2-12.rc1.fc14.x86_64-260.19.36-1.fc14.x86_64
kmod-nvidia-2.6.37-1.fc14.x86_64-260.19.36-1.fc14.x86_64
kmod-nvidia-2.6.38-0.rc2.git0.1.fc15.x86_64-260.19.36-1.fc14.x86_64
nvidia-settings-1.0-9.fc14.x86_64
nvidia-xconfig-1.0-6.fc14.x86_64
xorg-x11-drv-nvidia-260.19.36-1.fc14.x86_64
xorg-x11-drv-nvidia-libs-260.19.36-1.fc14.i686
xorg-x11-drv-nvidia-libs-260.19.36-1.fc14.x86_64
[leigh@localhost ~]$ cat /etc/fedora-release
Fedora release 14 (Laughlin)
[leigh@localhost ~]$ uname -r
2.6.38-0.rc2.git0.1.fc15.x86_64
[leigh@localhost ~]$

tox
23rd January 2011, 04:56 AM
thanks for that info leigh. wonder why those users on the Ubuntu forum didnt know that , unless i missed a thread.

leigh123linux
23rd January 2011, 05:06 AM
thanks for that info leigh. wonder why those users on the Ubuntu forum didnt know that , unless i missed a thread.


Looks like the new driver still has issues with the new Xorg ABI

http://www.nvnews.net/vbulletin/showthread.php?t=158983

tox
23rd January 2011, 05:08 AM
leigh, wouldnt the 270 drivers work if you say do this

Section "ServerFlags"
Option "IgnoreABI" "True"
EndSection

leigh123linux
23rd January 2011, 05:13 AM
leigh, wouldnt the 270 drivers work if you say do this

Section "ServerFlags"
Option "IgnoreABI" "True"
EndSection


It might work, it didn't work for 260.x.x


Nvidia don't claim to fully support it yet


Added preliminary support for xserver 1.10.

tox
15th February 2011, 11:08 PM
270.29 32bit Driver (ftp://download.nvidia.com/XFree86/Linux-x86/270.29/)

270.29 64Bit Driver (ftp://download.nvidia.com/XFree86/Linux-x86_64/270.29/)

http://www.nvnews.net/vbulletin/showthread.php?p=2396539

Hospital dos Lusiadas - Cataratas Do Iguacu - Brasil Travel Photos on Instagram