PDA

View Full Version : Soundproblem


god
28th February 2004, 01:56 PM
I searched through the internet but i didn't find a solution.
I have got a AC 97 soundcard made by VIA and I installed alsa!

My modprobe.conf:

alias eth0 via-rhine

include /etc/modprobe.conf.dist
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394


# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-via82xx
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && { /usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-card-0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove

alias sound-slot-0 snd-via82xx
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :



--------------------

Can anyone help me?

mhelios
28th February 2004, 04:03 PM
Have you unmuted all sound channels using `alsamixer` or the graphical `gnome-alsamixer`? They're muted by default.
If that doesn't work, have a look in our how-to forum for tutorials on setting up ALSA.

god
29th February 2004, 12:09 AM
When I start alsamixer I get that error:
alsamixer: function snd_ctl_open failed for default: No such device

Bana
29th February 2004, 07:23 PM
Hi, I am also going through this same procedure and here is a helpful link: http://www.linuxquestions.org/questions/archive/25/2003/12/2/112279 what it says is that you have to run the ./snddevices script during the install to get rid of this message. Unfortunately this didn't work for me but it seems to work most of the time.

HTH

god
2nd March 2004, 12:23 PM
Thanks, but it doesn't help!

I've forgotton to say that I'm using Fedora Core 2 test 1 and my Soundcard is snd-via82xx.

dpw2atox
2nd March 2004, 11:10 PM
in up2date get the new version of system-config-soundcard and also check for any alsa updates. That may fix your problem as sound was somewhat broken on test 1.

mhelios
3rd March 2004, 08:53 AM
Try usinf `aumix` if alsamixer doesn't work.

Maybe your sound modules aren't loading properly? Do an `/sbin/lsmod | grep snd` to confirm.
Do a `cat` of /proc/asound/cards to confirm that the card is loaded properly.

god
3rd March 2004, 03:52 PM
aumixer can't start!

lsmod gives me this:
snd_pcm_oss 48548 0
snd_pcm 99208 1 snd_pcm_oss
snd_page_alloc 11524 1 snd_pcm
snd_timer 30212 1 snd_pcm
snd_mixer_oss 17024 1 snd_pcm_oss
snd 53476 4 snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 9952 1 snd

and /proc/asound/cards shows this:
--- no soundcards ---

mhelios
4th March 2004, 12:49 AM
Ok, /proc/asound/cards show no sound card installed. That's obviously why alsamixer isn't working! Refer to one of the guides located on this site (how-to) to get ALSA up and running properly. Have a look at the 2.6 kernel how to I posted.

Bana
4th March 2004, 03:45 AM
Hmm, could it perhaps be that our soundcards aren't the exact ones? As mine is an onboard card whereas the module I am using is for pci cards, would modprobe be successfully running if it wasn't the right card though?

I have tried everything in the various howtos and guides that I could yet none seem to work, any input would be appreciated.

god
4th March 2004, 12:55 PM
Yeah. It works now. The only thing was modprobe snd-via82xx
alsamixer

I found another thread in this forum (http://www.fedoraforum.org/forum/showthread.php?s=&threadid=247)
which helped me!

Thank you guys.

Bana
5th March 2004, 01:07 AM
so you just ran modprobe snd-via82xx and then it fixer alsamixer? I wish mine was that easy :(

god
5th March 2004, 03:19 PM
It was that easy :-)

mars_hall
6th March 2004, 11:43 PM
How do I save the settings in "aumix" so the I don't have to un-mute the settings after a re-boot? I have already tried "S", but after rebooting all the levels are back at 0

mhelios
7th March 2004, 02:04 AM
Add this to your /etc/modprobe.conf:

post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

This will save on shutdown/reboot and load on startup your defined settings.

mars_hall
7th March 2004, 02:30 AM
OK trie that rebooted...sound still muted.
I am using Fedorara core 2 test 1
does that make any difference?

mhelios
7th March 2004, 03:27 AM
Woops! test1 eh. You should store the settings with `alsamixer` since t1 uses ALSA over the older OSS drivers..
How about this:

post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :

mars_hall
7th March 2004, 04:59 AM
still getting the same problem. "aumix" everything at 0 after re-boot.
Did I miss something?

I can't open "alsamixer"

mars_hall
7th March 2004, 05:27 AM
Maybe I shouldn't keep to my "Windoze" roots. If I just resist the urge to re-boot mp3's play just fine.

Bana
9th March 2004, 02:24 AM
Yes, the urge is strong and I succumb to the temptation all too often :cry:

Try using alsaconf or alsactl to save and auto setup your levels, I believe they are located in /usr/sbin (or maybe /usr/bin)

Mamou Travel Photos - Wrexham - Sukhinichi Instagram Photos