PDA

View Full Version : F12 + LSI Logic 1020/1030 MPTSCSI not detected


czeller91042
28th December 2009, 07:33 AM
Fedora 12 x86_64 system not detecting onboard MPT Fusion SCSI controllers.
System:
HP xw9300
2 x 2.6 GHz AMD Opteron
4GB RAM
4 x 500 GB 7200 RPM Sata-3 drives on "sata_nv" driver
NVidia Quadro FX1400 graphics
Motherboard dual channel LSI Logic "Fusion" 1020/1030 Ultra320 SCSI which had been
recognized by previous FC6 install as mptscsih, mptbase
Internal HP LTO-2 parallel-SCSI tape

The mptscsih, mptbase, st modules are not being loaded.
An "lspci" does not show the SCSI controller.

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
05:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
0a:00.0 VGA compatible controller: nVidia Corporation NV41GL [Quadro FX 1400] (rev a2)
[/FONT]

Does MPTSCSI SPI (parallel SCSI) now require a custom kernel compile?

Thanks.

tashirosgt
1st January 2010, 07:08 PM
Have you tried adding the modules to the kernel with the modprobe command? That would confirm whether the modules are useful.

czeller91042
2nd January 2010, 09:54 AM
The modules all load when invoked with modprobe. The problem seems to be that the controller is not being sensed on the PCI bus. During bootup, the controllers BIOS message comes up, and you can run the configuration dialog. The dmesg output does not mention the controller.

Craig Zeller

---------- Post added 2010-01-02 at 01:54 AM CST ---------- Previous post was 2010-01-01 at 10:38 PM CST ----------

The solution was to append "acpi=off" to the kernel parameters in grub.conf. Looks like this problem has been around since Fedora Core 4 days.

Ahvaz - Yogyakarta - Melbourne Travel Photos on Instagram -