PDA

View Full Version : Warning: be careful using yumex to update F12


AdamW
27th October 2009, 08:12 PM
Just a general warning - it's come to light in a couple of threads that if you use yumex to update a Fedora 12 Beta installation, it seems to have trouble updating the kernel package, and leaves the updated kernel broken. If you're stuck in this situation, remove the new kernel package and re-install it using yum or PackageKit, that should make it work properly. If you've installed F12 Beta but haven't updated yet, please update with yum or PackageKit, not yumex.

Thanks!

ovadyah
27th October 2009, 09:44 PM
Thanks for this update. I have done as prescribed and the new kernel is working, it is working as the old one did...no NM and I am getting the same boot error as I posted in the other thread.

""WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d"

Thanks for all the help and the progress I have made.

Dan
27th October 2009, 10:16 PM
Adam, this could nail a lot of folks, so I'm adding this to an announcement.

flokip
27th October 2009, 10:47 PM
I did file bug
Reported: 2009-09-16
https://bugzilla.redhat.com/show_bug.cgi?id=523644

ryptyde
28th October 2009, 03:54 AM
Had the yumex problem with the kernel update and removed the kernel then done yum update and it fixed the problem.

Before reinstalling the kernel it would boot to a black screen to an unresponsive blinking cursor and then doing Ctrl+Alt+F2 would get me to a text login. Entering startx would error out with no suitable screens.

I would have never guessed that yumex was the culprit and it does appear to boot quicker too! :)

VernDog
28th October 2009, 05:22 AM
I don't even know what "yumex" is. If fact I get 'Command not found' when trying to find help. I have seen several references about it and figured I don't need it.

Demz
28th October 2009, 05:23 AM
http://www.yum-extender.org/blog/

mit
28th October 2009, 01:59 PM
Check here for details about the issue

http://www.yum-extender.org/blog/2009/10/selinux-issues-in-yum-extender-2-9-x/

robatino
28th October 2009, 04:54 PM
Thanks for this update. I have done as prescribed and the new kernel is working, it is working as the old one did...no NM and I am getting the same boot error as I posted in the other thread.

""WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d"


The file /etc/modprobe.conf isn't even supposed to exist. Do an ls -l on it to see when it was created and if it's a zero-byte file. Also run "rpm -qf /etc/modprobe.conf" to see if it's owned by any package. If not, you should be able to remove it to get rid of the error message. I've seen the same problem with this file being created at install time (not with F12 Beta, but with F11, I think). No one has figured out why this happens occasionally or what is responsible for creating it.

ovadyah
28th October 2009, 05:25 PM
The file /etc/modprobe.conf isn't even supposed to exist. Do an ls -l on it to see when it was created and if it's a zero-byte file. Also run "rpm -qf /etc/modprobe.conf" to see if it's owned by any package. If not, you should be able to remove it to get rid of the error message. I've seen the same problem with this file being created at install time (not with F12 Beta, but with F11, I think). No one has figured out why this happens occasionally or what is responsible for creating it.

Thanks, it was as you said. I do see the error in the boot messages, can I get that to clear some way? I tried rebooting twice and it is still there.

robatino
28th October 2009, 05:27 PM
Is it in fact a zero-byte file? Does the modification time tell you whether it was created at install time? Is it owned by any package? Did you delete the file as I suggested, and if so, is it being recreated each time you boot?

ovadyah
28th October 2009, 06:52 PM
It was a zero byte file, I did not really note the time of creation, it was not owned by any package, I deleted it and it has not re-appeared. The error message in the boot log is there each time I boot. Perhaps there is a way to clear that?
thanks again.

robatino
28th October 2009, 07:04 PM
I don't understand why the message would appear if the file it refers to doesn't exist anymore. After I deleted this file on my machine, the error message disappeared.

ovadyah
28th October 2009, 07:25 PM
I don't understand why the message would appear if the file it refers to doesn't exist anymore. After I deleted this file on my machine, the error message disappeared.

It still appears, however it is before everything else, even before Welcome to Fedora. It is like it is stuck in the header???????? I do not get the error down in the boot log steps, as I did before.

robatino
28th October 2009, 07:29 PM
If you're talking about graphical boot, I disabled that by deleting "rhgb" and "quiet" from the kernel lines in grub.conf, so maybe that's why I don't see the same problem.

Jongi
28th October 2009, 07:33 PM
i have been getting that error message on debian on my custom built kernels since 2.6.30

Seychelles - Bundibugyo Travel Photos on Instagram - As Samawah Travel Photos on Instagram