PDA

View Full Version : State of intel driver and relate libraries in F11


TheIcebreaker
15th June 2009, 02:04 AM
Hi,
Tried Fedora but it is really not usable with compiz fusion on for me.
I am using a G33 motherboard on 2.33 GHz Core 2 duo.

Wat I want to ask is why there hasn't ben a build for the 2.7 intel driver which has been released as stable. There is libdrm 2.4.11 missing. Version in F11 is 2.4.6.

Is there a reason for this??? Does someone know.

Wat I have heard was that 2.6 driver really introduced KMS and DRI2 and had many bugs which have been worked out since in the 2.7 driver. Currently performance with DRI2 and KMS is horrible when compiz fusion is on. Textured video also is a mess with massive tearing.
F10 was perfect with no tearing on overlay and very good compiz performance

nirik
15th June 2009, 03:23 AM
There is. F11 comes with 2.7.0.

I expect the x maintainers will update libdrm when they deem it's ready.

TheIcebreaker
15th June 2009, 05:06 AM
I am sorry for that I was looking at the i810 package and didnt realise they renamed it as intel.

Still the performance problems exist be it 2.7. Thats even more worrying now as I thought updating to 2.7 would fix it.

nirik
15th June 2009, 05:09 AM
Well, I have a 915 and a 945 here and both are working fine... I don't see any performance issues. Perhaps it's a bug with your specific card?

Perhaps file a bug on it?

TheIcebreaker
15th June 2009, 04:43 PM
Well it depends maybe u were having issues all along and therefore dont notice the diffrence

I used to get 3000 in glxgears now its down too 750.
Menus flicker a lot. and everything is just generally slow.

nirik
15th June 2009, 06:04 PM
glxgears is NOT a benchmark. ;)

http://qa-rockstar.livejournal.com/7869.html

Things seem nice and snappy here... again, I am suspecting a bug in the support for your specific card. File a bug?

hotdog
16th June 2009, 01:10 AM
Looking at the Intel Linux Graphics page for the 2009Q1 (http://intellinuxgraphics.org/2009Q1.html) graphics package (the latest one, which includes the release of the 2.7.0 2D driver) it says "note: libdrm >2.4.6 is required for xf86-video-intel 2.7.0". My fresh F11 install has xorg-x11-drv-intel-2.7.0-7.fc11.i586 together with libdrm-2.4.6-7.fc11.i586, which in theory at least is an incompatible combination. I haven't noticed any problems myself yet though.

Algernon
5th July 2009, 07:36 AM
Granted I have an old system but...

Video and pictures (outside Firefox) makes the screen full of distorted blocks.

Gpu is 82845G/GL

I'm now going to try the nomodeset to boot parameters but would rather fix this properly.
In F10 I had the "XAA" option in xorg.conf because othervice X-would be buggered...

wvn
5th July 2009, 08:18 AM
i think i will try to revert to intel 2.4

Algernon
5th July 2009, 10:14 AM
Ok, now youtube (and flash) works but VLC / Mplayer either freeze or crash X.

Some work still needed.

and naturally the bootup animation is back to bars on the bottom.

Algernon
18th September 2009, 08:19 PM
Ok, happenend to stumble on this again...
Anyone seeing this should try to disable the tiling from xorg.conf.
There are instructions floating somewhere here.

However I'm not happy with the performance of this driver on overall.
Even Youtube seems to be sluggish. I do know that this is an embedded ship and not the fastest thing out there but still...

Zaafarana Rest House Photos on Instagram - Parliament of Canada - Calaguas Island Beach - American Express sala VIP Photos