PDA

View Full Version : Unable to view samba server from windows 98


linux_fed2
17th September 2004, 11:41 AM
hi,
am new to linux. i have installed fc2 and configure samba, but i can't view the samba server from windows 98. Below are the informations:
FC2 Box:
IP: 192.168.0.100
net: 255.255.255.0
hostname: linux_fc2

/etc/smb.conf:
------global section-----
workgroup=mygroup
netbios name=sambaserver
server string=archive
host allow=192.168.0. 127.
-----share definitions----
[sambaserver]
comment=public
path=/var/public
writable=yes
printable=no

Win 98 Box:
IP: 192.168.0.46
net: 255.255.255.0
workgroup: mygroup
computer name: unit

i can ping the ip of FC2 box. Thanks in advance! :confused:

superbnerd
17th September 2004, 12:17 PM
1) your smb.conf usually is in /etc/samba/ how did you install samba?
2) you config looks a like its missing things like what security level (share).
3) I suggest you enable wins support (wins support = yes).
4) its best if you use the gui tool system-config-samba and than add any extra option to the smb.conf file directly.
4) you will need to open the appropiate port on you firewalls (137-139, 445 tcp and udp).

Vinny
17th September 2004, 02:33 PM
hi, i have a similair issue with winxp boxs trying to access fc2 server. can you explain point 4 or show a link to how to?
regards Vinny
ps i have firewall configured correctly as point 4.

re windows 98 i have seen posts that mention due to encryption of log on. there is a setting of fedora that needs changing. sorry forgot to take note.

superbnerd
18th September 2004, 01:22 AM
you can open ports in fc2 by adding this "137:tpc, 137:udp" at the bottom of the security level. or you can use a much better firewall front end, firestart. yum install firestarter

linux_fed2
21st September 2004, 02:34 AM
thanks for the reply.
sorry for that, you are right path for smb.conf is /etc/samba/smb.conf.

i can now see my samba server from my win 98 box by turning off the firewall. the problem is, it's asking me for password to establish the connection. i also add "wins support=yes" and "security = share" in my configuration.

thanks!

superbnerd
21st September 2004, 02:49 AM
1) you don't need to turn of your firewall and you shouldn't! you just need to open the ports I mentioned in my first post.
2) FYI the wins support is what allows the computers to find you on the network. they do the name serving and discovering.
3) the asking for password is a know problem. it has been discussed in this forum several times. so do a search, but if I find the solution before you, I'll post the link here. likewise, if you find it, post the link to help others with similar problems.

linux_fed2
21st September 2004, 04:52 AM
thank you very much for your replies i can now access my samba server.

Helpful link:
http://www.linuxquestions.org/questions/archive/3/2001/12/2/9834

ghenry
21st September 2004, 05:32 PM
run testparm for checking the config.

You must have the right permissions on /var/public. Read the samba examples docs on www.samba.org

Salsomaggiore Terme Photos on Instagram - Diglur Travel Photos on Instagram - Khammam