PDA

View Full Version : FC2 Sound problem


mip
20th May 2004, 09:30 AM
When I login to KDE on my new FC2 install I get a permanent hissing sound coming from my left speaker.

Has anyone else encountered this problem? Sounds and media files seem to play ok but the hissing persists.

Any ideas? I've never had any sound problems with linux distros in the past so I'm guessing that this is something to do with ALSA.

mip
20th May 2004, 02:48 PM
No one encountered this? I'll try logging into Gnome this evening to see if this is a KDE problem.

xmmx
20th May 2004, 04:17 PM
Yes! I just burned discs and loaded them last night and everything was fine in Gnome (although I couldn't get the speakers to pipe up with anything), when I logged back in to KDE, the left speaker started making a very loud buzzing sound.

I seem to recall this was a problem in one of the release candidates.

Wish I could help but I don't know what the problem is.

gunnyman
20th May 2004, 05:13 PM
do you have an audigy?
If so,
open kmix
click advanced
I bet Audigy Analog is turned on.
Turn it off
this is common with alsa and SB audigy cards.

mip
20th May 2004, 06:18 PM
I'm not sure what audigy is.

I managed to sort out the problem by turning off IEC958 under the advanced option. Is this what you were refering to?

What is IEC958? I never have to switch it off previously.

How can I make this setting system wide for all users?

My sound card details are:

Vendor: Ensoniq
Model: 5880 AudioPCI
Module: snd-ens1371

xmmx
21st May 2004, 04:01 AM
Your solution worked for me and my Ensonique card. However, now sound doesnt work at all. I can hear sound during detection, but nothing for any of the individual events. When I click on the sound icon and move the slider to a higher volume, the slider gradually and visibly clicks itś way back to the minimum level. Damned thing I ever saw. FC2 is haunted I fear!

mip
21st May 2004, 09:29 AM
Now I'm back to having the sound problems I had with FC1.

When I finish playing an audio file I get all the queued up sound events which occured while the audio file was playing. Very annoying indeed.

Igoraus
21st May 2004, 10:02 AM
Originally posted by gunnyman
do you have an audigy?
If so,
open kmix
click advanced
I bet Audigy Analog is turned on.
Turn it off
this is common with alsa and SB audigy cards.

but where is configur file to make this manualy, am using gnome not kde.

tnx

mip
21st May 2004, 10:12 AM
You should still be able to run kmix.

Igoraus
21st May 2004, 10:19 AM
yes I run kmix and solve the problem, but am Angry to myself, becose I'l never think to solve the problem in that wey.
:mad:

mip
21st May 2004, 11:51 AM
Its not really a solution though is it?

Does anyone know if there is a bugzilla entry for this problem?

gunnyman
21st May 2004, 12:10 PM
not sure what they did to fix it, but the problem is fixed (for me anyhow) in Mandrake 10 final. Perhaps check the Mandrake 10 Community bugzilla?

gunnyman
21st May 2004, 12:12 PM
Xmmx,
this is a longshot, but do your problems occur when logged in as root?
If so, go to user account settings and add yourself to the audio group.

gunnyman
21st May 2004, 12:13 PM
Originally posted by Igoraus
yes I run kmix and solve the problem, but am Angry to myself, becose I'l never think to solve the problem in that wey.
:mad:

don't worry,
I found it quite by accident.

mip
21st May 2004, 12:24 PM
Originally posted by gunnyman
not sure what they did to fix it, but the problem is fixed (for me anyhow) in Mandrake 10 final. Perhaps check the Mandrake 10 Community bugzilla?

So what exactly is causing the problem?

deuch
22nd May 2004, 10:50 AM
I've got a similar problem ...

In fact, an "half" problem ...

I've got sound but only with my right speaker !!!
No sound on the left speakers ...

I've a hissing sounf when volume is too high (around 80 % ...)

My laptop is an IBM A21e with i810 AC 97 audio ...

I replace my ALSA configuration in modprobe.conf with FC1 modules.conf ... but i still the same ...

With FC1 + ALSA, no problem, sound is great ...

Strange isnt'it !!!

thx!

deuch

gunnyman
22nd May 2004, 03:05 PM
I am guessing here,
I think the Audigy DSP has the output that causes the hissing turned on by default. It is the Digital output (I think) that causes this. The Alsa Module doesn't turn it off or ask if it should like the Windows driver does.

lovswr
23rd May 2004, 03:49 AM
Originally posted by gunnyman
do you have an audigy?
If so,
open kmix
click advanced
I bet Audigy Analog is turned on.
Turn it off
this is common with alsa and SB audigy cards.

Thank you very much. I had the exact same problem.

deuch
23rd May 2004, 08:37 AM
i've the hissing sound, but no audigy in my Laptop ... ARGGHHH :-)

deuch

CooLMaN
24th May 2004, 01:40 PM
Hey,
I've got the same Hissing sound comming only for the left speaker .

Is there a solution ?
I can't hear any music at all, This really pisses me off.

Thanks a head for the helpers,
Gil.

ilja
24th May 2004, 01:43 PM
I got the same problem. My solution was to start alsamixer and mute all things till the odd sound disapeared. The problem for me was sth called IEC958. When I muted it, I never got this sound again.

deuch
24th May 2004, 03:53 PM
Great :-)

Nom it works ....

I played with the Gnome Mixer ... I only change the volume of the PCM channel of the "OSS card" ... if i change the PCM volume of the "Alsa Card", the sound diseaper ... i've to close the mixer and make again my change with the OSS card ...

Also i changes my conf in the modprobe.conf. I took it on the alsa site :

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Il leave lines with post-install and/or remove (the 2 opriginals) and it works ... Lucky maybe ????

deuch

Tijara Travel Photos - Chamchamal - Safety Harbor Instagram Photos