PDA

View Full Version : No sound on Fedora : Imac PPC


juanalan
8th March 2009, 07:44 PM
Good evening,
I have a problem with the sound of my computer.
I have got a imac G4 PPC (the sunflower !) and try Fedora 10. I upgrade my kernel element but I don't hear anything more, even though the pulseaudio or alsa volume meter/alsamixer are ok and show a variation.

I don't know how to solve this problem. thanks a lot for your help.

My configuration is :
$ uname -r
2.6.29-0.53.rc7.fc10.ppc

$ lspci
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
0000:00:10.0 VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200] (rev a1)
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 PCI
0001:10:17.0 Class ff00: Apple Computer Inc. KeyLargo/Intrepid Mac I/O
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:1a.0 USB Controller: Apple Computer Inc. KeyLargo/Intrepid USB
0001:10:1b.0 USB Controller: NEC Corporation USB (rev 43)
0001:10:1b.1 USB Controller: NEC Corporation USB (rev 43)
0001:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 Internal PCI
0002:20:0d.0 Class ff00: Apple Computer Inc. UniNorth/Intrepid ATA/100
0002:20:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

# ll /dev/snd/
total 0
crw-rw----+ 1 root root 116, 3 mars 8 15:55 seq
crw-rw----+ 1 root root 116, 2 mars 8 15:55 timer

# lsmod
Module Size Used by
vfat 14392 1
fat 54024 1 vfat
fuse 60696 2
ipt_MASQUERADE 6168 1
iptable_nat 8812 1
nf_nat 19938 2 ipt_MASQUERADE,iptable_nat
bridge 54632 0
stp 5800 1 bridge
bnep 16876 2
sco 13888 2
l2cap 23924 3 bnep
bluetooth 57244 5 bnep,sco,l2cap
sunrpc 182196 1
ip6t_REJECT 7676 2
nf_conntrack_ipv6 17076 2
ip6table_filter 5824 1
ip6_tables 16392 1 ip6table_filter
ipv6 284812 24 ip6t_REJECT,nf_conntrack_ipv6
dm_multipath 19448 0
uinput 11684 0
arc4 5080 2
ecb 6364 2
firewire_ohci 27592 0
firewire_core 46156 1 firewire_ohci
sungem 32896 0
rt73usb 28352 0
rt2x00usb 13448 1 rt73usb
sungem_phy 14604 1 sungem
crc_itu_t 5152 2 firewire_core,rt73usb
rt2x00lib 43972 2 rt73usb,rt2x00usb
usb_storage 94492 1
rfkill 13796 2 rt2x00lib
mac80211 197092 2 rt2x00usb,rt2x00lib
cfg80211 42376 2 rt2x00lib,mac80211
snd_aoa_i2sbus 22648 0
snd_seq_dummy 6236 0
snd_seq_oss 40092 0
snd_seq_midi_event 9540 1 snd_seq_oss
snd_seq 63508 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 10484 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 52264 0
snd_mixer_oss 20008 1 snd_pcm_oss
snd_pcm 79832 2 snd_aoa_i2sbus,snd_pcm_oss
snd_timer 24964 2 snd_seq,snd_pcm
snd_page_alloc 12020 1 snd_pcm
ide_cd_mod 33884 0
pmac_zilog 20776 0
snd 64560 9 snd_aoa_i2sbus,snd_seq_dummy,snd_seq_oss,snd_seq,s nd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,sn d_timer
soundcore 9136 1 snd
snd_aoa_soundbus 8364 1 snd_aoa_i2sbus
ide_gd_mod 26372 3

juanalan

juanalan
9th March 2009, 09:10 AM
I try with my headphones, pulseaudio move but no sounds !

Thanks

Wayne
9th March 2009, 09:16 AM
Moved to Mac & PPC...

juanalan
9th March 2009, 01:04 PM
Hi,

I work in gnome desktop essentially, but i may work in KDE too.
I have the both environnment.

I've tried some tools and I have always the same results:
- Totem, rhythmbox, Gnome Mplayer, Amarok, VLC
- I've no sound at all : system, music and video
- I've no difference of behaviour between gnome and kde.

Thanks for your help

juanalan

Captain Fazekas
11th March 2009, 10:58 PM
sorry bud, i've moved on to Ubuntu... but i got my audio to work after i updated.

juanalan
11th March 2009, 11:11 PM
Good evening,

It's an idea but I don't think so for the moment. I'll try Fedora (I'm pretty obstinate :)).
Did you have something special to do on with your speakers on Ubuntu ?

Thanks for the response

juanalan

Captain Fazekas
11th March 2009, 11:14 PM
No, worked "out of the box".

juanalan
11th March 2009, 11:20 PM
I assumed so with my mac, but it's more complicated than I imagined.
There's no recognition of my speakers nor headphones.

Very curious !

juanalan

carlfriend1
13th March 2009, 03:21 PM
You need powermac snapper. I had the same problem when I tried Fedora 10. The easiest way for me was just to get an older version of Fedora, install and upgrade to ten. I know it is not the way they recommend but I must have sound.

I've tried Ubuntu, Kubuntu, Opensuse and tried installing Debian Lenny but had no luck with it. I've found that Fedora works best for me on my 12 inch G4 powerbook with 764 mb of ram. It is the only computer I have.

There are things that I wish Fedora did better with 10. I get the loading/lib/kdb/keymaps/i386/qwerty/us.maps often when I reboot my system. It is a pain in the neck rebooting over and over till I get past that. I wish that Fedora 10 for PPC would install with powermac snapper like the other versions did. If something works why break it is how I feel. I tried testing the alpha for 11 but it would not install. Regardless of that problem Fedora beats the other distributions for me.

So the lesson I learned yesterday was stick with what you know, which in my case was Fedora. I mean wireless works for me, flash using gnash, streaming tv sites, ibm java for java games since other does not. Totem I love that youtube plugin where you can watch youtube videos from it. I wish KDE had a plugin like that for a movie player. But till it does Totem is my movie player though I use KDe 4 desktop.

juanalan
14th March 2009, 12:05 AM
Good evening,

You're right : after doing :
modprobe snd_powemac , the driver was loaded and then I have sound with "powermac snapper".
Nevertheless :
- i've had a warning :
'modprobe warning : /etc/modprobe.d/sound line 1 ignoring bad line starting with snd-aoa'

- after 2 minutes when I switch the volume, I lost the signal.
- After reboot, I must do it again in order to have sound. There was no autoload.

If you have new brilliant ideas, I'm interested in !!

Thanks for lot

juanalan

juanalan
16th March 2009, 09:37 AM
Good morning,

up !!

carlfriend1
16th March 2009, 07:21 PM
The way sound stayed all the time for me was by installing an older version of Fedora and after that updating 10. I don't know why powermac snapper is not there by default like it was before.

juanalan
16th March 2009, 09:32 PM
Good evening,

I had the same problem under Fedora 9, that's why I've upgraded to Fedora 10.
But, there's probably a little tips to do, but I don't know what.

juanalan

oswaldkelso
17th March 2009, 01:11 AM
Good evening,

I had the same problem under Fedora 9, that's why I've upgraded to Fedora 10.
But, there's probably a little tips to do, but I don't know what.

juanalan

Hi I run Debian but this may work? run run as root

alsactl store

this is meant to store sound setting maybe it's the same in Fedora?

carlfriend1
17th March 2009, 03:40 AM
Good evening,

I had the same problem under Fedora 9, that's why I've upgraded to Fedora 10.
But, there's probably a little tips to do, but I don't know what.

juanalan

I installed Fedora 7 first put in Fedora 10 chose upgrade and had my sound. Never tried 8 or 9. Since pc people need it not sure why they the distributors take it out.


Pulseaudio should be called pulseaudio hell from the threads I have read on other distributions besides this one.

juanalan
17th March 2009, 02:30 PM
Good afternoon,

Well we could call pulseaudio like this, but it may be very useful when it works. :p

Hi oswaldkelso, I'll try this evening and I'll tell you.

thanks

juanalan

carlfriend1
17th March 2009, 10:07 PM
Good afternoon,

Well we could call pulseaudio like this, but it may be very useful when it works. :p

Hi oswaldkelso, I'll try this evening and I'll tell you.

thanks

juanalan

Yeah when it works. Just my opinion but it seems every distribution rushed so fast with pulseaudio.

If oswaldkelso suggestion works put fixed in the title. Will have to try it also if it does.

juanalan
18th March 2009, 12:08 AM
Good evening

I'll try and we'll see.

juanalan

juanalan
19th March 2009, 11:50 AM
Good morning,

I'm always here.
Because of all my difficulties, I decided to remove alsa and pulseaudio in order to reinstall cleanly. So I did before going to office.
And after a very long time, it reboots and :
- a recurrent message :
Loading lib/keymap/i386/azerty/fr-latin9.map .
I must wait for a while
- A bottomright kernel error window which sends a mail to X
- and after all, I had a different login window on a white/grey background (and not the usual blue sun), very ugly with a unknown logo as an X ou K (I don't how to describe this). Problem : None of my login and pwd works !! even as root.
So nice, isn't it ?
I'll try again this evening and, pray..

juanalan

tiresia
19th March 2009, 01:02 PM
Ok, I know, it can sound just stupid, what I'm going to say, but it was my experience installing Fedora 10 on a PowerMac G5. The sound was not working - and I thought, damn, it's again the same problem as in Fedora 9. Then I tried to load the snd_powermac module. Still nothing. After reinstalling (for other reasons!) I discovered that I had just to adjust the Volume Control in Gnome - by default it was muted.
Therefore check it, if you haven't done it yet.
This just to say, that pulse audio worked on that machine.
After that I would try loading that module 'modprobe snd_powermac'

juanalan
19th March 2009, 03:33 PM
Good afternoon,

Well I had sound for 2 minutes and after reboot nothing. So I know that sound is possible.
Did you do something special in order to have sound automatically after reboot ? I mean after the modprobe.

Thanks for your answer,

juanalan

tiresia
19th March 2009, 05:11 PM
If loading the snd_powermac module is working for you, than you should tell to the kernel to load it at startup. In Debian you do it adding the name of the module to the file /etc/modules (as root).
I do believe, that you can do the same in Fedora, but I'm not sure and I can't check it right now.
Do you have that file /etc/modules? If yes, do it.

juanalan
19th March 2009, 10:30 PM
Damned,

bad luck today, I can't reboot.
This special window refuses all login and password I give. Or as user, it seems to load and then shows me the same window.

With ctrl+alt+F2, terminal mode, I can log but I don't know how to start on my desktop.

I try to reinstall alsa, but the response is "no more mirror to try" so I can't download and install it. I assumed that the reason is 'no web' !!

If you have a brilliant idea, please help me !!! :eek:

tiresia
19th March 2009, 11:43 PM
Strange... At the first 'login window', that it says that the name or the password are incorrect, or what?
Did you change anything in your configuration?

juanalan
20th March 2009, 12:15 AM
Nothing. I just uninstall pulseaudio and alsa.

juanalan

juanalan
25th March 2009, 09:59 PM
After this choice, what a disaster !!

I couldn't boot, or more precisely I had the weird window. So I've reinstalled F10 on my mac with KDE desktop.
I have the same problem of sound but I can boot...
Back to departure !

juanalan

Dareda Photos - Ojiya - Shilin Travel Photos