PDA

View Full Version : Install FlightGear Launch Control -> PLIB version


42istheanswer
4th December 2008, 09:04 PM
Hi all,

I try to install the FlightGear Launch Control 1.0.1 on FC10 since I can't find it installed with the FlightGear package.
When executing ./configure I always get the error message that PLIB > 1.8.0 needs to be installed. But I have PLIB 1.8.5 installed, so what could be the problem and can I solve it?


checking for PLIB include path...
checking for PLIB LDFLAGS...
checking for PLIB - version >= 1.8.0... not present.
configure: error: Sufficiently new version of plib not found.

phkahler
4th January 2009, 01:33 AM
I can't answer your question, but I have one of my own. Where do you unpack the scenery files for flightgear on Fedora 10? How do you display the variable that contains the path?

Thanks,
Paul

Lindy
4th January 2009, 01:44 PM
Hi all,

I try to install the FlightGear Launch Control 1.0.1 on FC10 since I can't find it installed with the FlightGear package.
When executing ./configure I always get the error message that PLIB > 1.8.0 needs to be installed. But I have PLIB 1.8.5 installed, so what could be the problem and can I solve it?


checking for PLIB include path...
checking for PLIB LDFLAGS...
checking for PLIB - version >= 1.8.0... not present.
configure: error: Sufficiently new version of plib not found.


It can be done but... It's a true PITA, talk about depenency hell, even the deps have deps! In all reality it's not worth the time. There is an easier way to start FlightGear with different aircraft and such. Put some aliases in your .bashrc and run FlightGear from the CLI. Here's an example from my .bashrc :
#for Flight Gear
alias fg="fgfs"
alias fglst="fgfs --show-aircraft"
alias fgufo="fgfs --aircraft=ufo"

True it's not as pretty as a nice GUI, but it will save you scads of time, and untold amounts of money you'd save on asprin:p
There are more options available ==>$fgfs --help will give you a list. BTW, Welcome aboard!

@phkahler... Scenery files go in /usr/share/FlightGear/Scenery

livibetter
4th January 2009, 02:09 PM
Hi all,

I try to install the FlightGear Launch Control 1.0.1 on FC10 since I can't find it installed with the FlightGear package.
When executing ./configure I always get the error message that PLIB > 1.8.0 needs to be installed. But I have PLIB 1.8.5 installed, so what could be the problem and can I solve it?


checking for PLIB include path...
checking for PLIB LDFLAGS...
checking for PLIB - version >= 1.8.0... not present.
configure: error: Sufficiently new version of plib not found.


You also need plib-devel package.

Nova Iguacu Travel Photos - Syria - Santa Cruz de la Sierra Photos -