PDA

View Full Version : Fedora 10 + noob + Installing ATI Drivers = Help


wtc321
28th November 2008, 10:39 PM
HI there guys,

Installed F10 just the other day, never really used Linux other than Ubuntu a while back for a short period of time and I need a bit of help here.

Due to my lack of patience I went on about 10 different forums trying to get different code on how to install my driver and get Compiz Fusion working etc but it never really worked out.

So I will try and get it done correctly this time. According to Apple's site (I have an iMac) my Graphics Card is:

ATI Radeon HD 2400 XT graphics processor with 128MB of GDDR3 memory

Now is there any chance someone could give me a hand in getting this installed so that I can finally 'Enable Desktop Effects' without just having my screen going white for 5 mins.

Let me know if any other information is needed.

And also I have 'CompizConfig Settings Manager' and 'Emerald Theme Manager' installed.

Thanks for your help in advance.

-- wtc321

mck182
28th November 2008, 10:53 PM
HI there guys,

Installed F10 just the other day, never really used Linux other than Ubuntu a while back for a short period of time and I need a bit of help here.

Due to my lack of patience I went on about 10 different forums trying to get different code on how to install my driver and get Compiz Fusion working etc but it never really worked out.

So I will try and get it done correctly this time. According to Apple's site (I have an iMac) my Graphics Card is:

ATI Radeon HD 2400 XT graphics processor with 128MB of GDDR3 memory

Now is there any chance someone could give me a hand in getting this installed so that I can finally 'Enable Desktop Effects' without just having my screen going white for 5 mins.

Let me know if any other information is needed.

And also I have 'CompizConfig Settings Manager' and 'Emerald Theme Manager' installed.

Thanks for your help in advance.

-- wtc321

Try this howto: http://forums.fedoraforum.org/showthread.php?t=155503 it worked for me with HD3200 and some others too...

Good luck 8)

wtc321
28th November 2008, 11:52 PM
Thanks for the link :) Will let you know if it works!

-- wtc321

wtc321
29th November 2008, 12:14 AM
Ok well I have followed that guide step by step up to the one from last which I really dont know what to do:

". Edit grub.conf

Code:

su
gedit /etc/boot/grub.conf

and add this "nopat" to the kernel arguments.


Optional (in case libdrm change breaks things due to relationship with KMS):
add "nomodeset" to end of kernel arguments"


What on earth am I supposed to do here...?

leigh123linux
29th November 2008, 12:22 AM
Try

su
gedit /boot/grub/grub.conf

wtc321
29th November 2008, 12:28 AM
Yer the window opens with gurb.conf with no text on it, but what am I supposed to do with it? Sorry if Im being a bit nabby here but not too sure what to type in it if thats what Im meant to do.

mck182
29th November 2008, 12:52 AM
Yer the window opens with gurb.conf with no text on it, but what am I supposed to do with it? Sorry if Im being a bit nabby here but not too sure what to type in it if thats what Im meant to do.

You should see something like this in grub.conf:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,4)
# kernel /boot/vmlinuz-version ro root=/dev/sda5
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=0
chaintimeout=5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.x86_64)
root (hd0,4)
kernel /boot/vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=UUID=a5ced134-5346-44b8-b794-a8dc03b856ce vga=0x323 rhgb quiet init=/sbin/bootchartd
initrd /boot/initrd-2.6.27.5-117.fc10.x86_64.img


This one's mine and that kernel parametr you're supposed to add to the end of line that starts with kernel, so in my case you would edit the line so it looks like (don't mind all the ":vga=0x323 rhgb quiet init=/sbin/bootchartd", that's my config and you can have some other, just add it to the end of the line)

kernel /boot/vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=UUID=a5ced134-5346-44b8-794-8dc03b856ce vga=0x323 rhgb quiet init=/sbin/bootchartd nopat

zecchinhg
29th November 2008, 01:13 AM
Why don't you just read leigh's fine tutorial? http://forums.fedoraforum.org/showthread.php?t=155503&page=1&pp=10

mck182
29th November 2008, 10:25 AM
Why don't you just read leigh's fine tutorial? http://forums.fedoraforum.org/showthread.php?t=155503&page=1&pp=10

Are you blind? He did, but got stucked...

Jeff72
29th November 2008, 11:14 PM
Yer the window opens with gurb.conf with no text on it, but what am I supposed to do with it? Sorry if Im being a bit nabby here but not too sure what to type in it if thats what Im meant to do.

You must have mistyped the file name.

The "su" part is to become root so you can modify the /boot/grub/grub.conf file.
su

After you "su" to root, copy and paste this line and run it:
gedit /boot/grub/grub.conf

Be very careful what you change in that file. That file controls some of your system's boot process options.

Jeff

Penguin_Frog
7th December 2008, 07:00 PM
I have a similar Graphics card(Same GPU)!
I have had all of the problems you have had - the white screens...
I shall try everything here, and post back if it works.

Penguin_Frog
8th December 2008, 05:11 AM
I have a similar Graphics card(Same GPU)!
I have had all of the problems you have had - the white screens...
I shall try everything here, and post back if it works.

I followed Leigh's tutorial exactly, and it ended up killing Fedora!
So I'm now waiting until I get my External HD to reinstall Fedora - I'm missing it already :(
All I needed to do was run ATI Config(which I did), but after adding Leigh's lines exactly, the kernel ker-ploped.:(

Pustaka Negeri Sarawak Travel Photos - Saung Angklung Mang Udjo. Bandung. Photos on Instagram