PDA

View Full Version : i can not see the other partitions


yaman
11th August 2004, 10:30 PM
My computer has several partition.
C --> ntfs
D --> fat32
and linux

I can not see the other partitions (ntfs und fat32) in linux.

what must i do to see the ntfs and fat32? :confused:

mtritab
11th August 2004, 10:42 PM
Check to see if they are mounted, use the disk management utility. If they aren't then you need to mount them.

However, I don't know if linux is compatible/can write to NTFS. I'm a noob but I've heard conflicting things about NTFS file systems and linux.

Mike

Mat
11th August 2004, 10:43 PM
you have to mount those partitions, have a look at
1. man mount
2. man fstab
3. http://www.fedoraforum.org/forum/showthread.php?t=18303

;)

Mat

yaman
11th August 2004, 11:31 PM
i think, my other partition is not in the linux :(
i opened the "disc management" and seen these informations :
DEVICE DIRECTORY FILESYSTEM
/dev/fd0 /mnt/floppy auto
/dev/cdrom /mnt/cdrom udf,iso9660
none /sys sysfs
none /proc proc
none /dev/shm tmpfs
none /dev/pts devpts

yaman
11th August 2004, 11:49 PM
thanks @Mat and @mtritab

fat32 partition is OK. :)

Mat
12th August 2004, 06:19 AM
disc management shows only those devices that are written in /etc/fstab..

but I guess, you've already figured that out :)

BloodyBullet
12th August 2004, 08:04 PM
My computer has several partition.
C --> ntfs
D --> fat32
and linux

I can not see the other partitions (ntfs und fat32) in linux.

what must i do to see the ntfs and fat32? :confused:
Under Linux you are not able to create or delete a folder on NTFS filesystems.
This will change in future.

Mat
12th August 2004, 09:09 PM
you could try to use captive

rmenezes
12th August 2004, 09:45 PM
In the fedoranews.org you can find a answer to use NTFS in your Fedora:

http://fedoranews.org/contributors/vitor_domingos/ntfs/

In this site also it shows as to optimize fedora 2 for its CPU.
To compile kernel is the best way for resolv the problem, but I find more easy to use something a little simpler like captive:

http://www.jankratochvil.net/project/captive/

I only found a problem with captive in the hour to move archives bigger than 700 mb. I tried to move and simply I lost the archive a time, and in the other I lost windows (that it was not great thing). In my opinion, captive does not serve to move very great archives.

PsyGhost
16th August 2004, 07:36 PM
First you have to mount these partitions, if you want to do it automaticlly add them to /etc/ fstab.
Linux can read/write to FAT32 Partitions with 99% success rate.
Redhat decided (because of legal reasons I guess) to remove the NTFS support from the distribution.
So there are 2 solutions.
The first one is to compile a new kernel and configure it to support NTFS, the second is to use and RPM from here:

http://linux-ntfs.sourceforge.net/rpm/downloads.html

Take note that NTFS partition can be read with no problems, however the writing support for NTFS is EXPEREMENTAL and may destroy the ENTRIE FILESYSTEM.
So I suggest you disable the NTFS write support if you compile a new kernel, or if you use the RPMS just mount the NTFS partition in read only mode. If you want to transfer files between the two OS you can use the fat32 partition.

Instagram Europe | America Instagram Photos | Asia Travel Photos on Instagram