PDA

View Full Version : ati 3.11.1 drivers on core 3?


skeetre
8th August 2004, 03:19 PM
I've tried using the HOWTOs from core 2 to get the new ati drivers working on core 3, but no luck. I got further using the 3.9 drivers than the 3.11, but still couldn't get the fglrx.ko module to compile.

Thanks for any help/suggestions in advance.

micha
8th August 2004, 04:10 PM
Can you post the error message of the fglrx module compilation ? I don't have FC3 but I'll try to help you. You could also have a look at the linux forum at http://rage3d.com, you'll find interesting information and competent people.

malcidragon
20th October 2004, 08:55 PM
The first problem is that you need to get the kernel source installed,
this is now only in the SRPMS, put drm.h, drm_proc.h etc. that are missing from the kernel source into /lib/modules/fglrx/build_mod/2.6.x/ directory.
fglrx 4.3.0-3.14.1 builds fine, however I can't seem to get it working, as when
the glx stuff is attempted it crashes the X session. :confused:
You will need to modify the config file generated by fgrlxconfig as the keyboard
stuff is different. (and rename is xorg.conf)

Anyone else have this working on fc3?

micha
22nd October 2004, 11:01 AM
The current ATI driver cannot work on Fedora Core 3 since FC3 uses Xorg 6.8 and the ATI driver is not compatible with this version of Xorg.
I guess ATI is currently building a driver suitable for newer version of Xorg. So at this time, you have to stick with FC2 (or Xorg 6.7), and wait for a new ATI driver with official Xorg support.

malcidragon
24th October 2004, 05:09 PM
the fglrx drivers do work, however the dri does not.
If you install the fglrx 14 version, then disable dri then it works fine.
The issues are as suggested to do with the latest x.org and ATI hopefully will
have an updated driver soon.

Saltillo Instagram Photos - Delhi Travel Photos - Busan Travel Photos on Instagram -