PDA

View Full Version : How do I get rid of the ugly progress bar (of plymouth)?


yikeouch
27th October 2008, 10:08 AM
I installed the plymouth-plugin-solar and used "plymouth-set-default-plugin solar", but to no avail. Only ugly progress bar. I've checked link in /usr/lib64/plymouth,and it was correctly changed.
Did I miss something? What should I do ?
Please tell me.

SlowJet
27th October 2008, 10:24 AM
It is a work in progress.
Worry about something you can actually fix.

SJ

glennzo
27th October 2008, 10:31 AM
Why not just get rid of rhgb in the grub config ??

yikeouch
27th October 2008, 10:37 AM
It is a work in progress.
Worry about something you can actually fix.

SJ

Gee, I don't know it's not completed.
Can't I just ask?

SlowJet
27th October 2008, 10:47 AM
Sure you can ask.

http://fedoraproject.org/wiki/Communicate

SJ

scottro
27th October 2008, 11:36 AM
And you got the answer in post number #3. :)

Mentioned in the release notes by the way.

yikeouch
28th October 2008, 07:33 AM
I found out how to use the plymouth solar plugin in elsewhere and got rid of the progress bar only boot screen. So maybe it is not completed but USABLE.

It's a pity I can't receive the right answer here.

Demz
28th October 2008, 07:43 AM
I found out how to use the plymouth solar plugin in elsewhere and got rid of the progress bar only boot screen. So maybe it is not completed but USABLE.

It's a pity I can't receive the right answer here.

ever heard of a proper place to ask if your not getting the answer you want from here?.. fedora-test list would help .. i suggest you subscribe to it,, if you dont like the current boot bar,, by all means i can give you a free ticket to ubuntu

SlowJet
28th October 2008, 07:51 AM
http://koji.fedoraproject.org/koji/packageinfo?packageID=6267

It's a pity he didn't share how to do it with us.

Take two updates and call me next week. :)

SJ

yikeouch
28th October 2008, 08:19 AM
Maybe my word offend someone and I don't know. I apology here. But I asked politely and only get sarcasm. It made me a little upset.
Ok, here is the tip:

after installed plymouth-plugin-solar through yum, do:

# plymouth-set-default-plugin solar

If you don't see the solar plugin next boot up, try edit /etc/grub.conf
add vga=0x318 in the line of kernel settings.

Next boot up you'll see the solar plugin.

Demz
28th October 2008, 08:20 AM
some people never do share how they fixed it,

glennzo
28th October 2008, 08:58 AM
It's a pity I can't receive the right answer here.I take offense to that bold statement. You got several answers. All for free, on our own time, and none of which were required of any of us. Mine was correct. Get rid of the thing and be done with it.

Wayne
28th October 2008, 10:59 AM
OK folks, time to take a deep breath, have a glass/cup of your favourite beverage and calm down.

To the OP. I'm sorry you couldn't get the answer here, but this is just a user forum. The devs rarely drop in and don't really monitor this forum. As someone suggested, it would have been better to ask on the developer mailing list.

Anyway, I'm glad you got the answer. If you want to share, then please PM me or one of the other CMs and this thread will be reopened.

Wayne

glennzo
28th October 2008, 01:56 PM
YikeOuch, some of us acted a bit hastily with our responses. Some of the replies could be considered rude while others were an honest attempt to offer possible solutions to your issue. My answer, getting rid of the graphical boot all together, while not the solution, was a valid option. I'm one of those who has no use for the graphical boot. I'd rather see all the data scrolling in front of me while the system boots. Sometimes you see some interesting stuff. Regardless, I don't think that Wayne will have any issues with me re-opening this thread so you and others can post here again. Let's see if we can get a proper solution to the issue or come to the conclusion that there may not be a solution at this juncture.

TheIcebreaker
28th October 2008, 03:02 PM
Ok well we know that using vesa mode will work if we dont have KMS like nvidia and intel users.
0x318 is for 1024x768 resolution has anybody got it working for a widescreen resolution like 1440x900. what are the vesa codes for widescreen resolutions.

yikeouch
28th October 2008, 03:06 PM
I apology for the rude words I said.
I was in bad mood today and maybe reacted harshly.
I've post the solution up there if you noticed.
And I hope we could be more friendly next time.

scotty38
28th October 2008, 08:44 PM
Don't be put off - there is no better place to be for your Fedora answers!

scottro
28th October 2008, 09:56 PM
Firstly, thank you for coming back and reporting your solution. Many people (even if there isn't any bad feeling that happened) just don't bother--the fact that you found this solution and posted it will definitely help others, especially since I suspect Plymouth questions will become more frequent as F10 is released.

Secondly, I'll join with Glenn in the apology. Like him, and perhaps most of us, we see things from our point of view and see the question, how can I get rid of the progress bar to mean, how can I get to a screen that is giving me all the bootup information.

Actually, and I suspect it's the same with Glenn, when it first came out, and I ran into the issue, I looked no further than just getting back to my normal boot screen (with all the information scrolling). So for us, that's a solution. :)

Anyway, glad you came back, and again, thanks for, especially considering the circumstances, posting the solution for others.

TheIcebreaker
28th October 2008, 10:18 PM
Now that we are all done with the apologies and kiss and make ups I have a related question.

I am on a G33 and it doesnt have KMS yet. I also have a widescreen monitor.
Now the vga switch works and the I can see the solar and whatever plugin I set but after that the system hangs. It doesnt load the gdm and I have to hard reset.

I suspect the problem is running a 4:3 resolution by vga=0x318. It sets the resolution at 1024x768.
What are the codes to get widescreen resolutions. Native resolution is 1440x900.

yikeouch
29th October 2008, 05:39 PM
To Theicebreaker,
try vga=791 or vga=792
it's for intel.

TheIcebreaker
29th October 2008, 06:49 PM
will these give widescreen resolutions

TheIcebreaker
29th October 2008, 08:30 PM
Tried with vga=792 still hangs after the plymouth plugin exits.
Problem persists.

ryptyde
29th October 2008, 08:46 PM
Tried with vga=792 still hangs after the plymouth plugin exits.
Problem persists.

I used "vga=0x315" for my Acer Aspire One it has a screen size of 1024x600. :)

TheIcebreaker
29th October 2008, 08:49 PM
315 is for 800x600 resolution.

yikeouch
30th October 2008, 02:45 AM
will these give widescreen resolutions

I don't know, I'm not using intel chips.

ryptyde
30th October 2008, 05:15 PM
315 is for 800x600 resolution.

Know that and it works better than no boot option. :)

Here's a list of values for common resolutions, haven't found any for the widescreens. ;)

Colours 640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
--------+--------------------------------------------------------------
4 bits | ? ? 0x302 ? ? ? ?
8 bits | 0x300 0x301 0x303 0x305 0x161 0x307 0x31C
15 bits | ? 0x310 0x313 0x316 0x162 0x319 0x31D
16 bits | ? 0x311 0x314 0x317 0x163 0x31A 0x31E
24 bits | ? 0x312 0x315 0x318 ? 0x31B 0x31F
32 bits | ? ? ? ? 0x164 ?


VGA Resolution and Color Depth reference Chart:
Depth 800600 1024768 1152864 12801024 16001200
8 bit vga=771 vga=773 vga=353 vga=775 vga=796
16 bit vga=788 vga=791 vga=355 vga=794 vga=798
24 bit vga=789 vga=792 vga=795 vga=799

Demz
31st October 2008, 12:37 AM
here's a story on KMS http://www.phoronix.com/scan.php?page=news_item&px=NjgyNA .. me thinks Redhat/fedora are using unstable KMS in the 2.6.27 kernels

ryptyde
31st October 2008, 02:43 AM
here's a story on KMS http://www.phoronix.com/scan.php?page=news_item&px=NjgyNA .. me thinks Redhat/fedora are using unstable KMS in the 2.6.27 kernels

Very interesting read. I have F10 snap2 with latest updates running on a Acer Aspire One also have installed the Plymouth plugins and ran the plugin scripts to see how they looked at boot. So far the "fade in" plugin appeals to my liking. :)

Demz
31st October 2008, 03:20 AM
it is interesting.. though hopefully it'll get a bit better with the KMS Patches etc in the 2.6.28 kernel till they do make it stable in the .29 kernel .. its just up to Nvidia to come to the party now to support KMS .. i really dont wanna buy another Videocard

ryptyde
31st October 2008, 05:27 PM
Trying to stay on topic and also say that I have found more info on how they work.

I tried some of the other plugins and have a new favorite now "solar" :)
You will get a list of installed plugins when you open a terminal and enter:

code
$ ls /usr/lib/plymouth/
default.so fade-in.so pulser.so spinfinity.so
details.so label.so solar.so text.so

Then for example choose the solar plugin and open a terminal as root (su) and enter:

code
# plymouth-set-default-plugin solar

then as root again to update initrd:

code
# /usr/libexec/plymouth/plymouth-update-initrd

reboot and see if the changes took effect. :)

sideways
31st October 2008, 05:35 PM
use vga=ask to get a list of supported vesa modes, including widescreen ones

TheIcebreaker
1st November 2008, 02:02 PM
I also figured that would work but It doesnt give any options for widescreen resolutions.
Do i have to get an updated or patched vesa fb driver.

sideways
1st November 2008, 02:21 PM
I also figured that would work but It doesnt give any options for widescreen resolutions.
Do i have to get an updated or patched vesa fb driver.

Probably not a supported mode then.
You can try vbetest, to make sure, run as root in a console window. it will list supported vesa modes. you need to add 512 to the mode number for the vga= parameter in grub.conf. eg On my 1280x800 laptop I get

[root@localhost ~]# vbetest
VBE Version 3.0
NVIDIA
[256] 640x400 (256 color palette)
[257] 640x480 (256 color palette)
[259] 800x600 (256 color palette)
[261] 1024x768 (256 color palette)
[270] 320x200 (5:6:5)
[271] 320x200 (8:8:8)
[273] 640x480 (5:6:5)
[274] 640x480 (8:8:8)
[276] 800x600 (5:6:5)
[277] 800x600 (8:8:8)
[279] 1024x768 (5:6:5)
[280] 1024x768 (8:8:8)
[304] 320x200 (256 color palette)
[305] 320x400 (256 color palette)
[306] 320x400 (5:6:5)
[307] 320x400 (8:8:8)
[308] 320x240 (256 color palette)
[309] 320x240 (5:6:5)
[310] 320x240 (8:8:8)
[317] 640x400 (5:6:5)
[318] 640x400 (8:8:8)
[352] 1280x800 (256 color palette)
[353] 1280x800 (8:8:8)
[354] 768x480 (256 color palette)
Type a mode number, or 'q' to quit -

mode 353 is 24bit widescreen so I set vga=865 (353+512). Not all widescreen modes are supported.

Trapper
1st November 2008, 04:26 PM
You can try vbetest, to make sure, run as root in a console window. it will list supported vesa modes. You need to add 512 to the mode number for the vga= parameter in grub.conf.

You may need to go through a few hoops to get vbetest working. Here's what I had to do:
(all as root)

yum install vbetest

Because of the way SELinux is acting for me I had to do this in a console window to get results:


chcon -t unconfined_execmem_exec_t '/usr/sbin/vbetest'

setsebool -P allow_unconfined_mmap_low 1

vbtest

TheIcebreaker
1st November 2008, 10:00 PM
Well I tried that and it does not list any of the widescreen modes.
The question now is can I do anything about it.

sideways
2nd November 2008, 05:30 PM
Well I tried that and it does not list any of the widescreen modes.
The question now is can I do anything about it.

Not easily. You could try another framebuffer driver, intelfb, nvidiafb, radeonfb etc. They're compiled as modules in fedora (not into the kernel itself), you can check with
grep FB_INTEL /boot/config-$(uname -r)

or grep for FB_NVIDIA, FB_RADEON etc. it'll probably say '=m', whereas CONFIG_FB_VESA=y, the m means module the y means compiled in.

In that case you'll need to recreate the initrd including the relevant framebuffer driver, seee 'man mkinitrd' specifically the --with option), then instead of 'vga=' you use something like 'video=intelfb:mode=1024x768-32@60'

It may not help with the widescreen modes, and in some cases may interfere with the Xorg Driver (nvidiafb is known to have some issues here)

Sapporo Photos - Shantou Photos - Haora Travel Photos -