PDA

View Full Version : nvagp vs agpgart nvidia 6106 drivers


th0ma7
30th July 2004, 02:05 AM
Hi everyone,

I've been searching for an answer since a few days wthout succes.

I'm trying to activate my AGP port in 4x mode on a CUV4x-D motherboard with a VIA Apollo Pro 133 chipset.

By default agpgart detects the AGP as a 2x but my board supports 4x. My motherboard support Side Band Adressing but not fast write. I have an MSI GeForce FX 5900. I made a few test with an option to my modprobe.conf file:
options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=0 NVref_EnableVia4x=1

Note: I'm currently using a kernel 2.6.8-rc2 with nvidia drivers 6106.

TEST 1)
Added Option "NvAGP" 0 in my xorg.conf file
Results:
::::::::::::::
/proc/driver/nvidia/agp/card
::::::::::::::
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge: PCI device 1106:0691
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/status
::::::::::::::
Status: Disabled

In this case we can see that NvAGP does detect my board having a 4x agp chipset but it disable the agp. Which is the result I expected.. and hoped for.
I get 20823 frames in 5.0 seconds = 4164.600 FPS with glxgears

TEST 2)
Option "NvAGP" "1" # This should enable nvagp

DMSEG
==============
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected VIA Apollo Pro 133 chipset
agpgart: Maximum main memory to use for agp memory: 1430M
agpgart: AGP aperture is 256M @ 0xe0000000
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-6106 Wed Jun
23 08:14:01 PDT 2004
NVRM: not using NVAGP, AGPGART is loaded!!
NVRM: not using NVAGP, AGPGART is loaded!!
NVRM: not using NVAGP, AGPGART is loaded!!
NVRM: not using NVAGP, AGPGART is loaded!!

::::::::::::::
/proc/driver/nvidia/agp/card
::::::::::::::
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge: PCI device 1106:0691
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/status
::::::::::::::
Status: Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this setup problem.

=====================================

What test 2 tells me is that since agpgart is built directly into the kernel I can't get nvagp working properly.

Questions:
1- Should I try to recompile my kernel with the option "CONFIG_AGP=m" instead of "CONFIG_AGP=y" ?
Doing so would (I think) make agpgart a loadable module and I then nvagp would be able to load properly.

2- Sould I try to use via-agp instead? If so, how? I know there is a "CONFIG_AGP_VIA=y" in my kernel config. Should I simply make everything has a module (and probably remove useless AGP stuff for me like ali, ati) and the do a "modprobe agp-via" manually and not be using nvagp?

3- Any ideas? :confused:


Thnks.. :)

- vin

th0ma7
31st July 2004, 01:46 AM
I've been able to make NvAGP working.

I've reconfigured my kernel with agpgart has a module:
Section Device Drivers -> Character devices -> /dev/agpgart (note: I've only kept via driver)

At the same time I made sure rivafb was deactivated (doing so removes the warning message while installing nvidia driver) and also remove dri which nvidia does not need.

Did "make && make modules_install && make install"
Changes the option in my xorg.conf file:
Option "NvAGP" "1"
Rebooted on the new kernel in run-lvl 4

Reinstalled nvidia driver
Modified my modprobe.conf:
alias char-major-195* nvidia
option nvidia NVreg_EnableAGPFW=0 NVreg_EnableAGPSB=1 NVreg_EnableVia4x=1

Changed to init 5
and took a look at my /proc/driver/nvidia/agp/* files:
::::::::::::::
/proc/driver/nvidia/agp/card
::::::::::::::
Fast Writes: Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1f000217:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge: PCI device 1106:0691
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1f000207:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/status
::::::::::::::
Status: Enabled
Driver: NVIDIA
AGP Rate: 2x
Fast Writes: Disabled
SBA: Enabled

Tried the famous MS workaround and rebooted... no success (has I tought so.) :eek:

I've also tried to, ini run-lvl 3:
rmmod nvidia
modprobe via-agp (which will load agpgart and sub-driver via-agp)
modprobe nvidia
startx
and still same result.

I really don't understand why I can see 4x for the host-bridge and card when agpgart is directly built into the kernel and conflicts with NvAGP but that I can't see 4x mode anywhere anymore?

please help!

BTW: Got the same frame rate with glxgears in AGP 2x with agpgart or NvAGP.

thnx.

th0ma7
10th August 2004, 03:17 AM
I finally got it working.. with the latest nvidia drivers which fixed the AGP issue. The problem really seemed to be with 6106 drivers but 6111 fix that.

I now can get AGP 4x working with both nvagp and agpgart.

To do so I recompiled a kernel (2.6.8-rc3-bk2) with agpgart builtin but via-agp has a module.
After rebooting on the new kernel I've reinstalled my nvidia drivers:
sh ./NVIDIA-Linux-x86-1.0-6111-pkg1.run -x ( it will extract the drivers)
cd NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/
edited "os-registry.c"
Modified theses lines:
static int NVreg_EnableVia4x = 1;
{ NULL, "ReqAGPRate", &NVreg_ReqAGPRate, 1 },
note: The first line will allow 4x agp rate on a via chipset and the second one will allow to ajust the agp rate to what ever I want.
make install (You must be in run-level 4 or less.. or not be having an X)

I then added theses lines to my modprobe.conf file:
alias agpgart via-agp
alias char-major-195* nvidia
options nvidia NVreg_EnableAGPSBA=1
options nvidia NVreg_EnableVia4x=1
options nvidia NVreg_ReqAGPRate=7

And I edited my /etc/X11/xorg.conf and switch between:
Option "NvAGP" "2" ### Force usage of agpgart
and
Option "NvAGP" "1" ### Force usage of nvagp

and rebooted...

note: I get a better FPS with agpgart... but there is not much differences.

- vin

cscheng
27th January 2005, 07:36 AM
Can you tell me the exact steps you tried to use either NvAGP or agpart? I still haven't got the 6629 driver working, but I believe this is close to the solution.

Berkhamsted - Loa Janan Photos - Abancay