PDA

View Full Version : FC1 + Windows not booting + weird partition


cipherxy
20th July 2004, 09:48 AM
Hi Everyone,

I'm having trouble booting into Windows and I know little about Linux. Please bear with me and explain to me (step by step) what I need to do to get my Windows back!!!

Here is my case:

I've just installed Fedora Core 1 on my PC, Linux boots up fine, but now I can't boot into Windows XP.

I have an unusual partition where both my Windows and Linux are installed on extended partitions. Here is a table of my partitions obtained when Linux installation wizard is examining my partitions:


......Hard.Drives....................Type......... ......Size.........Start........End
================================================== =
...>/dev/hda
...........Free..........................Free.Spac e.......8...............1............1.
............>/dev/hd1................Extended......15155..........2. ........1933
..................../dev/hda5..........ntfs...............9154..........2.. .......1168
..................../dev/hda6..........ext3..............6001.......1695... ...1933
............../dev/hda2.................ntfs.............16002....... 1934......3973
............../dev/hda3.................vfat...............7005...... .3974......4866


I have 4 partitions, 2 on primary and 2 on extended.
- hda2 and hda3 are my logical drives (on primary)
- hd5 is my Windows XP (on extended)
- hd6 is my Linux (Fedora Core 1) (on extended)

************************************************** *******

I searched online and was able to find the commands to pull out the GRUB.conf file, here is the code to boot Windows (red = added by me since some postings sugguested doing so, had to learn vi to modify the file, that was some experience!)
________________________
title=DOS
map (hd0,0) (hd0,4)
map (hd0,4) (hd0,0)
rootonverify(hd0,4)
chainloader +1
_________________________

When I try booting into to Windows, the code stops at charinloader +1 and nothing happends after that, just the curser blinking.... is that the way it suppose to be? I sure did't see windows booting up though!

Then I tried
__________________________
title=DOS
map (hd0,0) (hd0,4)
map (hd0,4) (hd0,0)
rootonverify(hd0,4)
makeactive
chainloader +1
_________________________

I get: [Error 12: Invalid device requested]
[ press any key to continue]
and press any key takes me back to Grub boot loader.


I hope I have enough information here for you to get a place to start.

Anyone of you know what the problem is? and how I can go about fixing it?

I was stupid enough not to copy out myDocuments from windows before linux installation 'cause I actually trusted linux to install properly... and now I can't afford to wipe out my windows. However, if I can boot into windows just once and get myDocuments out, I can wipe out both Windows and Linux and repartition my computer in a more standard way (ie, install operating systems on primary).

Someone please help me with this!!

Thank you in advance!!

imdeemvp
20th July 2004, 10:03 AM
i hope this will fix your problem.....

enter your bios and in the hard drive section change from AUTO to LBA.... this actually happened to me with FC2 and that was the solution....:D

BTW is windows on a second hard drive? i just noticed about the way you configured your grub.conf ?

cipherxy
20th July 2004, 10:05 AM
Ok, I've read this posting (http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html) and tried what it suggested.

When I run

sfdisk -d /dev/hda | sfdisk --no-reread -H255 /dev/hda

it generates the geometry table and attempts to make the change, but then it says Resource is busy and asks me to restart my computer...... (I'll copy the message when I get home) Does this bug apply to FC1 at all:confused:

imdeemvp
20th July 2004, 10:17 AM
can you open the terminal....type: su and pass

then type this: /boot/grub/grub.conf

dont make any changes to it just copy it and paste it in your next reply...because this does not look right:
title=DOS
map (hd0,0) (hd0,4)
map (hd0,4) (hd0,0)
rootonverify(hd0,4)
makeactive
chainloader +1

this is my grub.conf :

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
default=2
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
title Fedora Core (2.6.6-1.435.2.3) <-THIS IS FIRST KERNEL
root (hd0,1)
kernel /vmlinuz-2.6.6-1.435.2.3 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.6-1.435.2.3.img
title Fedora Core (2.6.5-1.358) <-THIS IS MY SECOND KERNEL
root (hd0,1)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
title WinXPHome <-THIS IS WINDOZ
rootnoverify (hd0,0)
chainloader +1

cipherxy
20th July 2004, 04:31 PM
Hi imdeemvp,
I don't think I have the option of choosing LBA in my BIOS.....

Also, to answer your question, I only have 1 hard drive. It's set as primary master. There are 4 partitions on this hard drive, 2 primary partitions and 2 extended.

quote: I have an unusual partition where both my Windows and Linux are installed on extended partitions.

4 partitions, 2 primary and 2 extended.
- hda2 and hda3 are my logical drives (primary)
- hd5 is my Windows XP (extended)
- hd6 is my Linux (Fedora Core 1) (extended)


Also, i've tried to make a copy of the grub.conf file but I can't seem to access my floppy drive.... (I really don't know how Linux works....)

But my grub.conf is every similar to yours. Linux boots up fine so I assume the Linux part is right, for my windows part it is

title=DOS
map (hd0,0) (hd0,4)
map (hd0,4) (hd0,0)
rootonverify(hd0,4)
chainloader +1

and I do NOT had a boot partition.

Any help is apprecitated! Thanks :)

Pipa Brasil Instagram Photos - Novo Centro Photos on Instagram - Radisson BLU Hotel Liuzhou Instagram Photos