PDA

View Full Version : Yum error : Missing dependency


vicky08
10th July 2008, 06:30 PM
Hi All,
I tired to install kdevelop, using

yum install kdevelop.i386

and i got the following error :
================================================== ==========================
Error: Missing Dependency: libopensync.so.0 is needed by package kdepim-libs
Error: Missing Dependency: libkdnssd-devel is needed by package kdelibs-devel
Error: Missing Dependency: libosengine.so.0 is needed by package kdepim-libs
Error: Missing Dependency: libgpgme.so.11(GPGME_1.0) is needed by package kdepim-libs
Error: Missing Dependency: libmal.so.0 is needed by package kdepim
Error: Missing Dependency: libgpgme.so.11 is needed by package kdepim-libs
Error: Missing Dependency: spambayes is needed by package kdepim
================================================== ===========================

What is the problem?

Here is my yum.conf file:
================================================== ============
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
installonly_limit=2

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
================================================== =================

Thanks in advance
Vicky

sideways
10th July 2008, 10:59 PM
Which version of fedora are you running and is it 32-bit or 64-bit?

Have you added any nonstandard repositories (post output of 'yum repolist')?

You could try 'yum clean all' see if that helps, otherwise a rpm database rebuild may be required.

vicky08
11th July 2008, 02:20 AM
I am using fedora 8 32 nit version. Here is output of yum repolist :
================================================
repo id repo name status
====== ========== =======
livna Livna for Fedora Core 8 - i386 - Base enabled
updates Fedora 8 - i386 - Updates enabled
================================================== ===

sideways
11th July 2008, 01:41 PM
You only have Fedora Updates, you're missing the core Fedora repo. Is it enabled in /etc/yum.repos.d/fedora.repo?
(It should be the first one listed in that file under "[fedora]" section, ensure it is there and hasthe line "enabled=1"),

vicky08
13th July 2008, 06:08 PM
Hi Sideways
Ya, I did. and that solved the problem... But how cud that file have changed.???.,. I have not changed it..

sideways
13th July 2008, 06:27 PM
Hi Sideways
Ya, I did. and that solved the problem... But how cud that file have changed.???.,. I have not changed it..

I'm not sure but it could have been a bit flip caused by cosmic radiation which changed ascii 1 (11001b) to ascii 0 (11000b)

I am not joking! eg

http://news.bbc.co.uk/1/hi/technology/7335322.stm

search google for "cosmic rays soft errors"

sideways
13th July 2008, 10:34 PM
I've noticed bizarre errors like this one recently, hard to pin down directly to cosmic radiation. Maybe due to Iran's nuclear prpgram or unusual sunspot activity.

Perhaps we need to start reporting these "mysterious" bugs globally.

adjusts tin hat ;)

Bhor - Samarra Photos - Delgado Instagram Photos