PDA

View Full Version : FC2 and Windows XP Dual boot


Slinwagh
8th July 2004, 11:58 AM
Hi

I have fallen into the "windows can't boot" dual boot trap.

I am using two physical SATA HDD, one per OS.

I installed as follows.

1. Install Windows XP on disk x
2. Install FC 2 on disk y

Via the GRUB bootloader the following happens:

1. FC 2 boots
2. During boot if I choose to boot Windows XP bia the GRUB bootloader the PC just hangs.

I have tried searching etc and I stumbled upon an article about using the sfdisk command.

http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html

I followed the Recovery procedure with no luck.

However when my PC boots I can choose which physical SATA disk to boot from, if I choose the disk with Windows XP on it will boot, the same goes for Linux.

Can anyone help me fix this so i can dual boot via the GRUB bootloader and not have to choose the disk via the bios.

Thanks in advance.

wayneman
8th July 2004, 02:48 PM
Try booting to rescue mode and use the fdisk command to retrieve your hard disk cylinders,heads, and sectors. Then load the Fedora installation as you would from the CD-ROM. At the GRUB bool loader screen, try passing in hda=14593,255,63 or whatever it is for your hard disk, as a kernel parameter.

It worked for me...

friez
8th July 2004, 03:35 PM
what does your grub config look when you pc hangs does it show
rootnoverify (hd0,4)
chainloader+1
or something simiar
make sure grub is pointing to the right partions

brax4444
9th July 2004, 01:41 AM
"
That's it, I got it figured out. Just so everyone knows, the thing to understand is that Linux usually shows your partitions (if you have one hard disk that is partitioned) as hda1, hda2, hda3 In my case: hda1 is the Linux partition and hda2 is the swap partition. hda3 contains my windows 2000. Grub starts with 0 instead of 1. it also includes a drive number it seems. (hd0,2) is what I had to change it to from (hd0,4) in my grub DOS boot command. hd0 is the primary hard drive and the ,2 means the third partition. That's all it took to fix it! ,4 is invalid (I don't have 5 partitions) but that's what grub had initially.

Also, in order to permanently change the file I had to log in as root and modify it, I never noticed a way to save changes when editing boot commands on startup in grub. They just go back to the way they were on the next boot.
"
I included the above quote because I thought it might help you. try changing (hd0,X) to (hd1,0) if you only have one paritition and the boot you're having trouble with is on the second hard drive (hd1). Log in as root to edit your grub.conf file found in /boot/grub/

Hope that helps!

PompeyBlue
9th July 2004, 02:41 AM
I had exactly the same problem. In the end, I found a reference on bugzilla that says your harddrive must be in LBA mode. I went into the BIOS and found that the harddrive with windows on was set to "auto". Setting it to LBA meant I had to re-install everything, but it also meant that the dual boot worked.