PDA

View Full Version : fedora 9 - connect to secure wireless network with broadcom drivers


rphegde
14th May 2008, 03:24 AM
I have not been able to connect to my secure wireless network with WEP security on.
I have the following wireless hardware
Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 03)

I installed the following firmware
broadcom-wl-4.150.10.5.tar.bz2
I can see all the wireless networks but when I try to connect I keep getting the
"Wireless Network Secrets Required" dialog box and it defaults to 40/128 bit hexadecimal -
If I disable the WEP security I can connect to the network.
Any help is greatly appreciated.
I also filed a bug
https://bugzilla.redhat.com/show_bug.cgi?id=444847

thanks

rphegde
24th May 2008, 10:39 PM
any help is greatly appreciated - Not sure what I am missing.

bbfuller
24th May 2008, 11:03 PM
Hello rphegde

What are you putting into the Wireless Secrets dialogue?

It should have options to input the hexadecimal code, ASCII text or passphrase.

I've always found the hexadecimal option the best for WEP. What happens when you input that?

rphegde
25th May 2008, 06:54 AM
I upgraded to the most recent kernel and now I can connect - WOW !!

NeilEvan814
25th May 2008, 08:16 AM
Hi I am having the same difficulty but can't find a screen like you state that that asks for a variey of key options. In netmanager I put in a key that I was using on my windows partiton, but when I check in iwconfig the 26 digit alpha numeric that I was using has been changed to something else. I do not even see an option for wireless networks anymore in the upper righthand corner of my screen. I am a linux newbie and would appreciate any assistance. I have installed my b43 driver and before I set up my own router I could detect wireless networks and even connect to them...so i don't know what's going on.
Thanks, Neil

NeilEvan814
25th May 2008, 08:18 AM
Just wanted to post what my iwconfig output was.....

[root@localhost ~]# iwconfig
lo no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"WingInIt"
Mode:Managed Frequency:2.462 GHz Access Point: 00:1F:33:24:63:32
Bit Rate=11 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:3078-4135-3742-3354-3138-5A54-5639-38
Link Quality=88/100 Signal level=-47 dBm Noise level=-73 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 no wireless extensions.

bbfuller
25th May 2008, 10:24 AM
Hello NeilEvan814

It's pretty unusual for the NetworkManager icon to disappear from Gnome, not so unusual in KDE.

Try the commands:

su -

to obtain full root control over your machine. That is a space and a minus sign after the 'su'.

Then:

service NetworkManager status

to confirm if NetworkManager is running. Capitalisation is important in that command by the way.

In any event, the output of you 'iwconfig' command would indicate that you are connected to the wireless network "WingInIt".

Are you not able to use your network?

Matola - Jalandhar Travel Photos - Amsterdam -