PDA

View Full Version : Installed F9 preview and can't get it to boot


gamblor01
24th April 2008, 01:51 PM
So not too long ago I setup my system to triple boot WinXP, Fedora 8, and Ubuntu 7.10. I had some problems getting Fedora 8 to work because the initrd did not contain some SATA drivers I needed so I got a kernel panic (I had to make a new initrd with ata_piix and point grub to that new initrd file). Here's my fdisk -l output:


Disk /dev/sda: 400.0 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2b7a2b79

Device Boot Start End Blocks Id System
/dev/sda1 * 1 48640 390700768+ 7 HPFS/NTFS

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000ebf86

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 8355 67111506 83 Linux
/dev/sdb2 8356 8486 1052257+ 82 Linux swap / Solaris
/dev/sdb3 8487 24421 127997887+ 83 Linux


Anyway, I submitted a bugzilla entry for this issue in Fedora 8. Someone just now responded asking if the problem still exists in Fedora 9 preview. Since I haven't really done much with my Fedora partition, I decided to download the F9 preview and try it out. So here's what I did (note that Fedora 8 was previously installed on my /dev/sdb1 partition):

1. Downloaded the F9 preview iso file and burned it to DVD

2. Put the DVD in and ran the installer

3. reformatted the /dev/sdb1 and installed

4. At this point I rebooted into Ubuntu to change the menu.lst file (and got an error while mounting /dev/sdb1 but that was because the UUID had changed. Once in Ubuntu I just ran "sudo vol_id /dev/sdb1" to get the new UUID and put that into my /etc/fstab for /dev/sdb1. Now it mounts fine).

5. I opened up my menu.lst file and changed the entry for Fedora 8 parameters to Fedora 9 now.

6. Rebooted my computer, with the intent of booting into F9 now.


Whenever I select Fedora 9 from the menu though, it just gives me this error on the screen that says:


Error 2: Bad file or directory type

Press any key to continue...

Pressing a key takes me back to the grub menu where I can load WinXP or Ubuntu just fine. I can't figure out what this error means!

Here's the relevant section of my menu.lst file (Ubuntu's grub is the current bootloader. I did NOT let F9 install a bootloader because one already exists):


title Fedora 9 preview
root (hd1,0)
kernel /boot/vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 root=/dev/sdb1 rhgb quiet
initrd /boot/initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img
savedefault
boot


I was told the problem was that Fedora no longer uses device designations from grub, it requires the disk label. So I ran "e2label /dev/sdb1" and it printed out "/":


bdmayes@ubuntubox:~$ sudo e2label /dev/sdb1
/


So I have tried changing my menu.lst to many different things. Here are some of them (and obviously...none of them work):



title Fedora 9 preview
root (hd1,0)
kernel /boot/vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img
savedefault
boot



title Fedora 9 preview
root (hd1,0)
kernel /vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 root=LABEL=/ rhgb quiet
initrd /initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img
savedefault
boot



title Fedora 9 preview
root (hd1,0)
kernel /boot/vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 root=UUID=b41c0b8c-7acd-46d7-a105-71ac938d6840 rhgb quiet
initrd /boot/initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img
savedefault
boot



title Fedora 9 preview
root (hd1,0)
kernel /vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 root=UUID=b41c0b8c-7acd-46d7-a105-71ac938d6840 rhgb quiet
initrd /initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img
savedefault
boot


Anyone have any ideas? Is this error even caused by an error in menu.lst?

angryfirelord
25th April 2008, 03:08 PM
Could be that something got corrupted with the filesystem, but I'm not sure what the error means. What I would do is grab a LiveCD and use that to install Fedora. The DVDs have given me trouble at one point or another.

Dangermouse
25th April 2008, 06:08 PM
Hi i dont know very much about grub, but heres mine if its any help

title Fedora 9 Preview
root (hd0,0)
kernel /vmlinuz-2.6.25-0.234.rc9.git1.fc9.x86_64 ro root=UUID=3e1d7c68-faa0-4696-a00f-f52a1dddb863 rhgb quiet
initrd /initrd-2.6.25-0.234.rc9.git1.fc9.x86_64.img

gamblor01
26th April 2008, 02:58 PM
Hmm...maybe I'll try the liveCD or just try reinstalling.

DangerMouse, there is going to be some subtle difference between our menu.lst files. Your root is (hd0,0) because of your partitioning scheme. This means that you installed Fedora 9 to /dev/sda1 (or /dev/hda1 if that's what it's called). The first 0 means that it's installed to the first hard drive (sda) and the second zero means it's the first partition, sda1, as opposed to sda2, sda3, or higher.

Mine should definitely be set to (hd1,0) because it's installed on the second hard drive, first partition (thus, /dev/sdb1). The only difference I noticed was that your file had the "ro" option but I seriously doubt that this is going to cause an error like I was seeing. I'm building Qt (for an open source project I work on) right now but once it's done I'll try one last time by adding the "ro" option and see if it will boot. If that doesn't work I guess I'll try reinstalling and/or using another install method. Perhaps I should let the installer verify the DVD this time...

If anyone else comes up with something please let me know. Thanks.

stoat
27th April 2008, 03:36 AM
Hello gamblor01,

You currently are booting with Ubuntu. I have never used Ubuntu, but I guess you can press 'c' at the Ubuntu GRUB menu and get a grub> prompt command line. Are you familiar with the <Tab> completion feature of the grub> prompt? You can use that to confirm (or not) what you think the entries should be for Fedora in the Ubuntu menu.lst.

For example... at the grub> prompt, enter: root (hd1, and press <Tab>
That should list the available partitions on hd1. Look for your type 0x83 Linux partitions. If they are not there, then try the other drive (you could be mixed up; it happens).
If you see your Linux partitions, continue completing the root line by entering a number for the Linux partition that you think is Fedora. Press <Tab> until the line is complete then press <Enter>. It should accept the entry and confirm the partition.
Next, at the grub> prompt enter: kernel /boot/vmlinuz and press <Tab>. That will complete the command line or partially complete it and list available kernels to complete it. Continue on this way with <Tab> and making entries until you get a complete kernel command line. Don't worry about any parameters. It will probably still boot without them (it did for me when I tested all this tonight). Press <Enter> and it should accept the entry and confirm the kernel.
Get the idea? Continue on with the initrd command next.
Finally, after the root, kernel, and initrd commands have been completed, entered, and accepted, then enter boot. See what happens. It's supposed to boot.

From all of this, you can confirm what you put in the menu.lst, or maybe get a big surprise about where you were wrong in your thinking about something.

Another idea that you can try is to use the configfile menu command for Fedora in the Ubuntu menu.lst instead of using the traditional root, kernel, initrd commands. It works by reloading the GRUB menu using the information in the specified configuration file. Example if (hd1,0) really is the partition with the Fedora boot directory...title Fedora
configfile (hd1,0)/boot/grub/grub.confA side benefit of using the configfile command is that a Fedora kernel update will not break the Fedora choice in the Ubuntu menu. This idea will not work if you chose to not install the boot loader when you installed Fedora. Reason: a grub.conf is not created when you choose that boot loader option in anaconda.

My last idea is to re-install Fedora's GRUB in the first sector of the Fedora partition (if it is not already installed there) and use the chainloader menu command in the Ubuntu menu.lst. It works to launch the boot sector code of the specified partition. Example...title Fedora
root (hd1,0)
chainloader +1You, of course, should change the drive and partition if you have discovered them to be something else. This method is also not affected by Fedora kernel updates.

leigh123linux
27th April 2008, 10:57 AM
Moved to Alpha - Beta

gamblor01
27th April 2008, 02:20 PM
As a bit of a side note, please everyone just trust me that Fedora is installed on /dev/sdb1. My fdisk -l output is in my first post. If you look at it you'll see the ext3 partition on /dev/sdb1. I am 100% positive that this is correct. There is no mix-up there I promise.


@stoat:
I tried the grub command line and it didn't help either. Typing in the "root (hd1,)" and doing the tab auto-complete showed the same 3 partitions from my fdisk output. I selected the first one [ root (hd1,0) ] and it seemed to accept that command just fine. That's when I ran into problems. It looks like it's the kernel command causing these errors.

Here's what the output looks like (note that each "error" message appeared as soon as I hit tab to attempt to auto-complete):


grub> kernel
Error 1: Filename must be either an absolute path or blocklist

grub> kernel /
Error 2: Bad file or directory type

grub> kernel /boot
Error 2: Bad file or directory type

grub> kernel /boot/
Error 2: Bad file or directory type

grub> kernel /boot/vmlinuz
Error 2: Bad file or directory type


I think at this point I'm just going to wind up reinstalling and I'll try again. I generally don't verify the md5sum (generally TCP/IP works), and I also skip the disc verification during installation, but this time I believe I will do both. I guess I'm off to download the ISO again...

stoat
27th April 2008, 03:20 PM
I think at this point I'm just going to wind up reinstalling and I'll try again. I generally don't verify the md5sum (generally TCP/IP works), and I also skip the disc verification during installation, but this time I believe I will do both. I guess I'm off to download the ISO again...Hello again gamblor01,

Well, at least you tried. I would get a new ISO and reinstall, too. But remember to use sha1sum to verify, not md5sum. It's also a good idea to have your disk burning software verify the data after burning if it can do that.

Another idea: You appear have some empty cylinders at the very end of that 250 GB drive. It looks like enough space for the F8 ISO file. There is also room in the drive's partition table for one more primary partition. You could create a FAT32 partition in that empty space, download the F8 ISO there, and do a Hard Drive alternative installation. It would skip the step of making a disk. If you are interested, also download the F8 vmlinuz and initrd, boot them from Ubuntu, choose "Hard Drive", select the partition with the ISO, and anaconda starts.

gamblor01
27th April 2008, 04:09 PM
Well I just tried downloading the iso again. You're correct, it was a sha1sum instead of md5sum. I verified the sha1sum...it was dead accurate. I also tested the installation media during the Fedora 9 installation and it checked out perfectly (though I realize this is not 100% fool proof).

So I reinstalled and the same problem exists.

I might try using the live CD to install this instead of the DVD. Has anyone else out there attempted to install the Fedora 9 preview x86_64 and actually been successful? I'm wondering if this is yet another bug. Certainly someone must have been able to boot this otherwise they wouldn't have released the DVDs, right?

I guess I'm off to download the live CD now.

bepaald
27th April 2008, 04:51 PM
Hi gamblor! Just so you know, you're not the only one with this problem. I'm having the same issue (using the livecd), and there are some other threads about it too (http://forums.fedoraforum.org/forum/showthread.php?t=186071 ).

I read somewhere, though I can't seem to find it now, that a solution is to format your partitions yourself and not have the installer do it. So you do not format the partitions in the F9 installer, just select the partititions, click edit, and set the desired mount point. Unfortunately, when I tried this with my livecd, I got an error saying I had to format the '/' partition when installing using the livecd. But it might still work with the regular install dvd.

If anyone else has a different solution I would be very happy. My DVD drive is busted and anything but the livecd is too big too fit my USB stick :( .

Good luck!

bepaald

*EDIT: solved my problem by creating a separate boot partition with gparted before install. you don't have to reformat that, and it's all grub needs to access. So that should work for you too if you have to use the livecd.

gamblor01
28th April 2008, 01:13 PM
@bepaald,

Thank you so much for this information! Installing via the live CD (actually the live DVD because I'm using the x86_64 version) failed as well. I will give this a shot (probably tomorrow...I have a research paper due today and a final) and report back on the results. From the other thread you linked to there, it definitely sounds like the issue is installing grub vs. not installing grub. Thanks again!


P.S. New DVD drives (even burners) are like $20-$25. Go get a new one. ;)

gamblor01
3rd May 2008, 08:54 PM
bepaald -- you were correct! Just so that I could test the F9 installation (to hopefully close the original bug report I opened) I let the Fedora 9 installer write to my MBR. It booted up fine after that. I just used my Ubuntu live CD to restore the "old" grub that I have been using.

So I have successfully confirmed that the bug I found can be closed because it is fixed by Fedora 9, and I was able to post some relevant information about the new bug (causing this "Error 2" condition).

Thanks!!

Trapper
12th May 2008, 10:23 PM
Well, I sure can verify that F9 has some sort of grub issue if you allow the installer to format your partition for you. I have F9 with kernel 2.6.25-14.fc9.i686.

When installing if I allow the installer to format my partition I get "Error 2: Bad file or directory type." and a failed boot. If I format the partition prior to installation and do not allow the installer to format the partition I get my first boot just fine. I replicated this several times and even replicated it on another machine across the room. Just my 2 cents worth.

product: KM266A-8237
vendor: VIA Technologies, Inc.
width: 32 bits
capabilities:
SMBIOS version 2.2,
DMI version 2.2,
SMP specification v1.4,
Symmetric Multi-Processing
configuration:
boot: normal
chassis: desktop
cpus: 1
memory:
512 MB
cpu:
AMD Sempron 2400+

gamblor01
13th May 2008, 02:38 AM
Yep, that sounds about right. The link that bepaald gave has good info in it. One of the things in there is a link to a bugzilla report. This has been reported to Fedora:

https://bugzilla.redhat.com/show_bug.cgi?id=443289


Not much we can do now but wait for someone in development to resolve the issue.

Trapper
13th May 2008, 03:14 AM
Not much we can do now but wait for someone in development to resolve the issue.

Ouch. This is F9's final that I am having the problem with. There are going to be a lot of squawking people tomorrow. This problem isn't at all desirable or beneficial for a final release.