PDA

View Full Version : Awful sound on F9


ButteBlues
23rd April 2008, 07:34 AM
The sound is very bright-sounding, as if there's no real base to it. Same speakers work fine with iPod and other distros.

It's getting really annoying having half my music sound like it was made by the Chipmunks.

Occurs across Gstreamer, Xine, and Audacious.

stevea
23rd April 2008, 02:38 PM
If this just 2 speakers of like a 5.1 ? If the latter then you probably didn't config xine and the others for the 5.1.

Also you may need to config the mixer "gnome-volume-control", If all your speakers aren't listed select edit->preferences and check off the boxes. Back in the main window unmute and adjust volumes.

In xineyou can right-click the window, select "settings->setup". In the popup screen scroll about 75% down and select the proper thing for "speaker arrangement".

On gmplayer (the gui front end for mplayer) right click the win select "preferences". On the audio tab click "configure driver", the top item menu has various speaker arrangements.

ButteBlues
26th April 2008, 09:43 PM
I've tried changing all that up.

Doesn't fix it.


I've also tried changing the settings via the Sound item in Preferences, and it seems the [soundcard] option is the ONLY one that works fine, but even then I had to remove the pulse plugin for ALSA.

However, this is NOT a good solution because that means audio output is restricted to one application at a time!

ButteBlues
26th April 2008, 11:07 PM
I've also noticed that the sound is tinny even with the above. :(

This hasn't occurred on Ubuntu, former version of Fedora, openSUSE, or Foresight.

ButteBlues
27th April 2008, 01:42 AM
Cool - we found the solution, and I've written about it here (http://dev.compiz-fusion.org/~wfarr/viewpost?id=22) as well as filed a bug.

mbokil
27th April 2008, 02:37 AM
Oy, it is amazing how many fixes it takes to get sound working on Fedora 9. I am hoping all the glitches will be fixed when pulseaudio moves to the glitch-free tree.

ButteBlues
27th April 2008, 02:58 AM
Oy, it is amazing how many fixes it takes to get sound working on Fedora 9. I am hoping all the glitches will be fixed when pulseaudio moves to the glitch-free tree.
Well, this was an issue with the kernel module not being configured correctly - not Pulse.