PDA

View Full Version : RDesktop problem


starstatras
22nd April 2008, 08:58 PM
I am a sixth form student currently doing my AS levels.
Therefore sometimes I need to be able to access my school work over the web. My school attempts/pretends to provide us with remote login, unfortunately I have been having problems with it. At one point it said I did not have permission to login over the net even though I was using my own user and password the same as I would from windows. That problem has apparently been fixed(knowing my sixth form probably not though) unfortunately when I try now, this happens.

[lee@localhost ~]$ rdesktop 62.171.195.132:9000
Autoselected keyboard map en-us
ERROR: Failed to extract public key from certificate
ERROR: send: Connection reset by peer
ERROR: Connection closed
[lee@localhost ~]$

Any help greatly appreciated.
Thanks, Lee.

wintersm
23rd April 2008, 02:02 AM
have a look at http://www.2x.com/forums/viewtopic.php?t=1200&view=previous&sid=ca4ee0afa897b80dec5977d33216eb87

I googled rdesktop "ERROR: Failed to extract public key from certificate" to find this.

starstatras
23rd April 2008, 12:14 PM
I cant manage to figure out what to do from that and I could not find anything helpful when I googled it.
Infact a google search only comes up with 3 results (including this one - which is infact top result)

wintersm
23rd April 2008, 10:44 PM
what it is saying is that the server that you are connecting to is requiring some security encryption that rdesktop doesnt handle..

you can only overcome this if you are able to lower the security of the server, which is unlikely. It seems that this protocol is only present in the newer windows servers.

starstatras
25th April 2008, 03:30 PM
Ah. The server is actually running windows 2008, which is probably why then.
If I contact the administrator would there be anything other than lowering security (I think they might be a bit reluctant to do that) that could be done?
Thanks for your help!
Cheers, Lee

ggulik
18th May 2008, 04:39 PM
rdesktop can connect to Vista or Windows Server 2008 with the -4 option:

-4 Use RDP version 4.

The default is to use RDP verison 5.

Mirny Instagram Photos - Sisauli Travel Photos - Tursunzoda Instagram Photos