PDA

View Full Version : aurora 1.0 --> fc2 for sparc


cybrjackle
21st June 2004, 04:51 PM
Just wondering if anyone uses sparc hardware and has sucessfully updated aurora 1.0 to Wombat (aka fc 1.91) ? Since there aren't any iso's my update is going slow and painful, a lot of packags don't want to update and i've been doing them one bye one, (sometimes a few at a time) Here is one of the big dep problems i keep getting:

# yum upgrade newt
Error: Cannot find baseurl or name for server 'updates'. Skipping
Gathering package information from servers
Getting headers from: Red Hat Linux Null base
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
.package netconfig needs libnewt.so.0.50 (not provided)
package ntsysv needs libnewt.so.0.50 (not provided)
package setuptool needs libnewt.so.0.50 (not provided)
package kbdconfig needs libnewt.so.0.50 (not provided)
package mouseconfig needs libnewt.so.0.50 (not provided)
package authconfig needs libnewt.so.0.50 (not provided)
package kudzu needs libnewt.so.0.50 (not provided)
package lokkit needs libnewt.so.0.50 (not provided)
package timeconfig needs libnewt.so.0.50 (not provided)


Here is what is in my "yum.conf"

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
exactarch=0
#exactarch=1

[base]
name=Red Hat Linux $releasever base
baseurl=ftp://auroralinux.org/pub/aurora/build-1.91/$basearch/os/Fedora/RPMS/
#baseurl=http://public.planetmirror.com/pub/yum-rpm/aurora/1.0/sparc/os/
#baseurl=ftp://auroralinux.org/pub/aurora/build-1.91/$basearch/os/Fedora/RPMS/
#baseurl=ftp://auroralinux.org/pub/aurora/build-1.0/$basearch/os/Fedora/RPMS/


[updates]
name=Red Hat Linux $releasever updates
#baseurl=ftp://auroralinux.org/pub/aurora/updates/1.91/$basearch/
#baseurl=http://public.planetmirror.com/pub/yum-rpm/aurora/1.0/sparc/updates/
#baseurl=ftp://auroralinux.org/pub/aurora/updates/1.0/$basearch/sparc/

I have been changing these two values to see if that makes a diff on some packages

exactarch=0
exactarch=1

I've updated about 90 rpms in total. Anyone have any "luck" here?


I noticed the board has "PPC" & "AMD64", just curious if you (Moderators) have thought about supporting "Sparc" too?

Jman
22nd June 2004, 03:09 AM
I see: you're trying aurora (http://auroralinux.org/).

Try running yum provides libnewt

cybrjackle
22nd June 2004, 05:52 AM
# yum provides libnewt
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.0 base
Finding updated packages
Downloading needed headers
Looking in available packages for a providing package
Available package: newt.sparc 0:0.51.6-2.1.1 from base matches with
/usr/lib/libnewt.so.0.51
Available package: newt.sparc 0:0.51.6-2.1.1 from base matches with
/usr/lib/libnewt.so.0.51.6
Available package: newt.sparc 0:0.51.6-2.1.1 from base matches with
libnewt.so.0.51
Available package: newt-devel.sparc 0:0.51.6-2.1.1 from base matches with
/usr/lib/libnewt.a
Available package: newt-devel.sparc 0:0.51.6-2.1.1 from base matches with
/usr/lib/libnewt.so
5 results returned
Looking in installed packages for a providing package
Installed package: newt.sparc 0:0.50.35-1 matches with
/usr/lib/libnewt.so.0.50.35
Installed package: newt.sparc 0:0.50.35-1 matches with
libnewt.so.0.50
2 results returned

cybrjackle
22nd June 2004, 05:59 AM
# rpm -Uvh newt-0.51.6-2.1.1.sparc.rpm
/etc/security/selinux/file_contexts: No such file or directory
error: Failed dependencies:
libnewt.so.0.50 is needed by (installed) netconfig-0.8.11-7
libnewt.so.0.50 is needed by (installed) ntsysv-1.3.5-3
libnewt.so.0.50 is needed by (installed) setuptool-1.8-2
libnewt.so.0.50 is needed by (installed) kbdconfig-1.9.15-2
libnewt.so.0.50 is needed by (installed) mouseconfig-4.25-2sparc
libnewt.so.0.50 is needed by (installed) authconfig-4.2.8-4
libnewt.so.0.50 is needed by (installed) kudzu-0.99.52-3sparc
libnewt.so.0.50 is needed by (installed) lokkit-0.50-8
libnewt.so.0.50 is needed by (installed) timeconfig-3.2.7-1


# yum upgrade timeconfig
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.0 base
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
..Dependencies resolved
I will do the following:
[update: system-config-date 1.7.2-1.noarch]
I will install/upgrade these to satisfy the dependencies:
[deps: ntp 4.2.0-7.sparc]
[deps: redhat-menus 1.3-1.noarch]
[deps: libcap 1.10-18.1.sparc]
[deps: rhpl 0.138-1sparc.sparc]
[deps: pyxf86config 0.3.15-1.1.sparc]
[deps: htmlview 2.0.0-12.noarch]
Is this ok [y/N]: y

I'm going to go through and see if i can update more one by one.

cybrjackle
22nd June 2004, 06:30 AM
# rpm -e kbdconfig
# rpm -e mouseconfig

# yum upgrade
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.0 base
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
.conflict between perl and perl-NDBM_File


By the time i get this upgraded, i could have had gentoo back on here and updated. :mad:

cybrjackle
22nd June 2004, 06:42 AM
Well Dr. I think we have a winner

# rpm -e perl-NDBM_File

# yum upgrade perl
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.0 base
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
.Dependencies resolved
I will do the following:
[update: perl 3:5.8.3-13.sparc]
I will install/upgrade these to satisfy the dependencies:
[deps: perl-Filter 1.30-2.1.sparc]
Is this ok [y/N]: y

perl 100 % done 1/6
perl-Filter 100 % done 2/6
Completing update for perl - 3/6
Erasing: perl-CGI 4/6
Erasing: perl-CPAN 5/6
Erasing: perl-DB_File 6/6
Updated: perl 3:5.8.3-13.sparc
Dep Installed: perl-Filter 1.30-2.1.sparc



# yum upgrade
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.0 base
Finding updated packages
Downloading needed headers
Finding obsoleted packages
Resolving dependencies
.Dependencies resolved
I will do the following:
[install: kernel 2.6.6-1.370sp2.sparc64]
[update: sendmail 8.12.11-4sparc.sparc]
[update: fedora-release 1.91-9.sparc]
[update: krb5-libs 1.3.2-1.sparc]
[update: openldap-clients 2.1.25-5.1.sparc]
[update: passwd 0.68-8.1.sparc]
[update: fedora-logos 1.1.21-1.1.noarch]
[update: krbafs 1.2.2-2.1.sparc]
[update: gmp 4.1.2-13sparc.sparc]
[update: iproute 2.4.7-13.sparc]
[update: psmisc 21.4-2.sparc]
[update: sysklogd 1.4.1-14.sparc]
[update: compat-db 4.1.25-2.1.sparc]
[update: cpio 2.5-6.sparc]
[update: util-linux 2.12-14sparc.sparc]
[update: jwhois 3.2.2-3.sparc]
[update: pidentd 3.0.16-2.sparc]
[update: vixie-cron 3.0.1-87.sparc]
[update: gdbm 1.8.0-22.1.sparc]
[update: parted 1.6.6-2sparc.sparc]
[update: reiserfs-utils 2:3.6.13-1sparc.sparc]
[update: hdparm 5.5-1.sparc]
[update: cracklib-dicts 2.7-27.1.sparc]
[update: netconfig 0.8.20-1.1.1.sparc]
[update: usbutils 0.11-3.1.sparc]
[update: radvd 0.7.2-7.sparc]
[update: sed 4.0.8-4.sparc]
[update: iputils 20020927-13.sparc]
[update: cyrus-sasl-md5 2.1.18-2.sparc]
[update: procmail 3.22-13.sparc]
[update: cyrus-sasl-plain 2.1.18-2.sparc]
[update: rdate 1.3-3.1.sparc]
[update: system-config-securitylevel-tui 1.3.8-1.sparc]
[update: pciutils 2.1.99.test3-1.1.sparc]
[update: kbd 1.12-1sparc.sparc]
[update: setuptool 1.13-2.1.sparc]
[update: nss_ldap 212-1.sparc]
[update: usermode 1.69-5.sparc]
[update: ntsysv 1.3.9-1.1.sparc]
[update: compat-pwdb 0.62-8.1.sparc]
[update: nfs-utils 1.0.6-19sparc.fc2.sparc]
[update: cyrus-sasl 2.1.18-2.sparc]
[update: rsh 0.17-21.sparc]
[update: tcsh 6.12-8.sparc]
[update: hesiod 3.0.2-29.1.sparc]
[update: vim-common 1:6.2.327-1.sparc]
[update: initscripts 7.54-1sparc.sparc]
[update: gawk 3.1.3-7.sparc]
[update: gpm 1.20.1-44.sparc]
[update: hotplug 3:2004_04_01-1.sparc]
[update: procps 3.2.0-1.1.sparc]
[update: setserial 2.17-15.sparc]
[update: openssh 3.6.1p2-34.sparc]
[update: readline 4.3-10.1.sparc]
[update: pam_krb5 2.0.10-1.sparc]
[update: dhclient 1:3.0.1rc12-2.1.sparc]
[update: hwdata 0.113-1sparc.noarch]
[update: cracklib 2.7-27.1.sparc]
[update: openssh-clients 3.6.1p2-34.sparc]
[update: gnupg 1.2.4-2.1.sparc]
[update: chkconfig 1.3.9-1.1.sparc]
[update: utempter 0.5.4-1.1.sparc]
[update: iptables 1.2.9-2.3.1.sparc]
[update: setup 2.5.31-1.1.noarch]
[update: openldap 2.1.25-5.1.sparc]
[update: sparc32 1.1-7.sparc]
[update: newt 0.51.6-2.1.1.sparc]
[update: specspo 9.0.92-1.1.noarch]
[update: talk 0.17-23.sparc]
[update: raidtools 1.00.3-8.sparc]
[update: quota 1:3.10-2.sparc]
[update: pcre 4.5-1.sparc]
[update: sendmail-cf 8.12.11-4sparc.sparc]
[update: portmap 4.0-59.sparc]
[update: stunnel 4.05-1.sparc]
[update: pam 0.77-38.sparc]
[update: nscd 2.3.3-26sparc3.sparc]
[update: kudzu 1.1.53-2sparc.sparc]
[update: rootfiles 7.2-7.noarch]
[update: tcp_wrappers 7.6-36.sparc]
[update: telnet 1:0.17-28.sparc]
[update: rmt 0.4b33-3.sparc]
[update: authconfig 4.6.1-1.1.1.sparc]
[update: tar 1.13.25-14sparc.sparc]
[update: openssh-server 3.6.1p2-34.sparc]
[update: vim-minimal 1:6.2.327-1.sparc]
I will install/upgrade these to satisfy the dependencies:
[deps: tcl 8.4.5-6.sparc]
[deps: ethtool 1.8-3.1.sparc]
Is this ok [y/N]:

Sorry i turned this into my BLOG. :cool:

Lora del Rio Travel Photos - Stung Treng Photos on Instagram - Lysva Photos on Instagram