PDA

View Full Version : Forwarding problems


John5342
20th January 2008, 12:09 AM
I have a router which happily shares my Internet connection between my own computer and the other 3 computers in my home. Besides my own computer i also have a second computer next to it that i have had connected for a while using a crossover cable using my second network card in my first computer and this has been fine up to now. I have now reached the point where i could do with my second computer connected to the rest of the computer connected to the rest of the network but i don't really want to fork out for a hub and it occured to me i can simply connect it using my first computer and simply forward the packets. I know it can be done but i am not sure how. Any help would be greatly appreciated.

Thanks in advance, John

cuongvt
20th January 2008, 12:21 AM
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/security-guide/s1-firewall-ipt-fwd.html
Above guide still valid for FC8 too.
Btw you can search forum with keyword NAT or forwarding or you can search in google.
Many discussion about this

John5342
20th January 2008, 12:48 AM
I do not want to use NAT as that will cause my second computer to effectively share the same IP address on the network causing many issues so i followed the first bit about forwarding in iptables and also the sysctl bit but i still am getting nowhere.

John5342
20th January 2008, 01:43 AM
Maybe i should clarify what i want to do. I want to connect my second computer to the network in such a way that it appears to be connected directly to the router but i want to do it using the existing direct conection to my first computer which is already on the network. From there the router can handle internet connection sharing, NAT and any other services within the network.

John5342
10th February 2008, 04:59 PM
Have found a solution.

Its not the most elegant solution and i am sure that its not the best way of doing things but adding the following to /etc/sysctl.conf allowed the setup to work:

net.ipv4.conf.eth0.proxy_arp = 1
net.ipv4.conf.eth1.proxy_arp = 1

If anyone has a better solution though to enable forwarding i would love to hear it.

jvonau
10th February 2008, 05:51 PM
This is a layer 2 issue, think "arp" here. When you have physical separation in the lan by some box, you need to use nat or proxy-arp, Bridging the interfaces is another way.

Vettur - Manihari Travel Photos - Garupa