PDA

View Full Version : Monitor horizontal scan problem


townssj
28th October 2007, 04:21 PM
I am using FC7, and I have figured out how to get the X-Windows display centred on the monitor display manually using xvidtune - each time X-windows starts I have to shift the display 4 clicks left otherwise the display is off the right edge of my monitor.

Reading the fora, seems I need to modify xorg.conf, which I have, including a monitor modeline which I copeid from the output of "show" in xvidtune. However, it doesn't seem to make any difference when I restart X-windows. xorg.conf included below.

What am I missing?

Simon

RJFUatHOME
28th October 2007, 05:31 PM
Have you tried using the adjustment settings built into the monitor itself?

Some displays have automatic adjustment settings built into them with limited basic memory for those settings, so it'll toss you back to what it thinks is right everytime until you manually asdjust the monitor and save the setting.

My current display auto adjusts from time to time and my last one saved seven or so specific settings once you adjusted the display manually.

Take a look at you monitors documentation or look it up at the manufacturer. It might help.

LouArnold
28th October 2007, 06:56 PM
I am using FC7, and I have figured out how to get the X-Windows display centred on the monitor display.
Simon

I have what may be the same problem with a just installed F7 Live CD. I should point out that there is no aliasing. The window display is wider than the screen and the RHS is offscreen to the right. When you move the mouse right, the window shifts to the left and then the left side of the window disappears. This isn't a matter of adjusting the monitor. Its a matter of the length (duration) of the horizontal sweep.

I also tried adjusting the Xorg.conf file to no avail.

Note that MS-Windows is installed on the same computer and it works fine in 1024x764 without a manufacturer's driver.

RJFUatHOME
28th October 2007, 08:29 PM
Have either of you tried using the gtf program at a terminal prompt?

Check out this thread which gives instructions on where to paste the output into your xorg.conf.

http://forums.fedoraforum.org/forum/search.php?searchid=5028360

I would look on your windows box display properties and see what exact refresh rate it's using and then try and match it using the gtf program and pasting into your xorg.conf.

townssj
28th October 2007, 10:11 PM
Have you tried using the adjustment settings built into the monitor itself?

Some displays have automatic adjustment settings built into them with limited basic memory for those settings, so it'll toss you back to what it thinks is right everytime until you manually asdjust the monitor and save the setting.

My current display auto adjusts from time to time and my last one saved seven or so specific settings once you adjusted the display manually.

Take a look at you monitors documentation or look it up at the manufacturer. It might help.

Yes, thanks. I looked at this again now, and the key bit of information is that I am using a screen switch to move between 2 machines, one windows (for the rest of the family) and another with FC7. Of course, if I set the screen for FC7, then it is left shifted for windows and vice versa.

I figured I had no way to fix this in windows, so spent some time checking out X. xorg.conf seems to fit the bill, but I can't seem to get it to work. I can of course fix it each time I start X using xvidtune, but I wanted to get it to work automagically.

The other option was a command line invocation of xvidtune, but there doesn't seem to be a way...

Simon

LouArnold
28th October 2007, 10:59 PM
Check out this thread which gives instructions on where to paste the output into your xorg.conf.
http://forums.fedoraforum.org/forum/search.php?searchid=5028360

I followed the thread, got the refresh rate of 60 Hz for the monitor, ran GTF for 1024x768, and for 800x600, modified the xorg,conf file. At the first reboot, it went to 800x600 (Millions of colors) and it all fit on the screen without panning. I changed to "thousands of colors" and went back to panning. I reverted to millions of colors and it still panned. I finally went to System>Preferences>Hardware>Screen Resolution. it was at 856x600 at 60Hz. I changed it to 800x600 at 60Hz and THAT worked. Its even preserved over reboots.

However...I do not get the 1024x768 screen resolution option at all, And frankly, I'm not sure the xorg.conf file is ever used given the evidence I have. I will attach it here, but until we solve this business of the xorg.conf content and format, we'll never really solve this.

townssj
28th October 2007, 11:11 PM
Yeah, funny, after playing with this for weeks, I tried GTF, installing the nvidia driver from linva, nothing worked. Then I went in to screen resolution and changed the refresh rate to 75Hz, and guess what, that fixed the problem...

Simon

LouArnold
28th October 2007, 11:21 PM
I spotted something peculiar in the xorg.conf file. I will try a few more things and get back to you.

RJFUatHOME
29th October 2007, 12:42 AM
Yeah, funny, after playing with this for weeks, I tried GTF, installing the nvidia driver from linva, nothing worked. Then I went in to screen resolution and changed the refresh rate to 75Hz, and guess what, that fixed the problem...

Simon

You know that's kinda funny because I was using a KVM switch with a laptop (windows) and a desktop(linux) and was experiencing similar problems with shifting when using 60 Hz and finally got everything stable at 75 Hz. I don't use the KVM anymore but finally just decided that 75 Hz works well.

There are so many variables, chipsets, drivers, OS, display/built in features etc. You just have to keep toying with it until you find something stable.

LouArnold
29th October 2007, 05:22 AM
Nope...some minor adjustments to xorg.conf don't work. I still don't get 1024x768, no matter what I do. I'll have to come back to this later this week.

Anyway, worse problems...I managed to delete the entire OS with a few choice picks of packages via Yumex. Every last one of 519 packages removed! And now the F7 Live CD gives me a boot failure - the very same one that I installed from successfully earlier today. There has to be a better way.

RJFUatHOME
29th October 2007, 04:50 PM
And now the F7 Live CD gives me a boot failure - the very same one that I installed from successfully earlier today.

It's is possible that the media was corrupted and resulted in a corrupted installation. Did you run the media check during the installation process?

Download and burn a clean copy and make sure you run the media check during installation.

David Stratton
30th October 2007, 04:13 AM
I just joined the forum this evening and I am having the same problem. I got my copy of Fedora Linux 7.0 from Linux+ magazine and the install went fine. Screen resolution is the problem. When I go through the steps to get to the screen resolution option the only choices I am presented with are 800 x 600 and 640 x 480. What I also need to do is find a way to set the resolution to 1024 x 768. I really want to learn how to do these things. I wish there were a user group I could go to close by but the nearest one is over three hours away. Any help will be greatly appreciated. Thanks.

David Stratton
30th October 2007, 05:01 AM
Okay gang. This forum did it. I just didn't look far enough before crying for help. I found my solution on a thread titled "F7 screen resolution?" at post #17. I did what he said and I now have my 1024 x 768. Thanks

LouArnold
30th October 2007, 01:52 PM
Well - er - what did he say to do?

Post 17 asks a question, to which the ultimate response is to change the color depth to 16 versus 24. Is that all you did? Where do you change that depth?

Changing the color depth in the xorg.conf doesn't seem like the answer. The xorg.conf file seems not to have any effect. Unless its the actual format of the file - the sections and subsections within sections. I thought there was a log file generated by the X server when it starts. I wonder if the messages are meaningful in this context.

Just as an aside. I'm not using an LCD display. Its an older monitor from 1996 that's not on the vendor's list. So the xorg.conf file is generic. Picking another vendor's monitor would risk cooking the monitor.

RJFUatHOME
30th October 2007, 05:58 PM
I would try changing your monitor to the "Generic CRT Display" option at "Monitor 1024x768".

Setting things to 60Hz would be safe for almost any monitor:

Also try changing the last "screen" section of your xorg.conf to:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600"
EndSubSection


By the way I have never heard of your graphics card so I'm not really sure what resolutions it can handle and at what color depths!

David Stratton
1st November 2007, 01:42 AM
This is not a good way for me to start out on a new forum. I screwed up. The post I intended to refer to was #16 posted by Seve. (I would have just linked to it but I have not figured out how to do that yet so here is what it said)

Hello:
Open a terminal and type
system-config-display
provide your root password
then, under the
\Hardware Tab
\Monitor Type
\Configure
\Generic LCD Display
\LCD Panel 1024x768


And yes, yum needs to have internet access.

Seve

The only problem I am still having is when the computer is booting up the screens that want my user name and password are out of proportion, tall and skinny but once I get signed in things are fine.

RJFUatHOME
1st November 2007, 02:17 AM
You could try going into System > Administration > Login Screen and change to a different theme and set it back and see if it resets itself correctly. I've run into that situation when playing with xorg.conf, but somehow it's always fixed itself in the end.

There is so much work going into automatically configuring X from the get go, but so many seem to have to resort to custom editing. Like with my LCD, X does detect the refresh rates it claims to be able to handle and at the right resolutions, but in practice those refresh rates, mostly at lower resolutions don't work right and I get an Out of Range error on my monitor. Even the documentation that comes with the monitor says well, if the refresh rates don't work resort to 60 Hz. Hmmm, seems like the poor coders at Xorg have their work cut out for them!

Unfortunately it doesn't make our installs any easier. And so we all continue to manually edit our xorg.conf files!

LouArnold
1st November 2007, 02:29 AM
I would try changing your monitor to the "Generic CRT Display" option at "Monitor 1024x768".

Setting things to 60Hz would be safe for almost any monitor:

Also try changing the last "screen" section of your xorg.conf to:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600"
EndSubSection


By the way I have never heard of your graphics card so I'm not really sure what resolutions it can handle and at what color depths!
First we have similar problems although we have different monitors. I have a CRT and David Stratton has an LCD display. We've tried the "Generic" at 1024x786", but nothing happens. We've tried generating codes for a few resolutions and then putting them into the Xorg.conf file. But we must be doing something wrong in the file format, because that config file doesn't seem to change anything after we log out and log in to re-start the X server. In any case, we cannot get any graphical configuration program under Gnome to give us anything more than 800x600 or 640x480.

Now I suppose we could find a display monitor manufacturer (such as Daytek) and try that setting, but we risk damaging the monitor with too high a frequency.

However David accidentally misquoted the post # of what may be the answer. If we go to post 16 of "F7 screen resolution", it may be there, just as he says.

LouArnold
1st November 2007, 02:31 AM
This is not a good way for me to start out on a new forum. I screwed up. The post I intended to refer to was #16 posted by Seve. (I would have just linked to it but I have not figured out how to do that yet so here is what it said)

Hello:
Open a terminal and type
system-config-display
provide your root password
then, under the
\Hardware Tab
\Monitor Type
\Configure
\Generic LCD Display
\LCD Panel 1024x768


And yes, yum needs to have internet access.

Seve

The only problem I am still having is when the computer is booting up the screens that want my user name and password are out of proportion, tall and skinny but once I get signed in things are fine.

Firstly, this has to be done after you install F7? Or is there another way to change the resolution when the LiveCD boots?

Secondly, I tried this after the install and security updates, and that process didn't work at all. You must have done something more - perhaps you created just the right format of the Xorg.conf file. Can you attach a copy of it?

Thirdly, in previous versions, when I changed the resolution, it changed in the log-on screen and the working window.

Anyway the Xorg.conf file is really key here. If we figure out how to write that up properly then we'll be much farther ahead. Doesn't the X server generate a log file when it reads that config file?

Belen de Umbria Instagram Photos - Leesburg Photos - Chester