PDA

View Full Version : Nvidia Drivers in Fedora Core 2 Test 3


Picomp314
5th May 2004, 04:36 AM
This issue had been driving me crazy for the past couple of days; The Nvidia drivers did not work properly in the 2.6.5 kernel included in FC2T3 because CONFIG_REGPARM=y and CONFIG_4KSTACKS=y both of which are currently incompatible with the latest (5336) Nvidia closed source binary.

The problem is that the default FC2T3 kernel has a patch which always enables CONFIG_4KSTACKS, this is why you must download a new fresh kernel from kernel.org...

1)Download the latest NVIDIA linux driver from http://www.nvidia.com

2)Download and Install the kernel-source package for the kernel you are currently running i.e. ( 2.6.5-1.327 or similar)

3)Download and extract kernel 2.6.5 (http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.5.tar.bz2) to /usr/src/ with the command tar -jxvf linux-2.6.5.tar.bz2

4)Copy the .config file from /usr/src/linux-2.6.5-1.327/ to /usr/src/linux-2.6.5/

5) cd to /usr/src/linux-2.6.5/
and type make oldconfig, and answer no to all questions involving experimental modules,
open the .config file with your favourite text editor and look for REGPARM and 4KSTACKS to make sure they are disabled

6)next type make && make modules_install && make install

7)Reboot


8)cd to /etc/X11/ and vi XF86Config comment out the lines saying Load "dri" and make sure the line Load "glx" exists; find Driver "nv" or Driver "vesa" and replace with Driver "nvidia"; Press ESC and type :w hit enter and type :q

9)use the command startx, happy 3D acceleration

linuxmad
5th May 2004, 10:55 AM
I hope nvidia fixes this issue right on time for FC 2 final.

gotmonkey
5th May 2004, 02:34 PM
Picomp314,

I think that I follow you most of the way. I don't really understand you would need to download the 2.6.5 from kernel.org.

Not to sound totally stupid (too late for that), line 8 talks about nvidia drivers. I have an ATI video card. How will get that to work?

gotmonkey
5th May 2004, 07:16 PM
Picomp314,

I am a noob to linux.

Nvidia.com. Should I be downloading the kernel tar file from Nvidia? or the source rpm?

Just supposing I don't botch up steps 1-7.
Reboot to a failsafe.
make changes under 8).
startx

With having an ATI video card (9700pro) will I be able to log in with graphical interface?

Picomp314
5th May 2004, 09:04 PM
Sorry, I must have gotten cofused because your last post mentioned both the nForce mobo and the ATI card, this will unfortunately not work for you. As far as I know there is no (decent?) 3d support for ATI cards, correct me if I am wrong because I have no experience dealing with ATI & Linux...

gotmonkey
6th May 2004, 12:04 AM
Thanks for getting back to me. I am glad that I waited to hear back from you.

I will keep looking

Finalzone
8th May 2004, 03:34 AM
I have two custom kernels (2.6.5-1.351 and 2.6.5). The former runs with nvidia rpm (NVIDIA-kernel) but the 3D application won't work anymore. Also, when I boot the system, I can no longer see the text. VESA displays Tux but no text. What went wrong?

Picomp314
9th May 2004, 11:14 PM
Sounds like you need to edit your /etc/XF86Config

attach yours so I can tell you exactly what you need to change

wshawn
10th May 2004, 01:16 AM
Originally posted by linuxmad
I hope nvidia fixes this issue right on time for FC 2 final.

Isn't it up to Fedora to include the driver or are we still wrestling with some license issue.

Picomp314
10th May 2004, 01:30 AM
this binary is closed source and would taint the kernel, i think this is why the Fedora Team does not include it

klopfest
11th May 2004, 04:22 PM
I have gotten the NVIDIA drivers to work in FC2 test 3 without kernel modification. There are two additional steps:

1) modify the XF86Config file to not wait for TV and something else (I apologize - it is on my system at home - I will post more details tonight)
2) do not boot using the graphical boot screen (i.e. remove rhgb from Grub)

Doing these two things, the driver works fine. With the rhgb enabled at boot up, it works the first time (showing the computer graphic) and then hangs when GDM starts.

Sorry for the "vagueness" of #1 - I will post more information this evening.

Finalzone
11th May 2004, 05:54 PM
I did not have problem until kernel 2.6.5-1.358. Boot text will change into something with Tux then it will freeze. I failed to find the source of the problem. .config is attached to see what went wrong.

zorroh
11th May 2004, 06:26 PM
Originally posted by klopfest
[B]I have gotten the NVIDIA drivers to work in FC2 test 3 without kernel modification. There are two additional steps:

1) modify the XF86Config file to not wait for TV and something else (I apologize - it is on my system at home - I will post more details tonight)
2) do not boot using the graphical boot screen (i.e. remove rhgb from Grub)


not working :(

cant wait for more details ... :)

Picomp314
11th May 2004, 10:56 PM
follow the howto, if you have specific questions over the instructions then ask...

wshawn
11th May 2004, 11:28 PM
Please write a new howto then link it here so that it will be more readily available to new people needing the info

Picomp314
11th May 2004, 11:35 PM
I get the feeling that klopfest is not actually using Driver 'nvidia' but rather the open source (and inferior for lack of 3D support )Driver 'nv', not having to recompile the kernel is very unusual since these two options are directly incompatible with the driver, and will be until NVIDIA writes new drivers when Fedora Core 2 Final is released

zorroh
12th May 2004, 12:56 AM
my action to get 3d and firewire work:

1) copy the .config file from /usr/src/CurrentKernel/ to /usr/src/NewKernel/ (my new kernel is 2.6.6)
2) gedit .config &
change
- CONFIG_REGPARM=y =>> CONFIG_REGPARM=n
- CONFIG_IEEE1394 is not set =>>
CONFIG_IEEE1394=y
#
# Subsystem Options
#
# CONFIG_IEEE1394_VERBOSEDEBUG is not set
# CONFIG_IEEE1394_OUI_DB is not set
# CONFIG_IEEE1394_EXTRA_CONFIG_ROMS is not set

#
# Device Drivers
#
# CONFIG_IEEE1394_PCILYNX is not set
CONFIG_IEEE1394_OHCI1394=y

#
# Protocol Drivers
#
CONFIG_IEEE1394_VIDEO1394=y
# CONFIG_IEEE1394_SBP2 is not set
# CONFIG_IEEE1394_ETH1394 is not set
CONFIG_IEEE1394_DV1394=y
CONFIG_IEEE1394_RAWIO=y
CONFIG_IEEE1394_CMP=y
CONFIG_IEEE1394_AMDTP=y

and save

3) make && make modules_install && make install

for question about CONFIG_4KSTACKS answer 'n'

4) reboot

5) gedit /etc/X11/XF86Config
comment out the lines saying Load "Dri" and make sure the line Load "glx" exists, find Driver "nv" or Driver "vesa" and replace with Driver "nvidia"

and save

6) shut xserver down with init 3

7) find your nvidia driver
sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

8) startx

(:))

i attach'd my kernel config for i686smp(intel HyperThreading)

big-big thanks to Picomp314 :)

Picomp314
12th May 2004, 12:58 AM
yep... those are the steps from my Howto with the 2.6.6 kernel instead...

klopfest
12th May 2004, 02:02 AM
Under the "device" section, I added:

Option "IgnoreDisplayDevices" "DFP, TV"

Then I removed the rhgb from the grub.conf file (kernel line) and it works now.

3D accel works (glxgears, etc.)

I have not recompiled the kernel...

Hope this helps too (now you have two (2) fixes)

:-)

klopfest
12th May 2004, 02:04 AM
Picomp314 - I am actuall using the compiled driver from NVIDIA (driver name "nvidia"). Please note that I am NOT really smart...just lucky that I got the right combo to work...

Picomp314
12th May 2004, 02:19 AM
interesting... it must be specific to your GeForce model, or something... I do not even have this 'Tv, DFP' option

klopfest
12th May 2004, 02:49 AM
GeForce4 MX 440 is the AGP card I am using. It does have a TV out (which I have never used), however, it does not have a DFP (I am assuming a DFP). I managed to find this fix via google and patience...somebody else posted it on another board.

Finalzone
12th May 2004, 05:11 AM
I did all the above step but the new kernel 2.6.6 boot up a graphical mode when I cannot see the text what confirm the initiating then it froze. What is the good method (VGA or SVGA) to only get the initiatizing text?

kdavison007
12th May 2004, 05:29 PM
So where exactly is the 8k stack vs 4k stack option when compiling kernel 2.6.5? I haven't tried the non-kernel compile fix, but have tried recompiling the kernel and couldn't find any stack options when running make xconfig

foolish
12th May 2004, 06:17 PM
Like I've always said, this will solve itself. But this is a good workaround for people who need 3d acceleration and core 2. Nvidia will most likely fix this after a week or two. This always happens, it happened with Red Hat Linux 9 and it happened before that. It will fix it self, give it some time.

Picomp314
13th May 2004, 09:05 PM
you downloaded the fresh kernel from kernel.org right???

kdavison007
13th May 2004, 09:16 PM
sure did. No stack 4k or 8k option that I see.

Finalzone
13th May 2004, 10:31 PM
I installed kernel 2.6.6 and did all the step above. I figured out the problem about "Kernel Panic". After this step
3) make && make modules_install && make install

for question about CONFIG_4KSTACKS answer 'n'

Configure your grub.conf or lilo config, by replacing "root=/LABEL/" with "root=/dev/your _hd"]. This will prevent kernel panic.

Picomp314
13th May 2004, 10:40 PM
that wasnt a problem for me, maybe your setup is different

kdavis: try opening the file with a text editor and manually searching for it...

kdavison007
14th May 2004, 02:08 PM
Thanks, Picomp, I'll give that a try.

ScubaStreb
19th May 2004, 10:58 AM
2)Download and Install the kernel-source package for the kernel you are currently running i.e. ( 2.6.5-1.327 or similar)

I'm a Fedora newbie, trying out FC2 after using Gentoo for a long time. I like Fedora so far, but this no accelerated graphics thing is giving me fits. I'm trying to follow your howto, and have downloaded the 2.6.5 kernel from kernel.org as well as the source packages corresponding to my kernel, kernel-2.6.5-1.358.src.rpm .

The problem that I'm running into, is how to do the step I quoted above. RPM is greek to me, but when su and try rpm -Uvh kernel-2.6.5-1.358.src.rpm , I get the following error, "error: cannot create %sourcedir /usr/src/redhat/SOURCES .

Any advice on how to overcome this?

Picomp314
19th May 2004, 12:35 PM
make sure you are super user
i.e.
su

ScubaStreb
19th May 2004, 01:14 PM
but when su and try rpm -Uvh kernel-2.6.5-1.358.src.rpm ,

Yes, I was a super user.

Gary
19th May 2004, 04:49 PM
I just want to say a huge "Thanks" to Picomp314. You sir, are a genius. I'd been waiting for core two to be released, hoping upon hope, the nvidia issue would be taken care of. When it wasn't I went ahead and tried your fix. It wasn't nearly as complicated as I thought (anytime I have to mess with the kernel, I get just a tad bit nervous). Thanks to you I now have Fedora core 2 up and running on the modified 2.6.6 kernel with 3d acceleration. Thanks once again.

whitehat
19th May 2004, 07:06 PM
I'm happy I found this

I've been going nuts since I download FC2 yesterday and it did't work with my FX5200, can't wait to recompile the kernel and get it running

thanks for the help guys, I'll report back after recompiling and trying NV drivers

Mad rush at trying to help LC (http://www.linuxcult.com/forum/showthread.php?s=&threadid=6371)

Picomp314
19th May 2004, 09:06 PM
scuba: try changing the command to:
rpm -ivh kernel-2.6.5-1.358.src.rpm

ScubaStreb
19th May 2004, 11:00 PM
2)Download and Install the kernel-source package for the kernel you are currently running i.e. ( 2.6.5-1.327 or similar)

OK, I downloaded the non srpm rpm and was able to accomplish this with the command rpm -ivh --replacepkgs kernel-2.6.5-1.358.i686.rpm .

However, this didn't give me anything in /usr/src.

The only directory there is the one I created for the 2.6.5 kernel sources.

[root@localhost src]# ls
linux-2.6.5

What command did you use to get the old kernel files installed in /usr/src? I'm currently stumped.

Thanks in advance.

Picomp314
19th May 2004, 11:50 PM
I understand what is going on now... There is confusion as to which package you need to get,

the first package you tried was an srpm, which is not what you need...

the second package you tried kernel-2.6.5-1.358.i686.rpm installs the redhat compiled kernel...

what you need are the kernel sources; In your case, "kernel-source-2.6.5-1.358.i386.rpm" is the right package

ScubaStreb
20th May 2004, 12:01 AM
what you need are the kernel sources; In your case, "kernel-source-2.6.5-1.358.i386.rpm" is the right package

AAAhhh, thank you very much. That explains a lot. I'll get this RPM thing sooner or later.... :) I'm used to all source in Gentoo, but this is starting to make more sense now.

Thanks!

ScubaStreb
20th May 2004, 12:58 AM
OK, it's making a lot of sense now. For you guys who are used to RedHat/Fedora, this may be nothing new. However, it was very strange for me.

When you do a fresh install of FC2, if you do a custom package selection, you have to explicitly check a Development Tools checkbox if you want to install the kernel sources and the compile tools. I don't know if this is true for the desktop/workstation/or server pre-configured options, YMMV. I've never seen that stuff taken out by default before - what's the point of using Linux if you can't compile your own stuff??? :)

Anyway, I hope that helps those of you who are coming from another distro or are experiencing problems with this.

Cheers!

theurge
20th May 2004, 02:20 AM
That's why I ALWAYS use "Custom" when installing stuff.

whitehat
20th May 2004, 03:15 AM
no good
I compiled Kernel 2.6.6 from kernel.org source file as instructed with 4K Stacks off

haven't even been able to start x
every time I modprobe nvidia I get the responce that the module will taint my kernel< how od i fix this and get Fedora Core running?

ScubaStreb
20th May 2004, 03:20 AM
OK, it's up and running nicely now. It's great to have accelerated video again since I'm an Enemy Territory junkie and need my daily fix!

A couple of things that weren't in the original howto that may help some people....

After you make and install the new kernel and modules, you should edit your /boot/grub/menu.list to reflect the new kernel. I left old kernel entries there in case the new kernel borked up. Here's my /boot/grub/menu.lst:

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz

title Fedora Core (2.6.5 Vanilla)
root (hd0,0)
kernel /vmlinuz-2.6.5 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5.img


title Fedora Core (2.6.5-1.358)
root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img


Also, it's a good idea, before you edit your /etc/X11/xorg.conf file, to make a backup in case it doesn't work right. I just did cp xorg.conf xorg.conf.old

Happy Accelerated Nvidia!

Cokky27
20th May 2004, 05:53 AM
Ok i'm using 2.6.5-1.358 and I have tried to follow the instructions in this post. However, the .config file was nowhere to be found however there was a configs director, so I simply copied that into the 2.6.5 folder. Then i did the make, make modules_install, make install step. Secondly, I odn't have an XF86Config file, I have a xorg.conf file so I did the proper editing on that. When I originally tried booting into X after installing nvidia drivers the normal way I got a black screen that I couldn't escape from (not in the literal since mind you.) However, after following this how to when booting into X my screen flickered and then produced an error message. I could post the /var/log/Xorg.0.log file if that would be of use. Any help would be extremely appreciated but please spell things out for me because I am obviously a N00B! I am also having the same problem as ^^whitehat.

ScubaStreb
20th May 2004, 07:36 AM
Did you edit your /boot/grub/menu.lst file to point to the new kernel like I did above?

If you didn't, the system is still going to boot off of the original kernel and it won't work.

This is the important portion:

title Fedora Core (2.6.5 Vanilla)
root (hd0,0)
kernel /vmlinuz-2.6.5 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5.img


To edit from the command line, I use a program called nano. It's like Pico so it's a lot easier to use than Vim or Emacs.

As superuser type "nano -w /boot/grub/menu.lst" . Edit the file, hit Crtl + X and then hit Y to save. Reboot with the vanilla kernel entry when Grub prompts you and you're all set.

LordMorgul
20th May 2004, 07:43 AM
see edit below..
Recompiling the kernel-source RPM's source will not work unless you also manually revert the nostack patch on that source. The option for CONFIG_4KSTACKS is removed from that kernel source and will NOT be honored even if you add it to the config.

There is a script at the site below that recompiles the kernel src.rpm after patching the specfile to remove the nostack patch and fixing the configs. The script is not quite complete enough for 'just run it and then install'.. but it will help many of you with understanding what needs to be done.
(I am not the author but comments on how to make it better.. here, will get back to the author).

http://www.lyricnz.com/linux/patches/nvidia/
The script will download the src.rpm if you do not have it in the current directory. Get the patch, place it where the script is.

This option is in case you prefer to use the Fedora kernel rather than the stock kernel (kernel.org0. There are several patches applied still.. even tho this is much lower than it was in RHL (the kernel is getting much closer to stock for Fedora).

<edit>
Have been reliably informed.. rebuild of the src.rpm will not currently work with only the nostack patch being removed. There are other patches present now that conflict (not in compile.. just in operation) so that this is not trivial anymore. It works for kernels up to 2.6.5-1.344. After that.. seems best to just use stock kernels for now, so anyone looking up the above script.. don't bother rebuilding that kernel ;)
</edit>

LordMorgul
20th May 2004, 07:52 AM
Originally posted by whitehat
no good
I compiled Kernel 2.6.6 from kernel.org source file as instructed with 4K Stacks off

haven't even been able to start x
every time I modprobe nvidia I get the responce that the module will taint my kernel< how od i fix this and get Fedora Core running?
You may also need to disable CONFIG_REGPARM.
The messages about a tainted kernel are normal and cannot be removed.. ignore them. If there are other messages displayed those would be interesting. If modprobe succeeds you should see 'nvidia' as an active module in lsmod's output.

ScubaStreb
20th May 2004, 10:12 AM
Recompiling the kernel-source RPM's source will not work unless you also manually revert the nostack patch on that source. The option for CONFIG_4KSTACKS is removed from that kernel source and will NOT be honored even if you add it to the config.

Lord Morgul,

I understood it that he had followed the original instructions and downloaded the 2.6.5 vanilla sources from kernel.org, so that shouldn't be the problem.

Also, with a native FC2 install, there is no more XF86Config. xorg.config is the right one. With an upgrade, the XF86Config file is now useless.

Cheers!

LordMorgul
20th May 2004, 11:25 AM
My previous posts were unrelated, one describes rebuilding using the src.rpm, the other is a suggestion for why the kernel.org attempt didn't work. CONFIG_REGPARM can still be a problematic issue with stock kernel.org builds.

Currently the src.rpm rebuild method is not working for my machine with the -1.358.. so it is only a suggestion for something to try (it worked previously with -1.349... this specific kernel seems not to work). The doesn't mean it will not work on some computers tho.. that I don't know yet.

/etc/X11/xorg.conf is the preferred file but if /etc/X11/XF86Config exists it will be used when the other is not present, so it is not useless.. just deprecated. You are correct that it should be removed and the newer file name used instead.

Picomp314
20th May 2004, 12:38 PM
whitehat: where does it say to 'modprobe nvidia'?????

cokky: the file is hidden if you are in a terminal in /usr/src/linux-2.6.5-1.358 try ls -A

it sounds like bother whitehat and cokky need to reboot into init 3, and run the nvidia installer again

if you want things to work, it is best to follow instructions word for word

Cokky27
20th May 2004, 04:05 PM
The grub automatically picked up on the new kernel and I booted into that one

belthezar
20th May 2004, 04:44 PM
Just wanted to say thanks to the original poster, this got me going again with accelerated video! It's amazing how much snappier even 2d stuff is now. Although I was very thankful to have a working alternative (the nv driver) even if it is un-accelerated.

Now that my video works properly I am really loving FC2! I haven't used red hat on a desktop in quite some time, this is a really slick setup.

s0lus
20th May 2004, 07:37 PM
yeah i have to thank picomp also...

i thought i remembered following his how-to but i now realize that i must not have...

i set up a new kernel (2.6.6) and configured it without the REGPARM and 4K stacks...

my 5900 ultra which used to run glxgears at 240 FPS is now running it at 8300.... big improvement....

thanks picomp, im an idiot, you have pulled me out of a week of frustration....

:D

polly_morf
24th May 2004, 12:49 PM
"4)Copy the .config file from /usr/src/linux-2.6.5-1.327/ to /usr/src/linux-2.6.5/"

Which .config file? Do you mean the .config-file in the config-directory?

LordMorgul
24th May 2004, 08:55 PM
The .config file may not be present in your kernel-source installed directory.. i.e. in /usr/src/linux-2.6.5-1.327. There is a directory in that directory.. named configs that will contain the config you need -- the config is also in the /boot directory.

To copy the config from /boot it would be: /boot/config-2.6.5-1.327
To copy the config from the configs directory: /usr/src/linux-2.6.5-1.327/configs/kernel-2.6.5-1.327.<arch>.config where you substitue <arch> for i686 or i686.smp for example.

If you are unsure what config arch should be used.. copy the config from the /boot directory using:
cp /boot/config-`uname -r` /usr/src/linux

As mentioned below..the 358 config can be optained easily and should be used if possible.. there are more changes from 327 that the 2.6.6 kernel will probably ask about.. better to get the Fedora version for those questions if you don't know what to say

Picomp314
24th May 2004, 09:00 PM
or, if the .config does not exist, go to /usr/src/linux-2.6.5-1.358 and type make oldconfig, which will create a .config file that you can then copy

polly_morf
25th May 2004, 10:27 AM
Originally posted by Picomp314
or, if the .config does not exist, go to /usr/src/linux-2.6.5-1.358 and type make oldconfig, which will create a .config file that you can then copy

And it will be generated to the .config-directory? That was actually the question all along. :P. Thanks anyway... i got the /boot-config file...

Will I have to edit grub.conf?

Picomp314
25th May 2004, 09:54 PM
it should be automatically done by 'make install'

polly_morf
26th May 2004, 10:10 PM
Originally posted by Picomp314
it should be automatically done by 'make install'

Cant i just get myselt the 2.6.6 kernel instead? Shouldnt it be compatible with the Nvidia drivers, or was the incompatibillityissue with att 2.6.x kernels?

LordMorgul
26th May 2004, 10:29 PM
The stock 2.6.6 kernel should work as well.. however the same issue exists with the two config options.

LordMorgul
27th May 2004, 08:39 PM
For anyone still having issues you may be interested in this. There are RPMs of the FC2 release kernel now posted that are built with 8k stacks -- I tested it and it does work on my machine.. but of course YMMV.
you also.. have to decide that you trust the source.. but getting your games back might be worth it

Here is where I first saw this, there are several people reporting it works other than me.
http://www.nvnews.net/vbulletin/showthread.php?t=29208

And for ease.. a direct link to the site hosting the RPMs.
http://www.linuxant.com/driverloader/wlan/full/downloads-fc2-kernel-i686.php

beanie
27th May 2004, 08:51 PM
My first custom-kernel.

answer the questions with no whichs contains experimental things. and the other questions with yes?
i try to fix the problem :)

bye
beanie

zosood
30th May 2004, 07:23 AM
Hey All!
After many hours of research I found an easy fix for the fc2 4 stack problem and the Nvidia driver.
Go to http://www.linuxant.com/driverloader/wlan/full/downloads-fc2-kernel-i686.php
and download their modified "8 stack" kernel, iinstall it , reboot to it, then modify your xorg.conf file to say nvidia instead of nv and voila! I'm a newbie and if I can do it anyone can! :D

kingmaximus
30th May 2004, 04:35 PM
yes that will work but you will lose the NTFS support..........so again recompiling the kernel again :mad: :mad:

ApuX
1st June 2004, 08:43 AM
Yes... how do I get the ntfs support again?

S.D.Willie
5th June 2004, 01:56 AM
Nvidia.com. Should I be downloading the kernel tar file from Nvidia? or the source rpm?

why would you need nvidia's drivers at all if you have a radeon?

Picomp314
5th June 2004, 02:24 AM
what? this is for Nvidia Cards, NOT ATI, duh...

ogetbilo
5th June 2004, 05:35 PM
Originally posted by kingmaximus
yes that will work but you will lose the NTFS support..........so again recompiling the kernel again :mad: :mad:

why don't you convert your windoze partition to vfat?

RichieV
9th June 2004, 05:48 AM
I started trying linux for the first time about 6 months ago and have had no end of trouble getting the Nividia drivers to work, Mandsrake 9.2 nothing happened, not even the Nvidia Splash screen, Xandros, got the splash screen but then mothing, then the splash screen again and so on, Mandrake 10, couldn't even start linusx once i had installed the drivers, finally got to FC2 and I am wondering if i folloe the above procedure I would have any mor luck

I have a GeForce3 Ti500 grafics card and an ASUS Mother board, any suggestions i would like to hear them.

Skunk
9th June 2004, 06:47 AM
Install kernel:
http://www.linuxant.com/driverloader/wlan/full/downloads-fc2-kernel-i686.php

And install Nvidia as usual. It works fine...

(then you dont need to recompile the kernel)


/Skunk

Picomp314
9th June 2004, 10:41 AM
Another side agenda of this howto was to show people how easy compiling a kernel is, and that by going through and 'trimming the fat' you can make your system run much, much faster.

As was stated earlier stock distro kernels are huge becuase they have to have support for so many different types of hardware, many of which you really do not need, and would never see. Don't be squeamish, if you make a bad kernel, your old one will still be there as a backup.

kingmaximus
14th June 2004, 01:41 AM
Hi,

I installed also the special kernel and Nvidia is working. Now I am busy with NTFS....but there is a new kernel......again back to roots. I will try the same procedure. Don't use special available kernels.....instead try to make the one that suites yours situation

kingmaximus
14th June 2004, 01:45 AM
ogetbilo......as you should know..........you cannot go back from NTFS to fat32 / fat..even with partition magic or other software...only option is format c.....

Picomp314
19th June 2004, 09:00 AM
if you like my howto, please add to my reputation
:D :D

onslaught
28th September 2004, 12:51 PM
hi

sorry if my questions are not very intelligent because i'm a absolutely newbie to linux :)

ok i have downloaded fedora core 3 test 2.91 (with kernel 2.6.8-1.541) then i tried to install nvidia driver. it didnt work because of missing kernel source. after some research i figured out to install the kernel source from cd - but there is no such rpm on any of the 3 cds ;)

ok here is my question

if i donwload

kernel-2.6.8-1.521.stk16.i686.rpm.zip and kernel-2.6.8-1.521.stk16.src.rpm.zip
from http://www.linuxant.com/driverloader/wlan/full/downloads-fc2-kernel-i686.php
and install them both with rpm -ihv <rpm package>, the installation of the nvidia drivers should work for me?

LordMorgul
28th September 2004, 08:53 PM
@onslaught
Nope, do not use the 16k stack kernels unless you require them for wireless driver support. The nVIDIA driver should install and be usable without the kernel-source in FC3t2 because the necessary files are present in the kernel rpm now.. the kernel source is not needed. I have not run the installer, but have seen others report that it worked, so I will need to see the nvidia-installer.log file to figure out why it didn't work for you.

This is how I installed the driver now in FC3t2 (2.91). I did not use the normal nvidia installer because I do not like the way it destroys files installed by other RPMs, instead I use the Livna.org package that contains the nVIDIA GL files. Look at this directory listing:
http://rpm.livna.org/fedora/2/i386/RPMS.testing/

The nvidia-glx package contains all the libraries and X extensions for the driver. Get that file and install it (unfortunately we have to break the rules here until they create a kernel module package for the latest testing kernel).
# rpm -i --nodeps nvidia-glx-1.0.6111-0.lvn.2.2.i686.rpm

Provided you did not have other things broken.. the kernel module package should be the only dependency we just ignored.

Then you have to build the kernel module separately and install it, for this use the nvidia installer:
# ./NVIDIA-Linux-x86-1.0-6111-pkg1.run --extract-only
# cd NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv
# make module
# mkdir /lib/modules/`uname -r`/kernel/drivers/video/nvidia
# cp nvidia.ko !$

At this point you have compiled the module, and placed it where it belongs, now just make the kernel aware of it (depmod) and then load it.
# depmod
# modprobe nvidia

<edit> typos corrected, commands should be _valid_ now </edit>

If this all works... and ONLY if all this works... you should then setup the X config file to use the driver, you can do this with a script included in the Livna.org driver RPM.
# nvidia-config-display enable

Good luck. I will look around for info about what might be necessary to use the normal nVIDIA installer as well since that is less complicated. The method I have just shown is a better way to install but requires getting dirty in the way it works.

Sniffer
28th September 2004, 11:54 PM
Will try the method you use...i hope that everything works.

I didn't try the original method...but i have heard that gives some problems...i wonder why it does???!!!!!

Sniffer
29th September 2004, 12:21 AM
[root@a213-22-63-94 ~]# rpm -i --nodeps nvidia-glx-1.0.6111-0.lvn.2.2.i686.rpm
warning: nvidia-glx-1.0.6111-0.lvn.2.2.i686.rpm: V3 DSA signature: NOKEY, key ID a109b1ec
[root@a213-22-63-94 ~]# NVIDIA-Linux-x86-1.0-6111-pkg1.run --extract-only
bash: NVIDIA-Linux-x86-1.0-6111-pkg1.run: command not found
[root@a213-22-63-94 ~]# sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --extract-only
Creating directory NVIDIA-Linux-x86-1.0-6111-pkg1
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 1.0-6111......... .................................................. .............................. .................................................. .............................. .................................
[root@a213-22-63-94 ~]# cd NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv
[root@a213-22-63-94 nv]# make module
Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!

*** Failed rivafb module sanity check, but continuing! ***


NVIDIA: calling KBUILD...
mkdir -p /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.tmp_versions
make -f scripts/Makefile.build obj=/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/ nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /root/NVIDIA-Linux-x86- 1.0-6111-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.nv.o.d -nostdinc - iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigr aphs -fno-strict-aliasing -fno-common -pipe -msoft-float -m32 -fno-builtin-sprin tf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 -fno-unit-a t-a-time -march=i686 -mregparm=3 -Iinclude/asm-i386/mach-default -Os -fomit-fram e-pointer -g -Wdeclaration-after-statement -I/root/NVIDIA-Linux-x86-1.0-6111-pkg 1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wno -cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU _SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_M INOR_VERSION=0 -DNV_PATCHLEVEL=6111 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -D NVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_CLAS S_SIMPLE_PRESENT -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /r oot/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv.o /root/NVIDIA-Linux-x86-1.0-61 11-pkg1/usr/src/nv/nv.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:14,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv-linux.h :52,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arithmeti c
cc -Wp,-MD,/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.os-agp.o.d -nostdi nc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-t rigraphs -fno-strict-aliasing -fno-common -pipe -msoft-float -m32 -fno-builtin-s printf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 -fno-un it-at-a-time -march=i686 -mregparm=3 -Iinclude/asm-i386/mach-default -Os -fomit- frame-pointer -g -Wdeclaration-after-statement -I/root/NVIDIA-Linux-x86-1.0-6111 -pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscri pts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D _GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -D NV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6111 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_ CLASS_SIMPLE_PRESENT -DMODULE -DKBUILD_BASENAME=os_agp -DKBUILD_MODNAME=nvidia -c -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-agp.o /root/NVIDIA-Linu x-x86-1.0-6111-pkg1/usr/src/nv/os-agp.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:14,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv-linux.h :52,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-agp.c:2 4:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arithmeti c
cc -Wp,-MD,/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.os-interface.o.d - nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -pipe -msoft-float -m32 -fno-bui ltin-sprintf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 - fno-unit-at-a-time -march=i686 -mregparm=3 -Iinclude/asm-i386/mach-default -Os - fomit-frame-pointer -g -Wdeclaration-after-statement -I/root/NVIDIA-Linux-x86-1. 0-6111-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-s ubscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DN TRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSIO N=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6111 -DNV_UNIX -DNV_LINUX -DNV_INT 64_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_CLASS_SIMPLE_PRESENT -DMODULE -DKBUILD_BASENAME=os_interface -DKBUILD_MOD NAME=nvidia -c -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-interface.o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-interface.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:14,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv-linux.h :52,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-interfa ce.c:26:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arithmeti c
cc -Wp,-MD,/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.os-registry.o.d -n ostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes - Wno-trigraphs -fno-strict-aliasing -fno-common -pipe -msoft-float -m32 -fno-buil tin-sprintf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 -f no-unit-at-a-time -march=i686 -mregparm=3 -Iinclude/asm-i386/mach-default -Os -f omit-frame-pointer -g -Wdeclaration-after-statement -I/root/NVIDIA-Linux-x86-1.0 -6111-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-su bscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common - MD -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNT RM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION =1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6111 -DNV_UNIX -DNV_LINUX -DNV_INT6 4_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_CLASS_SIMPLE_PRESENT -DMODULE -DKBUILD_BASENAME=os_registry -DKBUILD_MODNA ME=nvidia -c -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-registry.o /r oot/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-registry.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:14,
from include/asm/semaphore.h:41,
from include/linux/sched.h:18,
from include/linux/module.h:10,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv-linux.h :52,
from /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-registr y.c:14:
include/linux/prefetch.h: In function `prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type `void *' used in arithmeti c
ld -m elf_i386 -r -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nvidia.o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nv-kernel.o /root/NVIDIA-Linux- x86-1.0-6111-pkg1/usr/src/nv/nv.o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/n v/os-agp.o


As you can see i can't create directory for nvidia, i have tried manually...but the same error...why? Can you help me?

When running the installer for nvidia, you forgot of the sh command.

Sniffer
29th September 2004, 12:22 AM
here is the installation continue

/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-interface.o /root/ NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/os-registry.o
Building modules, stage 2.
make -rR -f /lib/modules/2.6.8-1.541/build/scripts/Makefile.modpost
scripts/mod/modpost -i /lib/modules/2.6.8-1.541/build/Module.symvers /root/NV IDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nvidia.o
cc -Wp,-MD,/root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/.nvidia.mod.o.d -no stdinc -iwithprefix include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -W no-trigraphs -fno-strict-aliasing -fno-common -pipe -msoft-float -m32 -fno-built in-sprintf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 -fn o-unit-at-a-time -march=i686 -mregparm=3 -Iinclude/asm-i386/mach-default -Os -fo mit-frame-pointer -g -Wdeclaration-after-statement -DKBUILD_BASENAME=nvidia - DKBUILD_MODNAME=nvidia -DMODULE -c -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/s rc/nv/nvidia.mod.o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nvidia.mod.c
ld -m elf_i386 -r -o /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nvidia.ko /root/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv/nvidia.o /root/NVIDIA-Linux-x86 -1.0-6111-pkg1/usr/src/nv/nvidia.mod.o
NVIDIA: left KBUILD.
[root@a213-22-63-94 nv]# mkdir /lib/module/`uname -r`/kernel/drivers/video/nvidi a
mkdir: cannot create directory `/lib/module/2.6.8-1.541/kernel/drivers/video/nvi dia': No such file or directory
[root@a213-22-63-94 nv]# mkdir /lib/module/uname -r/kernel/drivers/video/nvidia
mkdir: invalid option -- r
Try `mkdir --help' for more information.
[root@a213-22-63-94 nv]# mkdir /lib/module/`uname --r`/kernel/drivers/video/nvidia
mkdir: cannot create directory `/lib/module/2.6.8-1.541/kernel/drivers/video/nvidia': No such file or directory
[root@a213-22-63-94 nv]# mkdir /lib/module/uname --r/kernel/drivers/video/nvidia
mkdir: unrecognized option `--r/kernel/drivers/video/nvidia'
Try `mkdir --help' for more information.
[root@a213-22-63-94 nv]# mkdir/lib/module/`uname -r`/kernel/drivers/video/nvidia
bash: mkdir/lib/module/2.6.8-1.541/kernel/drivers/video/nvidia: No such file or directory
[root@a213-22-63-94 nv]# mkdir /lib/module/`uname -r`/kernel/drivers/video/nvidia
mkdir: cannot create directory `/lib/module/2.6.8-1.541/kernel/drivers/video/nvidia': No such file or directory
[root@a213-22-63-94 nv]# cp nvidia.ko !$
cp nvidia.ko /lib/module/`uname -r`/kernel/drivers/video/nvidia
cp: cannot create regular file `/lib/module/2.6.8-1.541/kernel/drivers/video/nvidia': No such file or directory
[root@a213-22-63-94 nv]#

Picomp314
29th September 2004, 12:27 AM
you do NOT need the sh command ./command is sufficient if the file has been chmoded +x properly
what ever you are doing it is WAY too involved
in your case i suggest you just download the relevant package from either dag's or the atrpm repository, i can't remember which one it is

Sniffer
29th September 2004, 12:36 AM
mkdir: cannot create directory `/lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia': File exists

1st - is not module but modules

[root@a213-22-63-94 ~]# mkdir /lib/module/`uname -r`/kernel/drivers/video/nvidi a
mkdir: cannot create directory `/lib/module/2.6.8-1.541/kernel/drivers/video/nvi dia': No such file or directory
[root@a213-22-63-94 ~]# mkdir /lib/modules/`uname -r`/kernel/drivers/video/nvidia
mkdir: cannot create directory `/lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia': File exists
[root@a213-22-63-94 ~]# cp nvidia.ko !$
cp nvidia.ko /lib/modules/`uname -r`/kernel/drivers/video/nvidia
cp: cannot stat `nvidia.ko': No such file or directory
[root@a213-22-63-94 ~]# mkdir /lib/modules/`uname -r`/kernel/drivers/video/nvidia
[root@a213-22-63-94 ~]# cp nvidia.ko !$
cp nvidia.ko /lib/modules/`uname -r`/kernel/drivers/video/nvidia
cp: cannot stat `nvidia.ko': No such file or directory
[root@a213-22-63-94 ~]# cp nvidia.ko !$
cp nvidia.ko /lib/modules/`uname -r`/kernel/drivers/video/nvidia
cp: cannot stat `nvidia.ko': No such file or directory
[root@a213-22-63-94 ~]# cd /lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia
[root@a213-22-63-94 nvidia]# cp nvidia.ko !$
cp nvidia.ko /lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia
cp: `nvidia.ko' and `/lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia/nvidia.ko' are the same file
[root@a213-22-63-94 nvidia]# cp nvidia.ko !$
cp nvidia.ko /lib/modules/2.6.8-1.541/kernel/drivers/video/nvidia
cp: cannot stat `nvidia.ko': No such file or directory
[root@a213-22-63-94 nvidia]# depmod
[root@a213-22-63-94 nvidia]# modprobe nvidia
[root@a213-22-63-94 ~]# nvidia-config-display enable
[root@a213-22-63-94 ~]#

Ok after some workaround, like manually pass nvidia.ko everything works.

Thanks for your work but next time try to check carefully what you wrote...because to some members this could be very annoying try to installl and solve problems all the way...sorry for the long posts.

Picomp314
29th September 2004, 01:20 AM
it seemed to me that my howto worked for everybody else
i think you are doing something "FAR TOO COMPLICATED"
as i said above

" download the relevant package from either dag's or the atrpm repository, i can't remember which one it is"

this howto is not exactly necessary anymore as it is, because the nvidia drivers (as of 6106) support 4kstacks in the kernel
this howto was mainly designed to provide a workaround for that particular problem
because you are using a standard official FC kernel you can install the rpms without any hassle and simply modify
/etc/X11/xorg.conf

also, hopefully you will actually read my post this time.

LordMorgul
29th September 2004, 09:03 AM
There are two quality sources for nVIDIA rpms for Fedora.. Livna.org and ATrpms. The livna package has not been built for this fc3t2 kernel version, but the ATrpms package has been. The link is below. I prefer the livna package and scripts and so I use them instead, despite requiring the kernel module build separately.. but Picomp314 has a good point, if its too complicated use another method.

http://atrpms.net/dist/fc2/nvidia-graphics/
http://atrpms.net/dist/common/nvidia-graphics-helpers/

@Sniffer: I fixed two additional typos in my instructions, I apologize for them. As you found out I left the s off 'modules' and the extraction requires a local path. I hope your system is up and running nicely now.

Sniffer
29th September 2004, 09:45 AM
it seemed to me that my howto worked for everybody else
i think you are doing something "FAR TOO COMPLICATED"
as i said above

" download the relevant package from either dag's or the atrpm repository, i can't remember which one it is"

this howto is not exactly necessary anymore as it is, because the nvidia drivers (as of 6106) support 4kstacks in the kernel
this howto was mainly designed to provide a workaround for that particular problem
because you are using a standard official FC kernel you can install the rpms without any hassle and simply modify
/etc/X11/xorg.conf

also, hopefully you will actually read my post this time.


I have read all your posts :)...now , i was just testing the tut from your friend nothing more, nothing less now that i know i can install the normal way.
I'm very happy that finally i have found a true Fedora Forum and now i think i will be a true fedora user.
I hope that you will be around when i'm in trouble :confused: ;)

JTM_88
5th October 2004, 08:04 AM
I got my NVIDIA driver to work! No kernel rebuilds!

background:
GPU: NVIDIA GeForce 2 Ti
CPU: PII-MMX
Mainboard: ASUS P2L97 (made in 1997)
OS: Fedora Core 2

Solution:
download NVIDIA-Linux-x86-1.0-6111-pkg1.run
$ chmod 700 NVIDIA-Linux-x86-1.0-6111-pkg1.run
$ NVIDIA-Linux-x86-1.0-6111-pkg1.run
install required dependencies (I used yum and installed a whole bunch of stuff, like all the libc and related language libraries (other libc* stuff).
$ yum upgrade
take 10 minutes to a few hours depending on amount of stuff

$ yum info
Here is where I picked out a bunch of libs and cc,gcc,g++ stuff.

$ yum install libstdc++ binutils ...... long list ......

now I was sure my NVIDIA install would not break halfway through (has happened to me while installing other programs which lead to system wipe)

then
$ init 3
change to non-graphic login
$ edit /etc/X11/xorg.cong
your X configuration file may be something like /etc/X11/XFConfig/XF86XConfig or
/etc/X11/XFConfig/XF86XConfig-4
find the Section "Device" with Identifier "Videocard" (near end of file)
comment out the line (use the "#" to comment)
Driver "nv"
add line under that
Driver "nvidia"

find the section "Module" (near beginning of file)
comment out the line
Load "dri"

now do
$ NVIDIA-Linux-x86-1.0-6111-pkg1.run

for me, it needed to download and build the module. I let it and it worked just fine.

Then, using LordMorgul's advice I did
$ depmod
$ modprobe nvidia

then start a graphical user session
$ startx
or you could do
$ init 5
which puts your at run-level 5

Good luck :)

momendo
21st October 2004, 06:49 AM
@onslaught
Nope, do not use the 16k stack kernels unless you require them for wireless driver support. The nVIDIA driver should install and be usable without the kernel-source in FC3t2 because the necessary files are present in the kernel rpm now.. the kernel source is not needed. I have not run the installer, but have seen others report that it worked, so I will need to see the nvidia-installer.log file to figure out why it didn't work for you.

This is how I installed the driver now in FC3t2 (2.91). I did not use the normal nvidia installer because I do not like the way it destroys files installed by other RPMs, instead I use the Livna.org package that contains the nVIDIA GL files. Look at this directory listing:
http://rpm.livna.org/fedora/2/i386/RPMS.testing/

The nvidia-glx package contains all the libraries and X extensions for the driver. Get that file and install it (unfortunately we have to break the rules here until they create a kernel module package for the latest testing kernel).
# rpm -i --nodeps nvidia-glx-1.0.6111-0.lvn.2.2.i686.rpm

Provided you did not have other things broken.. the kernel module package should be the only dependency we just ignored.

Then you have to build the kernel module separately and install it, for this use the nvidia installer:
# ./NVIDIA-Linux-x86-1.0-6111-pkg1.run --extract-only
# cd NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv
# make module
# mkdir /lib/modules/`uname -r`/kernel/drivers/video/nvidia
# cp nvidia.ko !$

At this point you have compiled the module, and placed it where it belongs, now just make the kernel aware of it (depmod) and then load it.
# depmod
# modprobe nvidia

<edit> typos corrected, commands should be _valid_ now </edit>

If this all works... and ONLY if all this works... you should then setup the X config file to use the driver, you can do this with a script included in the Livna.org driver RPM.
# nvidia-config-display enable

Good luck. I will look around for info about what might be necessary to use the normal nVIDIA installer as well since that is less complicated. The method I have just shown is a better way to install but requires getting dirty in the way it works.


If you are using the new 2.6.9 kernel, the module won't compile. You have to edit nv.c
http://00f.net/blogs/index.php/2004/09/16/nvidia_kernel_module_and_linux_2_6_9_rc2/

Which states:
Once and again, the nvidia kernel module doesn't compile with recent kernels.

On 2.6.9-rc2-mm1 kernels, in addition to these fixes, you now have to edit usr/src/nv/nv.c and add at the beginning of the file:

unsigned int __VMALLOC_RESERVE = 128 << 20;

Then recompile and it should work again.

Joe

Gaya Instagram Photos - Buenos Aires Photos on Instagram - Kantyshevo Photos on Instagram